Possible blue screen fix

Discussion in 'Videocards - AMD Radeon' started by Del_Boy, Jul 25, 2010.

  1. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    I have cured the blue screen plague on my pc, this may or may not work for you.

    Ever since moving over to ati in dec 09' ive had relentless blue screens but only while game play, after many hard drive formats and google searches i proceeded to wipe my pc of anything nvidia and i was surprised how much nvidia stuff was unintentionally on there, i used driver-sweeper to scan for nvidia chip set and sure enough there was, so this was purged, i remembered having to install physx for medal of honor airborne and 3d mark vantage so both programs were shown the back door and any remnants of physx where cleansed using driver-sweeper, i then uninstalled ati drivers restarted and ran driver sweeper again, then defragged (i use o&o defrag) then my reg-cleaner (pc securityshield) and then booted in safe mode, i ran the reg cleaner again also driver-sweeper again, rebooted normally and installed latest drivers. (Iam sure these extra steps where not really necessary but it makes you feel better) and there we have it, 4 weeks later and not one blue screen to speak of !
     
    Last edited: Jul 26, 2010
  2. mitzi76

    mitzi76 Ancient Guru

    Messages:
    8,722
    Likes Received:
    19
    GPU:
    MSI 970 (Gaming)
    congrats! well i did the same. well did a fresh os install and format and then only installed physx when necessary. worked for me.
     
  3. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    some kind of conflict going on (secret nvidia vs ati program warfare hush hush)
     
  4. Omagana

    Omagana Ancient Guru

    Messages:
    2,532
    Likes Received:
    1
    GPU:
    RTX 2070 Super
    Good to hear,

    Stuff like this happens ALL the time and ATI just get automatically blamed...
     

  5. isidore

    isidore Ancient Guru

    Messages:
    6,276
    Likes Received:
    58
    GPU:
    RTX 2080TI GamingOC
    well it started happening to me, i reinstalled windows and still random bsod's when gaming, now i installed drivers 10.5 used driver cleaner before installing..i'll search for physx drivers..and uninstall them too, i hope, i'll fix this annoying issue..

    edit_1: just checked for nvidia chipset and physx drivers, and what do you know, i had in the registry nvidia chipset drivers..WTF!! my last nvidia motherboard or gpu was like 3 years ago..

    edit_2:still blue screens after 10-15 minutes of playing, i've even updated the mobo bios to the last, retested my cpu for unstable oc, still blue screens, finally after reinstalling the original 10.1 driver that came with my card, i played for like 30-45 minutes and no blue screen, for the love of God ati, what are you doing to the drivers..

    man i hate when from nowhere **** starts to happen..like this blue screens..
     
    Last edited: Jul 26, 2010
  6. Del_Boy

    Del_Boy Banned

    Messages:
    457
    Likes Received:
    0
    GPU:
    MSI R9 290 (2560x1600)
    Yeah definitely get rid of that nvidia bloat software even if it means uninstalling a whole program or two.
     
  7. phill1978

    phill1978 Master Guru

    Messages:
    715
    Likes Received:
    0
    GPU:
    Saphire 1GB 5850@840/1140
    i blue screened since installing physx of course i have 5850 but metro wont play without it installed ??

    might ditch metro and physx now
     

Share This Page