Physx9.11.1107 and UT3 problem

Discussion in 'Videocards vs General Purpose - NVIDIA Ageia PhysX' started by ati666, Nov 13, 2011.

  1. ati666

    ati666 Master Guru

    Messages:
    465
    Likes Received:
    0
    Graphics Card::
    Gigabyte R9-290x Windforc
    Physx9.11.1107 and UT3 GPU-physx broken

    hi

    i just installed physx 9.11.1107 with quadro 270.51 x64 drivers.

    i know UT3 has GPU-physx support, in the past it used to work. but now physx i always stuck on cpu. whats going on?

    how can i force enable GPU-physx in UT3 againg with quadro270.51 win7x64 and physx software 9.11.1107?

    thanks
     
    Last edited: Nov 13, 2011
  2. TheHunter

    TheHunter Banned

    Messages:
    13,412
    Likes Received:
    0
    Graphics Card::
    MSi N570GTX TFIII [OC|PE]
    chose your gpu instead of auto detect?

    Or chose manually in UT3 profile..


    Also you might want to repair Physx installer (right-click on installer and chose repair).
     
  3. ati666

    ati666 Master Guru

    Messages:
    465
    Likes Received:
    0
    Graphics Card::
    Gigabyte R9-290x Windforc
    none of it works.
    what hould i do now?
     
  4. TheHunter

    TheHunter Banned

    Messages:
    13,412
    Likes Received:
    0
    Graphics Card::
    MSi N570GTX TFIII [OC|PE]
    Then it really is physx compatibility issue with older drivers..


    either update to 285.xx (if 285.62 causes trouble then try either 285.58Q or 285.67 parallel Insight) or downgrade physx to PhysX_9.11.0621_SystemSoftware :pc1::nerd:
     

  5. GenClaymore

    GenClaymore Ancient Guru

    Messages:
    5,928
    Likes Received:
    2
    Graphics Card::
    GTX 1080 FE @ 2ghz+VG248
    It only works with the physX map pack that Epic had released, The rest of the maps that comes with the game does it with the cpu.
     
  6. ati666

    ati666 Master Guru

    Messages:
    465
    Likes Received:
    0
    Graphics Card::
    Gigabyte R9-290x Windforc
    problem solved, looks like physx9.11.1107 has a serious bug which cripples gpu-physx in games.

    after reverting back to physx 9.11.0621, the gpu-physx came back in ut3 and metro2033.

    so, i highly recommend any one not to install physx9.11.1107, since it has a bug which will disable your gpu-physx and you will be stuck on cpu-physx all the time no matter what you do.
     
  7. Spets

    Spets Ancient Guru

    Messages:
    2,939
    Likes Received:
    0
    Graphics Card::
    GTX 1080Ti FTW3 SLI
    It didn't work because as TheHunter stated, 9.11.1107 isn't compatible with older drivers. Same thing happened to me so I went back to using the latest beta.
     
  8. ati666

    ati666 Master Guru

    Messages:
    465
    Likes Received:
    0
    Graphics Card::
    Gigabyte R9-290x Windforc
    which beta are you using?
     
  9. Spets

    Spets Ancient Guru

    Messages:
    2,939
    Likes Received:
    0
    Graphics Card::
    GTX 1080Ti FTW3 SLI
    285.79, it's working great for me so far
     
  10. applejack

    applejack Master Guru

    Messages:
    576
    Likes Received:
    0
    Graphics Card::
    MSI GTX 1070 GAMING X
    I'm using PhysX 9.11.1107 alongside geforce driver 290.39 beta,

    my problem is with Batman Arkham City, when setting GPU PhysX in game (Medium or High) and running its benchmark - game crashes right after a couple of seconds ingame.
    no problems with physx OFF.

    I know Batman AC use Unreal Engine as well... so I'm going to try the previous physx driver :cry:

    Edit: confirmed, changing back to PhysX 9.11.0621 solved crashing for Batman AC with GPU PhysX.
     
    Last edited: Dec 14, 2011

  11. yosef019

    yosef019 Ancient Guru

    Messages:
    2,060
    Likes Received:
    0
    Graphics Card::
    MSI 980 4G Gaming @1500
    i dont know my gpu handle high physx in batman alham city
    im on 290.56
    No single problem that i noticed in this driver or games
     
  12. applejack

    applejack Master Guru

    Messages:
    576
    Likes Received:
    0
    Graphics Card::
    MSI GTX 1070 GAMING X
    right, I forgot to update my previous post. installing 290.56 did solve the problem, works fine now w/ latest physx system software.
     
    Last edited: Jan 7, 2012

Share This Page