PhysX setting help

Discussion in 'Videocards - NVIDIA GeForce' started by iain martin, Mar 21, 2011.

  1. iain martin

    iain martin Member

    Messages:
    47
    Likes Received:
    0
    GPU:
    R9 390 8GB
    Evening guys,

    What should I set the physx setting to in the Nvidia control panel?

    I have a single gtx580 & wanted to know if i should set that as the default physx device or my cpu (2600k @ 5GHz)

    it doesnt seem to make much difference either way, only in Kombuster benchmark which, by the way, gives me higher results when i force CPU physx (in kombuster, not nvidia control panel)

    any input would be greatly appreciated. i am not sure if it makes any real difference to any of the games i play (AC brotherhood, warhead, etc...)

    thanks guys :)
     
  2. Copey

    Copey Ancient Guru

    Messages:
    10,710
    Likes Received:
    0
    GPU:
    960 2GB
    It only benefits games if they are designed to use the cpu, leave the physX settings to the defualt in the NVCP.

    Games Like Mafia 2 and Batman AA are 2 examples of hardware physX driven games.
     
  3. Redemption80

    Redemption80 Ancient Guru

    Messages:
    18,492
    Likes Received:
    265
    GPU:
    GALAX 970/ASUS 970
    Set it to GPU for the time being.

    Kombuster is using a mutli-threaded version of PhysX as far as i know, so CPU and GPU performance can be pretty similar, no games have used this so far, so you will likely get poor performance if you try and run Mafia2 with it forced to CPU.

    Also, Brotherhood and Warhead will be unaffected anyway.
     
  4. The Phoenix

    The Phoenix Maha Guru

    Messages:
    1,247
    Likes Received:
    53
    GPU:
    Gigabyte RTX 3070
    yeah set it to gpu
     

  5. ESlik

    ESlik Ancient Guru

    Messages:
    2,412
    Likes Received:
    20
    GPU:
    EVGA x2 1080 Ti SC Black
    I need help too. When I set my physx selection to 'auto',it shows GPU 2. When I exit the control panel and then re-open the control panel,it shows GPU 1. Why won't my phsyx setting stay where I had it? With every new driver for the 580s, the physx setting reverts from auto [which shows gpu 2] to GPU 1. Does it even make a difference? What setting would you use? GPU 1 or 2? Thanks.
     
    Last edited: Mar 21, 2011
  6. BlooHook

    BlooHook Master Guru

    Messages:
    441
    Likes Received:
    0
    GPU:
    EVGA GTX 1080 FTW SLI
    The reason that is because you set it to auto so the drivers select which GPU is wants to use. Usually it picks which card to use based on which one is crunching less data. If you want it to use the same GPU all the time, you've gotta check that box says dedicate GPU. If you do, usually the second card is a good choice cause it normally gets stressed less than the main card.
     
  7. Zboe

    Zboe Master Guru

    Messages:
    533
    Likes Received:
    0
    GPU:
    GALAX GTX 970
    On my system the numbering is "backwards". Meaning that my GTX 460 is GPU 2 even though it is my primary card and my 8800GT is GPU 1 even though it is my secondary card and has no monitor hooked to it.
     
  8. mr_47

    mr_47 Member Guru

    Messages:
    120
    Likes Received:
    0
    GPU:
    GBY GTX1070 ti gm
    set to gpu all the time
     
  9. ESlik

    ESlik Ancient Guru

    Messages:
    2,412
    Likes Received:
    20
    GPU:
    EVGA x2 1080 Ti SC Black
    When I set the Physx to 'auto select',it shows GPU 2. As long as I don't re-boot it will stay like that. After a reboot or when I start up my PC, the setting always goes back to GPU 1. When I manualy set it to GPU 2 it will stay like that no matter the re-boot or start up. This happens with all drivers above 258.96. I just need to know if it's normal for my settings to revert or switch the GPU physx settings. Will it do harm in any way? Is it my PC?
     

Share This Page