Performance Issue's

Discussion in 'Videocards - NVIDIA GeForce' started by Noosey, Mar 8, 2008.

  1. Noosey

    Noosey New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Nvidia 9600GT 512MB
    hi i have recently upgraded my system to 4gb ram from 2gb, upgraded from a 8300gs to a 9600gt

    when i play Medieval 2 total war in a battle the game slows right down to almost freezing point

    im not a total computer newb but cant figure out what can be causing this if anybody can share some suggestions to solve this for me ill be over the moon

    1 other thing to note is my sytem overall total memory is 3326MB is that right for 4gb

    thanks in advance :)
     
  2. shades3k

    shades3k Maha Guru

    Messages:
    1,116
    Likes Received:
    1
    GPU:
    ATI 4870 512MB
    As you've upgraded your graphics card from nvidia to nvidia I'd ask if youve properly removed the nvidia drivers and then installed them again with your new card in?

    If you are using 32bit Vista then that's why you can only see 3.3GB of ram. You'd need the 64bit version of vista to see/use it all. If you're on 64 bit vista try this...

    "Check the BIOS for the Memory Remap option for 64 bit OS's. Enabling
    that option will remap the hardware addresses from GB 3-4 to GB 4-5,
    freeing all 4 GB for use by RAM." from the first google search result.
     
    Last edited: Mar 8, 2008
  3. dukedave5200

    dukedave5200 Ancient Guru

    Messages:
    3,192
    Likes Received:
    0
    GPU:
    BFG GTX 285 OCX - SLI
    Make sure you resinstall the drivers cleanly. Might want to use Driver Sweeper in safe mode to remove the remaining driver files after you uninstall them. You could also try reinstalling the game after reinstalling the drivers if that doesn't affect anything.

    32bit operating systems will not give you all 4GB. This is a very well known issue and is normal. For a system to use 4gb or more ram you need a 64bit OS.
     
  4. Noosey

    Noosey New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Nvidia 9600GT 512MB
    thanx lads i only unistalled the drivers from control panel then installed new card and drivers

    also thinking back now when i had installed the drivers first from the point of view disc supplied with the card and restarted my pc when it loaded up the computer froze i had to restart

    ill do as suggested and do a clean uninstall of drivers then reinstall

    should i install drivers from the point of view disc or nvidia webby?

    also my computer can support a 64bit os should i upgrade to 64 from 32 xp pro

    would my computer be faster becasue of being able to utilize all 4gb ram

    im running win xp pro sp2

    ok just uninstalled from control panel restarted then run driver sweeper, restarted, installed new drivers,reinstalled the game and am just going to test how things are now
     
    Last edited: Mar 8, 2008

  5. Noosey

    Noosey New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Nvidia 9600GT 512MB
    just finished testing and i still have the same problem, alltho it is noticably better it still lags right down when a few minutes into battle

    im completly lost as to what could be causing this?

    is my psu good enough? for the gfx card
     
  6. PredatorX64

    PredatorX64 Member

    Messages:
    47
    Likes Received:
    0
    GPU:
    HD4850 + 9600GT Physx
    Try to remove old driver in add/remove program. then restart.

    Next you need to get new Nvidia Driver 169.21 install this driver then check it at your device manager.
     
  7. Noosey

    Noosey New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Nvidia 9600GT 512MB
    i have the latest nvidia drivers which are 174.16

    i also play counter strike source and get a average fps of 120-140 and see highs of 200 and over sometimes

    im also playing assasins creed and the game so far has played smooth

    in medieval total war 2 the game slows right down when there are to many in battle i mean actually clashed together and fighting, the battle starts ok and everything runs smooth then as soon as they clash together they lag up and slow down, i do have the unit selection in the options on the game set to huge but would of thought a 9600 and 4gb ram would of played great
     
    Last edited: Mar 8, 2008
  8. Noosey

    Noosey New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Nvidia 9600GT 512MB
    any1 else have any ideas for the cause of this problem?

    is my 650W psu enough for the gfx card to run optimal, it only has 20A on the 12V rail im not sure what a 9600 requires?
     

Share This Page