performace lotro 4870x2

Discussion in 'Videocards - AMD Radeon' started by Selo, Jan 22, 2009.

  1. Selo

    Selo Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    XFX GTX295
    hey

    im getting very low fps with my 4870x2 (Q6600@3,2gghz)

    my friend with 8800gts SLI is getting more fps (i7 920@stock)

    the more people that are around the more my card loose in fps and it drops alot when theres special effects around

    im using 8,12 drivers

    [​IMG]


    ingame picture, dont know why its so dark :p its not even crowded where i am and it will drop lower when more peoples show up

    [​IMG]
     
  2. tukm

    tukm Member Guru

    Messages:
    151
    Likes Received:
    0
    GPU:
    ATI Radeon X1800XT 512MB
    let me guess. vista 64bit?
     
  3. esidyo

    esidyo Member Guru

    Messages:
    154
    Likes Received:
    0
    GPU:
    Asus Radeon EAH4850 T0P
    Maybe the game likes nvidia more, as i7 920 and Q6600 don't have tooo much of difference, and 4870x2 is far better than 8800GTS SLi

    Did you guys test other games like GTA IV also?
     
  4. hallryu

    hallryu Don Altobello

    Messages:
    11,387
    Likes Received:
    14
    GPU:
    2x HD7970
    He has Vista 64 in his signature, you don't have to guess!

    Is this happening in any other game? Have you tried running the game without your overclock? have you got the latest updates for the game? (Sorry never played it) What about heat? Have you got adequate airflow in your case? Do you have a good fan profile?

    I have noticed with some very quick searched on google that some folks with graphical anomalies solved there problems by running the game on Dx9 mode. Have you tried that?
     
    Last edited: Jan 23, 2009

  5. Miller

    Miller Master Guru

    Messages:
    740
    Likes Received:
    0
    GPU:
    EVGA 660ti Signature FTW
    What FPS are you actually getting? I have a similar computer to you and don't have any FPS problems, unless there are a lot of people on screen; however, I think that's largely down to latency from everyone's combined connection?

    I think my screen ratio is set to auto, maybe try that? I have a 16:10 screen and Vista 64 too btw
     
  6. Selo

    Selo Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    XFX GTX295
    if theres more people it drops below 20 fps

    i have vista 64 yes, and 4x120mm fans for airflow
     

Share This Page