PC X1650XT - Checkers effect in Quake Wars

Discussion in 'Videocards - AMD Radeon' started by MrIbra, Jul 31, 2007.

  1. MrIbra

    MrIbra Master Guru

    Messages:
    246
    Likes Received:
    0
    GPU:
    XFX HD 7770 1GB
    Hi!

    Installed my new PowerColor X1650XT a few days ago. Had a similar one of the HIS brand, which got replaced by this one because of a defective cooler.
    Haven't had the time to try out too many apps more than 3DMark01/03/05/06, some Battlefield 2 and the new World in Conflict Beta.
    Everyting seemed fine and the temperature stayed around 50 C (122 F) after a few hours of gaming. But when i loaded up Quake Wars things weren't as promising any longer.

    A couple of Quake Wars screenshots that show some kind of "checkers effect":

    http://hem.bredband.net/ibra/QW_Rutor.gif
    http://hem.bredband.net/ibra/QW_Rutor2.gif

    Can't try different drivers because the brand wasn't supported by ATI until recently in the latest version of Catalyst (7.7). I checked the RAM for errors in memtest and fortunately the testing went good. My old card worked fine with Quake Wars, but at the time i was using Cat 7.4.

    What can be causing this?
    All help appreciated. :)

    UPDATE:
    Managed to revert back to Cat 7.2 and the checkers pattern vanished! :)
    But I can't recall that QW ran this sluggish.

    //MrIbra
     
    Last edited: Aug 1, 2007
  2. TheWheelman

    TheWheelman Master Guru

    Messages:
    819
    Likes Received:
    0
    GPU:
    Asus96GT512 700/1800/1100
    Check to make sure that CrossFire isn't accidentally on.
    That could cause this.
    Otherwise, does it do this with other programs?
     
  3. InfDaMarvel

    InfDaMarvel Ancient Guru

    Messages:
    3,218
    Likes Received:
    0
    GPU:
    HD3850 256mb
    Is that the only game, could deal with the game. Might wanna try 7.8 betas.
     
  4. dudecat64

    dudecat64 Ancient Guru

    Messages:
    3,768
    Likes Received:
    11
    GPU:
    xfx 5700xt 8gig
    Seems weird that your x1650xt is only supported with newer drivers. I thought the x1650xt been out for atleast the 7.4 cats. I would say it is more likely a driver issue.
     

  5. PhatKat

    PhatKat Banned

    Messages:
    3,782
    Likes Received:
    0
    GPU:
    Hawk 5770 1.02G/1.4G H2O
    I'm gonna say drivers on this one. Maybe uninstall/reinstall them, that should help.
     
  6. MrIbra

    MrIbra Master Guru

    Messages:
    246
    Likes Received:
    0
    GPU:
    XFX HD 7770 1GB
    The other named games i've tried haven't had these kind of symptoms, but I believe that shadows looks kind of pixelated/messy if that is related somehow.

    Under normal Windows operation (Win Vista x32), there's not even a sign of instability.

    It's not that the X1650XT model itself isn't supported, but the PowerColor brand version wasn't supported by the the official drivers until Cat 7.7. As strange as it may seem.

    I might actually do that.
    Any links to them?

    //MrIbra
     
    Last edited: Aug 1, 2007

Share This Page