PC seems to boot but no display

Discussion in 'General Hardware' started by amieneel, May 6, 2012.

  1. amieneel

    amieneel Master Guru

    Messages:
    896
    Likes Received:
    0
    GPU:
    XFX 5770 + 240 GT PhysX
    hi all,
    a few days ago when i turn on my pc there is no display is coming, but after few second i can here that sound while desktop is appear. that means my pc is booting properly but display is not coming. i cleaned and spewed ram slot changed power(6 pin) of my gpu. then i booted up and it worked fine .. but today again the same problem appeared !!
    so my question is what could be the problem? is my gpu is dying ? or bios problem? (bios is up-to-date though).
     
  2. clawhamer

    clawhamer Ancient Guru

    Messages:
    2,576
    Likes Received:
    0
    GPU:
    EVGA 780 Classified
    Does it still happen if you remove the PhysX card?
     
  3. amieneel

    amieneel Master Guru

    Messages:
    896
    Likes Received:
    0
    GPU:
    XFX 5770 + 240 GT PhysX
    yes .. Problem persist ..
     
  4. tanner314

    tanner314 Master Guru

    Messages:
    257
    Likes Received:
    0
    GPU:
    Sapphire Tri-X R9 290 4GB
    Make sure in your bios that you have PCI-E enabled and not Integrated or Try using integrated graphics and installing your display driver. Then change your settings back to PCI-E
     

  5. clawhamer

    clawhamer Ancient Guru

    Messages:
    2,576
    Likes Received:
    0
    GPU:
    EVGA 780 Classified
    You could disconnect all devices from the MB, leaving only necessary components to complete post (cpu, ram, VC, psu). While everything is disconnected, clean any dust from the devices and slots, clear cmos, and reset the cpu.

    You could also remove 5770 and run the 240 as main to see if the display comes on for post. It may help give you an idea if it’s the VC or MB

    If you have another computer (or a friend’s computer) you could test the 5770 in it as well.

    Do you have another psu to test with?
     
  6. Mufflore

    Mufflore Ancient Guru

    Messages:
    12,779
    Likes Received:
    1,325
    GPU:
    Aorus 3090 Xtreme
    If you have it plugged into another display (like a TV), it may be defaulting to the wrong screen.
    Or you may have a bad connection or faulty/too long HDMI cable.
     

Share This Page