PC lockup when gaming after mining unless I reboot

Discussion in 'Videocards - AMD Radeon' started by dove, Mar 17, 2014.

  1. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    I've found that if I've been mining with CGminer, which OCs my 6950 to 880/1350 and never gives any HW errors and then stop it and play a game, it will inevitably lockup after maybe 30-60mins. It doesn't BSOD, just everything freezes as it is, so the last frame is stuck on the screen and sometimes the audio gets stuck in a ms loop but tends to just go silent and I have to hard reset.

    When I stop CGMiner, it drops the clocks back to the default 800/1250 but MSI Afterburner has the 3D profile set to 850/1300 so it uses that when gaming. None of the overclocks change the voltage. I'm using an Accelero Xtreme III heatsink and the temps stay below 70c when mining and even lower when gaming.

    If I reboot after stopping CGMiner and then play a game, I never have any problems so I'm sure it's not a HW fault. Perhaps something needs resetting after mining, so I'm wondering if there's any way to do this without rebooting, as even with a SSD it's still a pain having to close everything?

    Anyone got any ideas what the problem might be or how to fix it?
     
  2. seaplane pilot

    seaplane pilot Maha Guru

    Messages:
    1,295
    Likes Received:
    2
    GPU:
    2080Ti Strix
    Always have to reboot after stressing the GPUs, does not take long to reboot.
     
  3. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    Doesn't seem to make much sense. I don't have to reboot after gaming, which stresses the GPU, or running benchmarks, which stress the GPU, only after mining to prevent it locking up when I try gaming, which stresses the GPU less than mining so it would seem more logical that it would lockup if I left it mining (which it never has) than when under the lesser stress of gaming.

    As I said, it's a pain having to reboot regardless of how long it takes.
     
  4. seaplane pilot

    seaplane pilot Maha Guru

    Messages:
    1,295
    Likes Received:
    2
    GPU:
    2080Ti Strix
    Mining and other GPU computing stresses a GPU more than benchmarks and gaming. If you are to lazy to reboot to solve the issue than try disabling each GPU and then enable them again.
     

  5. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    Yes I know that mining stresses the GPU more than those other things. Hence why I said it doesn't seem to make much sense that it would only lock-up when trying to do something less stressfull, like playing a game and not when mining.

    If you're too lazy to read (see, it's not very nice being called names is it and if you'd bothered to read, you'd see I explained why I'd prefer not to reboot and it's nothing to do with being "lazy") then perhaps forums aren't really the right place for you.
     
  6. Pvfc-Epic

    Pvfc-Epic Maha Guru

    Messages:
    1,188
    Likes Received:
    0
    GPU:
    ASUS GTX560Ti DirectCU II
    why do you need to close everything before clicking reboot?

    windows closes all programs for you, yeah you need to close open windows or text files ect.. but everyday software that runs with windows closes during the reboot process
     
  7. Ripshod

    Ripshod Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    HIS HD7950 FAN 3GB
    The way I understand it mining doesn't just tweak the clocks. Apparently it makes changes to vRAM timings and stuff. Just because the clocks drop back when you close it doesn't mean the vRAM timings are restored.
    I think you're falling foul of these 'tweaks' and mining is to blame!!
     
  8. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    I don't have to close everything manually of course, I just mean it's a pain if I have a number of tabs open in IE or documents in OpenOffice, etc that it's a pain to have to reboot and lose all that, when I could happily leave them open and play a game and then have them there still when I finish playing.
     
  9. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    That might make sense. I don't know enough about it to say it does but it sounds plausible I guess ;)

    I actually installed Win8.1 to have a fresh Windows to see if it would improve my fps in ArmA3 (sometime it goes down to 15fps or lower), which it didn't but my PC actually locked up whilst playing, even though I'd never mined under Win8 or even installed any mining software. I think it was the OC I set in Afterburner, at 880/1350 which is obviously not stable on my card. I checked in Win7 and I have it set to 850/1300 there for gaming (I use 880/1350 for mining no problem), which never locks up unless I haven't rebooted after mining.

    I guess I should disable the 3D OC so that games play at the default 800/1250 and see if that stops it locking up after mining. 850/1300 works fine if I've rebooted but maybe the combination of mining then gaming at those clocks causes the lockups, whereas gaming at 800/1250 may not. I doubt I'm getting much benefit from OCing to 850/1300 anyway.
     
  10. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    I've also found another issue, in that if I've been gaming and then try and start mining, it's stuck at 20-30KH/s instead of the usual 480KH/s and I have to reboot to fix that as well. I didn't have this issue until recently and frequently restarted mining after I stopped playing games, so this is strange.

    I guess I could try logging out and back in as well to see if that fixes it but that will still involve closing any open apps/windows, so that's not really any better than rebooting.

    Is there any way to reset the GPU, other than disabling/enabling it in Device Manager which I'm worried might cause issues (not least, how will it display anything for me to see if I disable it?).
     

  11. seaplane pilot

    seaplane pilot Maha Guru

    Messages:
    1,295
    Likes Received:
    2
    GPU:
    2080Ti Strix
    Just reboot your PC it is so simple, and no there is no other way to reset the GPUs other than a reboot or disable/enable them in DM.

    I have been mining almost 2 years, take some advice from someone that has experience.

    Also sometimes the .bin file the mining software creates gets corrupt and you have to delete it and let the mining software create a new one.

    Try another mining software maybe cgminer 3.7.2 or the Kalroth version of cgminer.

    http://k-dev.net/cgminer/

    Just reboot your PC and you will have no problem, I do it every time I stop my miners on my gaming rig when I want to game.
     
  12. Vindaloo

    Vindaloo Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    R7850 2Gb CF 1000/5000
    I reboot my pc after running ANY game, with an ssd it takes 15-20 secs down time, serious whats wrong with a quick reboot?
     
  13. dove

    dove Master Guru

    Messages:
    312
    Likes Received:
    0
    GPU:
    Powercolor 6950 2GB
    It actually takes anywhere from 53-90s to boot my PC even with a SSD and that's just from the time Windows starts to boot, so doesn't include the shutdown, POST and boot menus (although I can skip the latter by pressing Enter quickly).

    The BootPostBootTime varies between 28-50s and MainPathBootTime from 18-53s. No doubt it's slowed down a bit by having My Documents on the HDD and having to parse that but so many things dump their files in there that it's impractical to have it on the SSD as it would take too much space.

    Anyway, if I have to reboot after mining to prevent games crashing, so be it, I was just hoping there was a way to avoid it, as it's a pain.
     

Share This Page