PatchScript for FireGL 8.293

Discussion in 'RivaTuner Advanced Discussion forum' started by huangyanhao, Oct 8, 2006.

  1. potkan

    potkan New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    HD2900Pro 512MB
    WinXP
     
  2. cedmar

    cedmar New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire X1950XT 256
    i have a problem,

    i use this script on a sapphire X1950XT

    Code:
     
    The SoftFireGL for R5XX is this:
     
    [Common]
    SrcFile = ati2mtag.sys
    BakFile = ati2mtag.old
    HlpFile = SoftR9x00.rth
    MakeCRC = 1
    Packed = 1
     
    ;common script for 663X+
     
    DstVar0 = force FireGL 3300 capabilities
    DstVar1 = force FireGL 5200 capabilities
    DstVar2 = force FireGL 7350 capabilities
    DstVar3 = force MOBILITY FireGL V5200 capabilities
    DstVar4 = force MOBILITY FireGL V7200 capabilities
    DstVar5 = force MOBILITY M54GL capabilities
     
    Src0 = 81 FA 00 80 00 00 75 16 A9 00 00 00 08 74 0F A9 00 00 00 10 75 08
    Dst0 = 81 FA 00 80 00 00 90 90 A9 00 00 00 08 90 90 A9 00 00 00 10 90 90
     
    Src1 = 83 F8 40 75 1D 66 81 BD 00 00 FF FF 02 10 75 00 0F B7 85 FE FE FF FF 
    SCM1 = FF FF FF FF 00 FF FF FF 00 00 FF FF FF FF FF 00 FF FF FF FF FF FF FF 
    Dst1_0 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 52 71 66 89 85 FE FE FF FF 90
    Dst1_1 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D DA 71 66 89 85 FE FE FF FF 90
    Dst1_2 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 0F 71 66 89 85 FE FE FF FF 90
    Dst1_3 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D C4 71 66 89 85 FE FE FF FF 90
    Dst1_4 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 03 71 66 89 85 FE FE FF FF 90
    Dst1_5 = 0F B7 85 FE FE FF FF 66 25 00 00 66 0D 44 71 66 89 85 FE FE FF FF 90
     
    Src2 = FF 74 24 08 E8 83 75 FF FF A8 04 75 0B 6A 2E
    Dst2 = FF 74 24 08 E8 83 75 FF FF A8 04 90 90 6A 2E
     
    Src3 = 85 BE B4 00 00 00 75 3A 6A 3C
    Dst3 = 85 BE B4 00 00 00 90 90 6A 3C
     
    Src4 = E8 90 93 FF FF 85 C0 74 2E 
    Dst4 = E8 90 93 FF FF 85 C0 90 90
     
    Src5 = E8 E0 50 FF FF F6 C4 20 74 08
    Dst5 = E8 E0 50 FF FF F6 C4 20 90 90
     
    Src6 = 85 C0 74 2F 50 8B 47 04
    Dst6 = 85 C0 EB 2F 50 8B 47 04
     
    Src7 = 8A 85 04 FF FF FF
    Dst7 = B0 80 90 90 90 90 
    
    --------------------------------

    Code:
    DriverVer=09/08/2006, 8.293.0.0
    --------------------------------

    Code:
     
    Browsing for file ati2mtag.sys
    compressed file selected
    Depacking ati2mtag.sys
    succeeded
    Browsing for file ati2mtag.sys
    selected unknown version, 1060201 bytes
     
    Using native patch installation mode 0
     
    WARNING: Certified patch script not found,
    using common patch script
     
    ERROR: Target sequence must be replaced 1 time(s)!
    81 fa 00 80 00 00 75 16 a9 00 00 00 08 74 0f a9 00 00 00 10 75 08
    


    it's normal ???

    What is amusing is that the source does not value in the file ati2mtag.sys
     
    Last edited: Nov 13, 2007
  3. cedmar

    cedmar New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire X1950XT 256
    It's good I find the 8,263 same problem with rivatuner but it works
     
  4. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,469
    Likes Received:
    1,482
    May I ask _how_ can it work if the log clearly says that the patch script processing engine have not applied _any_ changes to the miniport? Stop fooling yourself, that's a placebo effect.
     

  5. oklakla

    oklakla New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI 1950 Pro SCS Edition
    Hello,

    I’m posting because it seems to me I have done something wrong. Please, excuse me if I make some english mistakes because I’m German native speaker and I will give my best !

    History:

    I bought a new pc with a 1950 pro scs

    installed windows
    installed rivatuner
    choose script for 1950 pro
    pasted the script to a text file and saved it and changed the extension of the text file to rts -double clicked on it.
    selected ati2mtag.sys file from where I have extracted the firegl driver files
    installed patched driver
    windows show firegl 7350

    BUT:

    No more performance… It is not a big deal because I’m a student… I have enough time but less money…

    My real problem is that the “photo rendering module” from Catia V5 doesn’t work. I’m only getting a black picture instead a rendered picture 

    I do not need more performance but I need the render from Catia V5. Since my Quadro 3400 has crashed I´m lost!

    If anybody could help me to become the render module from Catia to work in any way (without new card, please) I would be very happy.

    In order to do something for the community of this forum I could translate some text files into german if somebody wants that…

    Please help me!

    Christian
     
  6. baldino

    baldino New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    geforce 7600gt
    need tha 2.293 driver please

    hi ! i would like to mod my x1600 xt in a v5200 but i cannot find the driver anywhere !! Do you know where to find it ? Or can somebody send it to me ? Please !!
     
  7. bubbatt77

    bubbatt77 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    x1950pro
    Hi .Im from turkey. ı have a x1950pro 256 and x64 windows os.I wanna try to mod to firegl 7350 .but ı read all forum posts .I have some problem to make mod because oklakla says no more perforrmance.But cosmyco says its great.ı wanna try in 32 bit windows.((sorry for my bad english).ı dont know anythink about modding (forexample ı dont know how to change extension name:))).can any one tell me that how ı can mod x1950pro 256 to firegl 7350 .or give me a link including step by step explanations.
     
  8. aggiebroz

    aggiebroz New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    ATI HD 4870
    Anybody know if there is a way to try and make this work on the new HD38xx cards, I would really love to use my 3850 512MB with firegl.
     
  9. LTD

    LTD New Member

    Messages:
    5
    Likes Received:
    0
    well im sitting in front of my mac pro with a x1900xt and i cant get it work

    i downloaded the 8.293 and the 8.263 drivers, i tried all scripts i found - nothing worked. the applications are as slow as usual and others say no opengl driver found...

    could someone pls help me? it drives me nuts! thx a lot

    btw. im using winxp 32
     
  10. cavallipurosang

    cavallipurosang Member

    Messages:
    26
    Likes Received:
    0
    Did anyone try to mod these cards in Vista? Would be scripts the same?
     

  11. cavallipurosang

    cavallipurosang Member

    Messages:
    26
    Likes Received:
    0
    Ehy guys, nothing yet for xp x64?
     
  12. aleix

    aleix Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    saphire 3870. 8GB ram
    hey guys,

    could anyone upload the CX_.....inf. file to work with a mod from mobility x1600 to mobility firegl v5200 ???

    i can't manage to make it work without this file correctly.

    thanks
     

Share This Page