PatchScript for FireGL 8.293

Discussion in 'RivaTuner Advanced Discussion forum' started by huangyanhao, Oct 8, 2006.

  1. daimon

    daimon Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    ATI Radeon X1600 > pro FireGL V5200
    This is what I get from the X1600pro that was modify to Fire GL 5200, I think that its too low to be called a FireGL plus I have some weird redraw problems with maya 7 interface, Maya 8 is unusable with the default X1600pro, So you guys don't even bother to use it if you have that card.

    maya-02 Viewset
    -------------------------------------------------------------------------------
    Test Weight Frames DLB Visual Double Frame Buffer Depth Stencil
    # Per Sec Sec ID Buffer Red Green Blue Alpha Buffer Buffer
    -------------------------------------------------------------------------------
    1 11.00 40.9 N/A 5 True 8 8 8 8 24 8
    2 11.00 26.2 N/A 5 True 8 8 8 8 24 8
    3 11.00 19.8 N/A 5 True 8 8 8 8 24 8
    4 11.00 67.4 N/A 5 True 8 8 8 8 24 8
    5 12.00 70.4 N/A 5 True 8 8 8 8 24 8
    6 11.00 16.5 N/A 5 True 8 8 8 8 24 8
    7 11.00 13.0 N/A 5 True 8 8 8 8 24 8
    8 11.00 12.9 N/A 5 True 8 8 8 8 24 8
    9 11.00 37.8 N/A 5 True 8 8 8 8 24 8
    -------------------------------------------------------------------------------
    maya-02 Weighted Geometric Mean = 28.25
     
  2. ferdel1973

    ferdel1973 New Member

    Messages:
    1
    Likes Received:
    0
    patch script for 8.293 64 Bit

    Hey!
    Thanks for the great work doing all these scripts for the community!
    Just one thing - I need a working script for x1xx but I want to use 64bit drivers.
    the actual script doesnt work...
    Would you be so kind to help me and change the script for me? Or give me some links so I can try to do it myself?
    thank
    ferdel
     
  3. plof123

    plof123 New Member

    Messages:
    3
    Likes Received:
    0
    what about x1950 pro?? is it possible to mod?
     
  4. huangyanhao

    huangyanhao Member

    Messages:
    45
    Likes Received:
    0
    use this scirpt ,it could be mod too

    [Common]
    SrcFile = ati2mtag.sys
    BakFile = ati2mtag.old
    HlpFile = SoftR9x00.rth
    MakeCRC = 1
    Packed = 1

    ;common script for 663X+


    Src0 = 81 FA 00 80 00 00 75 16 A9 00 00 00 08 74 0F A9 00 00 00 10 75 08
    Dst0 = 81 FA 00 80 00 00 90 90 A9 00 00 00 08 90 90 A9 00 00 00 10 90 90

    Src1 = FF 74 24 08 E8 83 75 FF FF A8 04 75 0B 6A 2E
    Dst1 = FF 74 24 08 E8 83 75 FF FF A8 04 90 90 6A 2E

    Src2 = 85 BE B4 00 00 00 75 3A 6A 3C
    Dst2 = 85 BE B4 00 00 00 90 90 6A 3C

    Src3 = E8 90 93 FF FF 85 C0 74 2E
    Dst3 = E8 90 93 FF FF 85 C0 90 90

    Src4 = E8 E0 50 FF FF F6 C4 20 74 08
    Dst4 = E8 E0 50 FF FF F6 C4 20 90 90

    Src5 = 85 C0 74 2F 50 8B 47 04
    Dst5 = 85 C0 EB 2F 50 8B 47 04

    Src6 = 8A 85 04 FF FF FF
    Dst6 = B0 80 90 90 90 90
     

  5. huangyanhao

    huangyanhao Member

    Messages:
    45
    Likes Received:
    0

    my friend,it's a little difficult
    i don't know if someone have made it
    we don't have the link too
     
  6. plof123

    plof123 New Member

    Messages:
    3
    Likes Received:
    0
    Thanx, huangyanhao.
    As soon as I get x1950 pro, I will try it.
     
  7. drcosinus

    drcosinus New Member

    Messages:
    2
    Likes Received:
    0
    Using 8.293 drivers on an X300 (Blue screen of death)

    Hi,

    I tried installing the new (8.293) drivers on my (desktop) Radeon X300 using a slightly modified version of the first script in this thread. I tried to guess the parameters for the X300 based on some older posts, and ended up with:

    DstVar7 = force FireGL V3100 capabilities
    Dst1_7 = 0F B7 85 FE FE FF FF 66 25 F0 FF 66 0D 04 00 66 89 85 FE FF FF FF 90

    which installed fine, but I get a BSOD when windows try to use them.

    Does anybody know what the correct patch is?
    Also, If I get these to install, will I be able to turn on Quad Buffered stereo?

    Any help would be greatly appreciated!
     
  8. plof123

    plof123 New Member

    Messages:
    3
    Likes Received:
    0
    well, I tried to mod my x1950pro to firegl v7350 with this script. drvier was moded. but specview score was low. It was not working properly in maya. the other problem is no application tab, just driver tab in CP.
     
    Last edited: Nov 5, 2006
  9. Kurei

    Kurei New Member

    Messages:
    2
    Likes Received:
    0
    For those who have softmoded their ATI radeons. Are there any artifacts when cadding or gaming on moded cards; more than normal radeon use or more than normal cad card use?
     
  10. phusho

    phusho Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    x600 64mb
    No artifacts. Moded x600->v3200 I have tried Solid Edge, Quake, Unreal, and several other games and programs
     

  11. photon0

    photon0 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    HIS X1650pro AGP 256MB
    Can I try my 'HIS X1650pro AGP 256MB' with 'X1XXX' script above ?
     
    Last edited: Nov 10, 2006
  12. photon0

    photon0 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    HIS X1650pro AGP 256MB
    I tried but not working for me.

    Maybe I should try hardware tunning.
    Would you let me know how to?
    or recommend me a good site?
    I am not joking.

    Thank you.
     
    Last edited: Nov 11, 2006
  13. photon0

    photon0 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    HIS X1650pro AGP 256MB
    For me ,
    This softFireGL is working on Windows XP.
    But not working on Windows 2003.
    I use google earth openGL to check.

    On Windows XP, google earth openGL is working on ATI Radeon driver, needlessly FireGL driver. No soft mod necassary already.

    I wish this information could help.

    Anyway Thank you.
     
    Last edited: Nov 11, 2006
  14. AlecRyben

    AlecRyben Ancient Guru

    Messages:
    7,774
    Likes Received:
    0
    GPU:
    5x580 2x590 2x780Ti 1x970
    You have to enable 3D acceleration in Windows 2003 server manually. It's disabled by default (since it's designed as a server OS)
     
  15. photon0

    photon0 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    HIS X1650pro AGP 256MB
    OK , I'll try.

    May take some time, that I have to install OS.
     

  16. Scruples

    Scruples New Member

    Messages:
    1
    Likes Received:
    0
    x800

    on my x800 pro

    ati2mtag.sy_ is the closest thing i can find to ati2mtag.sys

    so i patched that instead and it seemed to work......
    yes im using 8.293

    anyone confirm?
     
  17. CROiga

    CROiga Member

    Messages:
    23
    Likes Received:
    0
    Hi all!
    according to http://ati.amd.com/developer/vendorid.html there`s one FireGL equvalent to R480 chip (radeon x850xt) and it is FireGL7200 (R480GL chip) - (theres also FireGL7200 based on R520GL chip)
    Is there any possible way to mod my X850xt to FireGL 7200 (R480GL) ?

    I managed to mod it to FireGL 7100, based on R423GL chip, but sure it should be better if it could be moded to 7200 (R480GL)
    I found huangyanhaos scripts for R520 based 7200, but I need R480 based 7200
    can it be done?
    can anybody help me with a script,...?
    maybe to include FireGL 7200 (R480GL device ID 7104 / 7124 secundary) to huangyanhaos x4xx script?
    that would be great

    thanks

    ps. you can mail me to imajer@inet.ht
     
    Last edited: Nov 19, 2006
  18. CROiga

    CROiga Member

    Messages:
    23
    Likes Received:
    0
    double post sorry...
     
    Last edited: Nov 19, 2006
  19. hitman273

    hitman273 New Member

    Messages:
    1
    Likes Received:
    0
    i have tried the skript from huangyanhao(thanks huangyanhao),and my mobility x700 now is mobility fireGL V5000,but nothing change. The result of cinebench and Specview is even lower my x700. In control of V5000 i saw advanced setting.
    what i must do to make my x700 @ V5000 get better result?
    thanks in advanced
     
  20. Neonlajt

    Neonlajt New Member

    Messages:
    1
    Likes Received:
    0
    Hey man, you seem to know alot! good someone is still helping out with the softmodding. But I wonder, is it possible to revert the action? Softmod an ati mobility fireglv5200 to a mobility x1600?

    The clocks on my Ati mobility Firegl v5200 is 425/465. I would love to boost my performance in games, cus as of now, I get low fps rates with the original and Omega (it detects Firegl).

    I know this card is ment for Rendering, and not gaming, bad choice on my side. But still, as people can softmod the x1600 to my card, then it should be possible to softmod it back ?

    Friendly regards
    Jan-Erik
     

Share This Page