P4 Hyperthreading

Discussion in 'Processors and motherboards Intel' started by dude420, Nov 7, 2005.

  1. dude420

    dude420 Member Guru

    Messages:
    111
    Likes Received:
    0
    GPU:
    eVGA 7600GT KO
    Can someone help me out? I am looking for an application that will disable hyperthreading in windows. I don't want to disable it through the BIOS. Also I've seen articles say Win2k Pro does/doesn't support hyperthreading. Whats the word guru's?
     
  2. JohnMaclane

    JohnMaclane Ancient Guru

    Messages:
    4,824
    Likes Received:
    0
    GPU:
    8800GTS 640mb
    why would you want to disable it?
     
  3. dude420

    dude420 Member Guru

    Messages:
    111
    Likes Received:
    0
    GPU:
    eVGA 7600GT KO
    Well Win2k Pro seems to take a huge performance hit with it enabled. Office hangs/crashes and once HT is turned off the problems go away. I've searched through google and found nothing. C'mon gurus....
     
  4. JohnMaclane

    JohnMaclane Ancient Guru

    Messages:
    4,824
    Likes Received:
    0
    GPU:
    8800GTS 640mb
    HT is not the reason to such performance hits? its actually meant to speed things up!

    well theres only one location: BIOS
     

  5. TeaEtchSee

    TeaEtchSee Master Guru

    Messages:
    717
    Likes Received:
    0
    GPU:
    XFX 7950gt (Winfast a400gt RIP)
    bios is the only I know how aswell
     
  6. dude420

    dude420 Member Guru

    Messages:
    111
    Likes Received:
    0
    GPU:
    eVGA 7600GT KO
    I understand the concept of HT, but unfortunately it does not work that way in Win2k Pro.
     
  7. Nasgul

    Nasgul Master Guru

    Messages:
    288
    Likes Received:
    0
    GPU:
    BFG 9800GTX 512MB 700/11
    LIke this:

    **************[​IMG]***********


    Being Core 0 as the main (logical) core, I'd say run everything you want with that one and uncheck Core 1.
     
    Last edited: Nov 9, 2005
  8. mike_995

    mike_995 Master Guru

    Messages:
    305
    Likes Received:
    1
    GPU:
    ATI X1900 XT
    You can also unistall the multiprocessor driver in device manager and install the uniprocessor driver.
     
  9. alanm

    alanm Ancient Guru

    Messages:
    10,843
    Likes Received:
    2,918
    GPU:
    Asus 2080 Dual OC
    This would be too big of an issue not to be mentioned in Microsofts Knowledge Base. Theres 1000's of W2K systems with P4 HT's, so if you cant find any reference to this in MSKB, then its likely only an issue with your W2K system.
     
  10. Sapart

    Sapart Member Guru

    Messages:
    105
    Likes Received:
    0
    GPU:
    MSI 7600GS 256MB
    I don't understand why you have HT enabled on system with Win2k, this OS doesn't support HT: http://www.intel.com/cd/channel/res.../proc_dsk_p4/technical_reference/36016.htm#os
    "Operating System Support
    Intel recommends Hyper-Threading Technology for systems with Microsoft Windows XP Professional and Home versions or certain versions of Linux. These operating systems support and have optimizations for Hyper-Threading Technology. Service Pack 1 (or higher) for Windows XP must be installed to ensure full support for Hyper-Threading Technology. Certain versions of Linux will need to be updated (with available patches), in order to ensure support for Hyper-Threading Technology.

    Other operating systems such as Microsoft* Windows* 95, Windows* 98, Windows* 98 SE, Windows* NT 4, Windows* 2000, Windows* ME, and OS/2* do not support Hyper-Threading Technology for Intel processor-based systems. When using any of these operating systems, Hyper-Threading Technology must be disabled in the BIOS settings to ensure proper compatibility with the Intel processor..."
    In your spec. there is XP - do you have 2 OS on your comp and you want to use HT when starting XP? I see the only way - disable HT in the bios.
     

Share This Page