OverdriveNTool - tool for AMD GPUs

Discussion in 'Videocards - AMD Radeon' started by tede, Aug 6, 2017.

  1. doctorman

    doctorman New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    rx5700
    trying to set the profile for RX 5700 BIOS moded
    with Wattman I can put

    P2 at 1431Mhz and 791 mV

    but when I set that through the OverdriveNtool the mV gets set at 1031 instead
    all other values apply correctly

    Would appreciate some help on this
     
  2. tkoucinauci

    tkoucinauci New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Vega 64 / 8GB
    Hi there, is there a older version of the driver that work with ODNT and RX5600XT for setting voltage? Like @doctorman posted above all is set but not voltage undervolt. Thank you!
     
  3. hihello

    hihello New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    5700xt
    This is how I solved voltage resetting on OverdriveNTool for my 5700's and 5700 xt's.

    I tried to create a script for my mining rig where after Windows restart OverdriveNTool would oc/uv my cards before launching miner software (as it is known that they tend to sometimes reset after a crash and this results in drawing too much power for example).

    However, some cards wouldn't give in and would reset the voltage to some random number after clicking "apply". I found out on this forum that the culprit is the new driver. So I found a combination that works for me:

    OverdriveNTool 0.2.9.0
    win10-radeon-software-adrenalin-2020-edition-20.4.2-apr23


    When I installed the older 20.4.2 driver and also disabled Windows updates, "AMD Crash Defender Service" and "AMD External Events Utility" through services.msc I can finally use my little .bat script to auto-overclock and launch the miner without any problems after a Windows crash.

    I just noticed that I cannot launch Adrenaline anymore as it says that my drivers and AMD software do not match. Maybe it is because my AMD reinstall wasn't completely clean as I did not delete the old AMD directory but who cares, I do not need it anymore.
     
  4. OnnA

    OnnA Ancient Guru

    Messages:
    13,486
    Likes Received:
    3,435
    GPU:
    3080Ti VISION OC
    AMD External Events Utility - is used by Freesync (i think, so leave it alone).
    To totally disable AMD Crash Defender Service You need to Disable System Device also (in Device manager).
     

  5. hihello

    hihello New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    5700xt
    You are correct about Freesync, I forgot to mention that since I only use my cards for mining.
     
  6. flaviowolff

    flaviowolff Member

    Messages:
    24
    Likes Received:
    7
    GPU:
    XFX 7600GT 256MB
    Hello, is the software planned to receive an update soon? voltage control is broken for drivers newer than 20.5.1.
     
  7. flaviowolff

    flaviowolff Member

    Messages:
    24
    Likes Received:
    7
    GPU:
    XFX 7600GT 256MB
    Try adrenalin 20.5.1. It's the latest driver that works fine with overdriventool.
     
  8. MaxMidnite

    MaxMidnite Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI RX580
    Hey guys, is this project dead? Im using the 0.30 beta and feels stable, but wondering if we get further updates for newer drivers?
     
  9. flaviowolff

    flaviowolff Member

    Messages:
    24
    Likes Received:
    7
    GPU:
    XFX 7600GT 256MB
    looks like it, sadly
     
  10. OnnA

    OnnA Ancient Guru

    Messages:
    13,486
    Likes Received:
    3,435
    GPU:
    3080Ti VISION OC
    Best for Vega is 0.2.9 Beta 1
     

  11. cts

    cts Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    5700XT x2
    I have two systems, each with two 580s and two systems with one 580 each. I've been mining a number of years now without a hitch but recently I've run into an issue where the two systems with two 580s would halt loading ONT if ran from a batch file at system startup unless the user logged in. Conversely, the two single 580 systems continue to work. To get around this I discovered the -consoleonly command where if added it now loads and Phoenix is off to the races.

    overdriventool.exe -consoleonly -r0 -r1 -p0"A" -p1"A"

    This was a great fix and coincidentally it fixed both systems which had the same fault nearly the same day however there now is another issue where GPU0 is not set but GPU1 will. I have tried the following:

    -r0 -p0 : No effect

    -p0 : No effect

    -r1 -p1 : GPU1 set

    -r1 -r0 -p1 -p0 : GPU1 set, not GPU0

    So I'm at a loss and not sure what to do as it does this in both systems. I have tried drivers 19.12.1, 20.4.2, and 20.5.1 as mentioned above as being a very popular version. I've tried ONT 0.2.8, 0.2.9 and Poisson's 0.3B RBRT 2.2.5 version, all with the same result. Any ideas?
     

Share This Page