OverdriveNTool - tool for AMD GPUs

Discussion in 'Videocards - AMD Radeon' started by tede, Aug 6, 2017.

  1. Kelg

    Kelg Guest

    interesting. I skipped the part with the double click in the initial post of yours. Thanks for pointing that out. It is helpful and works, kind of...
    On the newest driver I have a bug that causes the core clock to become unstable and clocks down wildly to +-800 mhz. (This happens with events related to DXVA.) Disable all states except one, didnt fix the problem, though.


    The command line utilization is extremely helpful! Thanks for implementing that feature. I made a small workaround with a batch file that applies regularly the clock settings (different profiles) with your tool.

    A little critic: it would be more helpful if you can add a visual hint that let the user activate/disable the Pstates. Something like a checkbox beside the Pstate. Double click is not really intuitive.

    This is an excellent tool to apply Wattman setting without the need to open the ugly and slow Wattman UI. I will keep suggest this tool in the future.
     
    Last edited by a moderator: Aug 18, 2017
  2. tede

    tede Guest

    Thanks for all good words. I was thinking about checkboxes for Psates, but this would add to much mess to the gui, also this is not commonly used feature, and most users don't need to disable any state, so i finally decided for double click.
    I must update first post with the info about this feature because many people skip changelog
     
  3. Kelg

    Kelg Guest

    and add a Readme.txt ... and put the version number in the window title... and use PNG for the preview pic...

    yeah, i am just glad i could fix that stupid driver bug.
     
    Last edited by a moderator: Aug 18, 2017
  4. chronek

    chronek Guest

    can not get right voltage with this tool, trying set to 0.9V and it end with 1.1V ... btw wattool had offset settings, did you plan provide that option too? cause any voltage set in power state was moddified by it...
     

  5. Kelg

    Kelg Guest

    have you tried to reset in Wattman and then use this tool?
     
  6. linkfor

    linkfor Guest

    Having tested on several PCs I now cannot confirm the sorting is OK. It was OK on first PC and different on the second one. (same motherboards but GPUs are different.

    In regard to the voltage control - it did work on some of the Rx480 but not all of them. Did not work on Rx580 Red Devil.

    Don't know if I can help further. Had to revert to Afterburner 4.4 beta 16 to make things work with the new drivers. :bang:
     
  7. wiak

    wiak Guest

  8. chronek

    chronek Guest

    lol offset and phase working in old wattool, now i get some good results, i like overdrive powerstate disabling, can test voltage on specific powerstate in hwinfo before running miner
     
  9. tede

    tede Guest

    What gpu? maybe 1.1V is minimal value?
    Offset feature in WattTool is still working. I'm not going to add this, or monitoring to OverdriveNTool.
    Would be great if you try beta for kosho (page 1) which has sorting by Bus number, on different PCs.
    Strange.. Wattman worked for them? When you changed voltage was it changed in wattman too, and not used by the driver?
    Thanks @wiak I will update 1'st post
    I2C uses different ADL funtions which weren't changed by AMD for ages, and i don't think they will change them in the nearest future. There would be sooner produced new voltage controller incompatible with WatTool
     
  10. linkfor

    linkfor Guest

    The beta for Kosho works well for my PCs. Fixed the sorting.

    @kosho - please confirm it works for you too.
     

  11. tede

    tede Guest

    Thanks for the info. Here is 0.1.6beta1 for you to test on those not working gpus
     
  12. linkfor

    linkfor Guest

    Cant get it working for some RX480. The interesting thing is that this is a 6 GPU machine: 5 of the same type RX480 (White Asus 4G) and one different RX480 (Asus strix 8G). The 8G one seems to accept the voltage settings but the 4G not.

    Image here

    (using AMD beta blockchain driver)
     
    Last edited by a moderator: Aug 18, 2017
  13. Hurtman

    Hurtman Guest

    With Beta Blockchain driver working?
    i have a rig 6x480 8 gb
     
  14. TigraSan

    TigraSan Guest

    First, thanks for promising tool

    Got problem:
    "Failed to set gpu clocks" and memory clocks on all cards
    Used "beta blockchains drivers". Tried administrator mode as well

    No AB installed
    Clean install of drivers via device manager after removal with DDU + drivers patch
    Bios has patched values for clocks/voltage. (but not the values i intend to use, just safe low fallback values for cases of crash)

    Cards are rx 470 nitro 4g (not plus)
    Any advice? Willing to run some debug build if this helps
     
  15. Metroid

    Metroid Guest

    What happened to the new messages?
     

  16. tede

    tede Guest

    There is lost lats days forum database, they will restore it from backup or not.
    In the meantime, I installed 17.8.1 and good news for WattTool fans: it's back alive again! :)
     
  17. Metroid

    Metroid Guest


    Let's hope they restore it.

    For you 17.8.1 is working with wattool for some is not.
     
  18. tede

    tede Guest

    Agree, so if people want i can continue my work on OverdriveNTool for 5xx users who don't have memory P2 in WattTool (maybe vega too, who knows?) and for 4xx users as an alternative to WattTool.
     
  19. faridgv

    faridgv Guest

    this is the exactly prolem i have whit watttool,vega seem to be have p0,p1,p2,p3 for memory
    i suggest you to put monitoring parameter like gpu load,fan rpm,fan %,core & mem clock in overdriveNtool
    and plz tell me a way to auto start overdrive from clymore bat file like watttool....now i can start it with bat file and when set profile from the command in bat file it close after setting profile if i just set to open overdrive it keep open but when i put -p0"name" it close after set profile...watttool keep open after set profile
    I am embarrassed for writing English
     
    Last edited by a moderator: Aug 22, 2017
  20. Alexandr

    Alexandr Guest

    Я подтверждаю наличие новых драйверов 17.8.1, WattTool работает, но Mh / s падает
     
    Last edited by a moderator: Aug 22, 2017

Share This Page