OverdriveNTool - tool for AMD GPUs

Discussion in 'Videocards - AMD Radeon' started by tede, Aug 6, 2017.

  1. tede

    tede Member Guru

    Messages:
    144
    Likes Received:
    70
    GPU:
    AMD RX 470
    @davemz contact me on PM
    All GPUs that use wattman api are supported, I've updated first post.

    @future-vision GPU P0-P5 for Vega cannot be normally changed in OverdriveNTool, they always revert back to default. You need to use PPTable editor to edit them (right click on the title bar to open it)
    I see that you have the same profile as @Zac Leonard, you need to make your own, that works wihout crashing your GPUs
    Every GPU needs different voltage to be stable, so having different profile for each GPU is better option than just one for all. But if you use just one profile you can have commandline shorter:
    OverdriveNTool.exe -r* -p*Vega64
     
    LocoDiceGR likes this.
  2. evlo

    evlo New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    rx570v rx580, gtx10
    Is there any chance you can make this tool able to set cards to compute mode, that would make it really perfect.
     
  3. CCoR-

    CCoR- Active Member

    Messages:
    71
    Likes Received:
    3
    GPU:
    AMD ASUS Strix RX580 8GB
    Overdrive stop working with new adrenaline drivers, setting wont stick.
     
  4. rancar

    rancar New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Rx Vega 64 Nitro+
    Hi! New in the forum :oops:

    I've a problem with my new Radeon Vega 64 Sapphire Nitro+ Limited edition. When I apply the settings to this GPU, i think it doesn't work... the fans doesn't move even if I use the minimum rpm at 3000.

    Any idea?

    Im using the blockchain drivers from AMD and the last overdriventool (0.2.3).

    Greetings! :)
     

  5. future-vision

    future-vision New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Vega 56

    I'd like to adjust the voltages to get each card stable but I'm not really sure which one(s) is/are crashing. They certainly don't follow the order they are plugged into the MB. Any way to identify which one is the offending card when it goes down?

    I'll give the shorthand command a try.
     
    Last edited: Dec 27, 2017
  6. tede

    tede Member Guru

    Messages:
    144
    Likes Received:
    70
    GPU:
    AMD RX 470
    I started PM conversation with you
    My fans behave same way using wattman api when idle. If you want full controll of your fans use other software that controlls fans by temperature curve, e.g Afterburner.
    I'm not planning this, but you can try manually set registry value, something like this:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000]
    "KMD_EnableInternalLargePage"=dword:00000002
    I don't have any problems with adrenaline drivers
     
    evlo likes this.
  7. future-vision

    future-vision New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Vega 56
    Didn't work for me. No idea why. bat ini and exe file all in the same directory. I even moved them all over and stuck them in the miner directory. Nada!
     
  8. Amerzel

    Amerzel New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    vega56
    What does error code -5 mean? Is that what everyone else is getting too?
     
  9. evlo

    evlo New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    rx570v rx580, gtx10
    Thank you, I eventually googled KMD_EnableInternalLargePage on the xmr reddit, shame it is impossible to do trough amd settings, as amd settings are joke.

    Guess I will have to do some powershellscript or something as i'm now on card 16 in registry - i only (uh, only?) have 12 cards in the pc, but when you remove and put back the cards, it is new entry in registry :/

    One more thing - as others pointed out - gpu order in overdriveNtool is different then in, almost, all other software, are you planing to add some different order options or option to identify currently selected gpu - fan/leds?
     
  10. tede

    tede Member Guru

    Messages:
    144
    Likes Received:
    70
    GPU:
    AMD RX 470
    I thought problem was solved when I changed sorting to by bus number, can you contact me on PM?
     

  11. evlo

    evlo New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    rx570v rx580, gtx10
    I see it is correct now, but only claymore is using different order then all other SW, no altnum is helping, so it was just my mistake.
     
  12. usatf1290

    usatf1290 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    XFX Rx580
    I'm also not able to see changes to the actual hashrates when clicking "Apply" using 0.2.3, Adrenaline AMD drivers 17.12.1, Rx580's in Compute mode.

    I can see the change in HWiNFO and GPU-Z, but the changes don't actually affect hashrates until I restart the computer. I never installed .NET 3.5, is this still required for the tool to run properly?
     
  13. future-vision

    future-vision New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Vega 56
    Any ideas why I have this problem? I still wonder if it has anything to do with using the Vega64 profile with Vega56's. Maybe if I rename the Vega64 profile to Vega56 and delete the old Vega56 profile it would work?
     
  14. gasya

    gasya New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    13*Sapphire RX470
    Hello! I setup msi afterburner - but can not make any changes - main window is unactive except settings. How else i can control fans in overdriveNTool?
     
  15. supemm

    supemm New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    AMD RX 580
    Hello !

    When I execute OverdriveNTool 0.2.3, I have the dialog box: "Failed to load ADL library" followed by the red text "This application requires driver 17.7.2 or newer".

    My drivers are "Adrenalin Edition 17.12.2" (http://support.amd.com/en-us/download/desktop?os=Windows 10 - 64)
    I have 6x RX580 Sapphire Nitro+ on Windows 10.

    The problem is the same with older versions of OverdriveNTool (0.2.2, 0.2.1).

    What can I do to solve the problem ?

    Regards,
     

  16. tede

    tede Member Guru

    Messages:
    144
    Likes Received:
    70
    GPU:
    AMD RX 470
    No, it doesn't require .net or visual c++ libraries to work.
    I told you, test your GPU, find optimal clock/voltages and use them in your own profile, not just use copied profile. Renaming doesn't change anything except profile name.
    In OverdriveNTool only using 4 fan values like in wattman.
    It looks like something wrong with your driver installation. Did you DDU before installing new driver? Do other tools like GPU-Z work?
     
  17. motoyaki

    motoyaki New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    amd rx580
    i have the exact same problem. have you find any solution? i tried driver 17.12.2 and 17.12.1. still no luck
     
  18. motoyaki

    motoyaki New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    amd rx580
    GPU-Z works, and I tried DDU and reinstall driver. Still same error. any solution? :(
     
  19. tede

    tede Member Guru

    Messages:
    144
    Likes Received:
    70
    GPU:
    AMD RX 470
    Contact me on PM so we can investigate :)
     
    motoyaki likes this.
  20. viking1978

    viking1978 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    VEGA 64 / 8GB
    It is great tool. I want to confirm that for installing driver, since the tool is doing overclock now, only installing driver is mandatory?
    otherwise, the wattman might do some dodgy things?
     

Share This Page