Optimus: how to disable Nvidia for a certain app?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Thunderbolt8, Aug 4, 2014.

  1. Thunderbolt8

    Thunderbolt8 Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    Geforce GTX 760M
    I want to use TMPGEnc Video Mastering Works 5 with my IGP and not my Nvidia card on my laptop. the problem is when I add this program to the programs to customize in program settings and I set it to IGP this option gets ignored and the program the nvidia card is used anyway.

    the program has CUDA support, but I didnt even enable this in preferences. so I dont know why the nvidia card is used in the first place.

    I also tried adding TMPGEncVMW5.exe to the same profile of mpc-hc.exe in nvidia inspector. but while mpc-hc still doesnt uses the nvidia card, TMPGEnc nevertheless still does use it...
     
    Last edited: Aug 4, 2014
  2. smokeyjon

    smokeyjon Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    EVGA GTX 770 Superclocked
    Can you explicitly enable Intel Quick Sync in TMPGEnc settings?
     
  3. Thunderbolt8

    Thunderbolt8 Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    Geforce GTX 760M
    no I can't
     
  4. smokeyjon

    smokeyjon Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    EVGA GTX 770 Superclocked
    Open preferences and check the Input/Output format list. Make sure Intel Media SDK (Hardware) has + marked for both input and output:

    [​IMG]

    Under CPU/GPU, make sure all CPU features available are enabled, and NVIDIA CUDA is disabled.

    I'm assuming this is for when you are encoding? The nvidia control panel settings won't help with that. Have you modified your GPU settings in the BIOS at all (such as setting the discrete GPU as primary or setting PEG first)?
     

  5. Thunderbolt8

    Thunderbolt8 Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    Geforce GTX 760M
    my laptop bios doesnt even show me such settings.

    all MMX, SSE, AVX etc. settings are enabled. multithreading as well. enable Nvidia CUDA is unticked. I also got + for those intel media sdk settings.

    the nvidia card already gets activated during the start of the program and then just keeps running, never stops until I close the program. this is very annoying when I just want to deal with filters and the cut section, because it creates more noise and heat while having no advantages at all.
     
  6. smokeyjon

    smokeyjon Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    EVGA GTX 770 Superclocked
    It's possible the program is behaving badly. I can't find any additional in-app controls for this, you'll probably have better luck with the developers.
     
  7. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    You can try disable CUDA via Nvidia Control Panel, just go to "CUDA - GPUs" and untick your graphic.
     

Share This Page