OpenGL-problems after legacy-modding

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by Gwalle, Jul 8, 2014.

  1. Gwalle

    Gwalle New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon X800XL 256MB
    Hey folks

    Figured I might as well post a new thread for this.

    As you can see from my computer stats, I'm stuck with a very very old computer at the moment.

    I tried Amiloman's tutorial for xp-modding found on the first page of his FLEM-thread (had to copy some extra files over and edit 2 lines in the inf, due to my card having a - Secondary), and sort of successfully modded 14.4-drivers using legacy 10.2 as base.

    I'm getting noticeable improvements with stuff like youtube (before the picture used to lag behind the sound, now it's flawless) and directx seems to work.

    But I can't get OpenGL to work. Using atioglxx.dll from the 10.2 legacy drivers now makes all opengl applications just quit before starting up, while they used to work somewhat when just using 10.2 legacy drivers on their own.

    I've only been able to get opengl "working" by using atioglxx from 9.11 drivers, and then it shows up as opengl 1.1 in opengl extension viewer, while it was 2.1 before when using only 10.2 legacy.

    Anyone have any ideas what I can do here? The whole point of this modding originally was to try to improve opengl to play a specific game while waiting for getting my real computer back. Not that I'm not happy with the improvements to youtube etc...

    Thanks
     
  2. Dch48

    Dch48 Ancient Guru

    Messages:
    1,818
    Likes Received:
    0
    GPU:
    Sapphire Nitro+ RX 470 4g
    There are 2 files you need from the legacy driver set. The atioglxx.dll you mention and atiogl.xml. I had to use them from the 10.2 driver to make the original Half Life game run with my modded 13.4 driver.
     
  3. Gwalle

    Gwalle New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon X800XL 256MB
    Yeah, I have been doing that actually.

    Using those 2 files from 10.2 opengl extension viewer just shuts down halfway through "loading extensions" with no message, using 10.1 it shuts down halfway but I get a crash-message, 9.11 runs it properly but says opengl 1.1 support..
     
  4. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Firstly it's not enough, you need to copy the whole opengl relevant files across like gtk etc (the exact names escape me as I haven't bothered with this stuff for some time, except there are way more than only just 2 files to be copied across to get a complete implementation)

    Secondly, at various points, the OpenGL subsystem got changed within the core Catalyst driver architecture, which means that past a certain point, old modules will no longer work with newer dx components or kernel files.

    10.10e was the last multithreaded ogl driver. After this starting at 10.11 as a base you can use newer opengl components (even from last driver). Older than this will allow you to use 10.2 components, but there isn't any reason to not be using 10.4 components as 10.2 has some bugs.

    So in other words you can't tack ogl components from >10.11 onto 10.2 as a base.
     

  5. Gwalle

    Gwalle New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon X800XL 256MB
    Ah thanks, that was informative. Do you have any suggestions on where to look for which files i need to copy?

    Edit: Btw, you're saying that even though 10.2 is supposed to be the last working driver for my gpu i can still use newer as base?
     
    Last edited: Jul 9, 2014
  6. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    No, I'm saying that using >10.10e ogl files tacked onto 10.2 won't work correctly, as the ogl implementation changed somewhere around 10.5a (ogl 3)and again at 10.11.

    Starting at 10.11 as a base would allow you to use *any* newer ogl components past 10.11 and would work (even latest legacy ogl in 10.11 driver). Preferably you would want to start at something like 11.1a/11.2 ogl (photoshop and old quake games working that were broken since 10.4) and work up.

    Obviously you can't do that as 10.2 was the last driver for your card, but you may try switching up to 10.10e components for ogl and stop at the point it stops working. 10.4a is the most compatible of the old ogl's.

    I did all the legwork on figuring all this interoperability crap out many moons ago on here for legacy drivers, but my memory these days isn't what used to be because I haven't touched this kinda stuff in a long time.
     
    Last edited: Jul 9, 2014
  7. Gwalle

    Gwalle New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon X800XL 256MB
    Alright, thanks man.

    Weird thing just happened though, after deciding to make sure I got rid of old garbage by using the "Display Driver Uninstaller" found here on the forums, it just keeps telling me the drivers aren't compatible with windows xp. Only thing I've been able to install again is 10.2...?
     
  8. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    0
    GPU:
    570m / MSI 660 Gaming OC
    do it the other way... use 10.2 as your base, slowly add newer dx components, i assume your main goal is particularly having stable youtube

    btw i have a 9800pro on 10.2, youtube is a bit slow in firefox+flash, but i thought it was due to the card's performance

    had an x800xtpe but accidentally killed it i think

    you should also see if FF vs chrome vs opera & flash vs html5 result in different levels of youtube peformance
     
  9. Dch48

    Dch48 Ancient Guru

    Messages:
    1,818
    Likes Received:
    0
    GPU:
    Sapphire Nitro+ RX 470 4g
    Since your card is from roughly the same generation as the one I modded for, the Radeon Xpress 200M, I would suggest using the 13.4 driver modded with 10.2 and using the 2 OpenGl files I mentioned earlier. anything past 13.4 probably won't provide any benefits anyway and it's even doubtful that the 13.4 does over the 10.2.

    My problem was that 10.2 would not install in Windows 8/ 8.1. Modding 13.4 with FLEM gave me the only driver newer than the old 2005 one provided by HP that would install and work. The HP driver has problems with some games. Notably Half-Life 2 Episode 2 where you can't exit the wrecked train car at the beginning using the HP driver. The card only supports OpenGL up to version 2.0 so the newer files don't work correctly. Your card may be the same in that regard.

    Actually, in your case there wouldn't be anything wrong with sticking with the 10.2 driver since you say it works.. Anything newer may very well provide no benefit at all and actually cause problems.
     
    Last edited: Jul 14, 2014
  10. DjDiabolik

    DjDiabolik Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    Nvidia GT720
    I have the same EXACT problems and i have posted some time ago a similar problems!

    Now i'm on Windows 7 X64.. i have installed this 10.2 legacy.. and the 9.11 legacy but both of this driver have no good support for OpenGL games.

    I have try to copyed on c:\windows\syswow64 the both files atioglxx.dll and atiogl.xml picked fron normal but it's uselless :(
     

  11. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Like I said, you need at least 10.11 as a *base* to use any and all of the newer OpenGL subsystem files transplanted from anything out of 10.12 up to 13.9 without crashing and burning.

    Lower driver bases than 10.11 should use the older components, but you can forget about running modern games like RAGE if you go this direction instead, and there only a few opengl drivers out of the 11.x range where photo shop opengl support won't screw up. I don't remember the specific ones that do work with PS since it's ages since I touched any of this stuff.
     

Share This Page