Official ATI Catalyst 9.12 Released / Download

Discussion in 'Videocards - AMD Radeon Drivers Section' started by olapaulakoski, Dec 17, 2009.

  1. Funky Doodle

    Funky Doodle Master Guru

    Messages:
    792
    Likes Received:
    0
    GPU:
    Gigabyte ATI HD 5830 1GB
    anybody tried 9.12 chipset drivers? when i installed usb filter driver, it damaged all usb devices, so i needed to do system restore and i was doing this without mouse, lol!
     
  2. Jack_Bourne

    Jack_Bourne Member

    Messages:
    24
    Likes Received:
    0
    GPU:
    XFX Radeon 5770
    Greatly appreciated. I'll download driver cleaner and use that with 9.12 and hopefully my issues will go away as well!
     
  3. HaZe303

    HaZe303 Ancient Guru

    Messages:
    1,944
    Likes Received:
    0
    GPU:
    RTX 2070 Super
    Hotfix download links now working! :) Testing begins!
     
  4. lenix

    lenix Master Guru

    Messages:
    301
    Likes Received:
    0
    GPU:
    EVGA 1080 Ti FTW3
    Is the hotfix posted here link for 64 and 32 bit systems?
     

  5. Cablespider

    Cablespider New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire Toxic HD4870
    Bottom of the page.
     
    Last edited: Dec 18, 2009
  6. Sever

    Sever Ancient Guru

    Messages:
    4,826
    Likes Received:
    0
    GPU:
    Galaxy 3GB 660TI
    oh god, stick to the prerelease drivers.

    with the prerelease 9.12 drivers or the official ones, vantage gives me 16700 gpu score.

    with the hotfix 9.12 drivers, vantage gives me 13800...

    EDIT: nevermind, driver installation error.
     
    Last edited: Dec 18, 2009
  7. olapaulakoski

    olapaulakoski Master Guru

    Messages:
    280
    Likes Received:
    0
    GPU:
    msi hawk 5770 1 gb
    Must say although underscanning crysis and warhead is damn silky smooth on stock clock on ati whql drivers i dont have fraps but the framerate felt over 50 on highest settings and 1920*1080 resolution. No need for overdrive on any game for my great midrange 5770.:)

    Just installed the hotfix...
     
  8. olapaulakoski

    olapaulakoski Master Guru

    Messages:
    280
    Likes Received:
    0
    GPU:
    msi hawk 5770 1 gb
    just installed the hotfix, still crazy good performance. Good damn can crysis be this good on this card! Must be stream and my cpu.:)

    Btw anyone know a workaround for underscan in crysis i have black bars around ive set it to native 1920 1080. Never been issue on other ati drivers and i donĀ“t have it on any other game?

    /Ola
     
  9. Sever

    Sever Ancient Guru

    Messages:
    4,826
    Likes Received:
    0
    GPU:
    Galaxy 3GB 660TI
    go to ccc, desktops and displays, right click the little monitor at the bottom and choose configure, turn on gpu scaling.

    note, you may have to change your desktop resolution to a lower one to get the option to not be greyed out.
     
  10. olapaulakoski

    olapaulakoski Master Guru

    Messages:
    280
    Likes Received:
    0
    GPU:
    msi hawk 5770 1 gb
    Thanks it worked.:)

    Crysis still had great framerate, got smoothest gameplay by using force options in ccc, anisoptric worked in that game. Seems they are working with crysis atleast.:)

    Played a little on old fallout 3, made that old great game look really nice and anisoptric did its job sharpening up the textures. :)

    Im happy, finally seen what my new graphic card can do, and it just kicked ass.:)

    Gotta go sleep now, big day tomorrow i have a long trip. Me and my girlfriend are going to gothenburg to se avatar in 3d.:)
     

  11. Funky Doodle

    Funky Doodle Master Guru

    Messages:
    792
    Likes Received:
    0
    GPU:
    Gigabyte ATI HD 5830 1GB
    is there any solution, how to fix cryostasis dx 10 stuttering?
     
  12. Jcazz

    Jcazz Master Guru

    Messages:
    871
    Likes Received:
    0
    GPU:
    Tri-fire 5870
    playing Crysis warhead maxed. 60fps with this driver...runs insane.
     
  13. wsarahan

    wsarahan Master Guru

    Messages:
    408
    Likes Received:
    1
    GPU:
    Evga Titan X SLI
    so guys, should i install the official driver or the hotfix? Wich one is better?, the date of hotfix is 16/12 and the official 17/12, Why? Hotfix was launched first?

    Thanks
     
  14. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    on the notes from the hotfix, they say install only if you suffer from any of the problems the hotfix describeds

    so this leads to the fact that the driver it's the same, but just fixes some problems
     
  15. wsarahan

    wsarahan Master Guru

    Messages:
    408
    Likes Received:
    1
    GPU:
    Evga Titan X SLI
    Thanks, but any idea why hotfix was launched 16 and the official 17? Did you tryed both?
     

  16. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    the original can be older, and then just re-compiled or re-packaged , thus earlier dates

    i don't mind such things unless it's beta drivers or leacked stuff, what it's published it's what it is ....
     
  17. nutyo

    nutyo Ancient Guru

    Messages:
    4,588
    Likes Received:
    0
    GPU:
    Sapphire Vapor-X HD5870
    Hotfix doesn't work for me. Even after driver sweeping I get version 9.8??? And fps drops to about 70% across the board. Haven't been able to solve it yet.
     
  18. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    uninstall all software from ati, at control panel
    reboot
    go to hardware , video, select video card, and click on delete all driver files
    say yes,
    reboot
    you will be on 800x600 or so, and your video card should day Generic VGA on driver info

    if not, repeat

    then boot again, and when you are on generic vga installa drivers again

    it works allways,

    I have never used driver sweepers so I do not the secondary effects
     
  19. nutyo

    nutyo Ancient Guru

    Messages:
    4,588
    Likes Received:
    0
    GPU:
    Sapphire Vapor-X HD5870
    I finally got it working but performance is still down on Furmark. Anyone know if they re-gimped that, I do have the exe renamed.
     
  20. technotoad

    technotoad Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    msi,gtx 570
    I am havin the same problem with the hot fix as above but i ended up with driver 9.7 twice. Once uninstalling,driversweeper and install and i tryed the above method but still no joy, anyone got any other idea,s on how i could get these working.At the momment i have the new ccc and the whql 9.12
    thx for any help.
     

Share This Page