NVIDIA issues firmware update for GeForce RTX 3080 Ti and RTX 3060 fixing DisplayID issues

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Oct 21, 2021.

  1. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    42,454
    Likes Received:
    10,269
    GPU:
    AMD | NVIDIA
    Apparatus and JonasBeckman like this.
  2. Jean-Baptiste Simonnet

    Jean-Baptiste Simonnet New Member

    Messages:
    2
    Likes Received:
    2
    GPU:
    Vega 64 LC
    Link doesn't work, error 404
     
  3. Caesar

    Caesar Maha Guru

    Messages:
    1,377
    Likes Received:
    544
    GPU:
    GTX 1070Ti Titanium
  4. Astyanax

    Astyanax Ancient Guru

    Messages:
    12,046
    Likes Received:
    4,562
    GPU:
    GTX 1080ti

  5. stormy

    stormy Ancient Guru

    Messages:
    2,656
    Likes Received:
    47
    GPU:
    Pulse RX5600XT
  6. chr!s

    chr!s Member Guru

    Messages:
    176
    Likes Received:
    28
    GPU:
    GTX 1080
    tried it on my 3080ti, say update already applied.
     
  7. IceVip

    IceVip Master Guru

    Messages:
    811
    Likes Received:
    151
    GPU:
    RTX 3080 Ti
    Ha! I was gonna ask here on the forums if anyone else had this. Ever since i updated to the official build of w11 my pc boots into a blackscreen from cold boot. Gotta restart and go through bios for it to boot properly. I wonder if this is gonna fix it, gonna report back asap.

    //EDIT

    Says my card's up to date.

    rip in pesos i guess.
     
    Last edited: Oct 21, 2021
  8. doza

    doza Member

    Messages:
    25
    Likes Received:
    2
    GPU:
    RTX2080 Gigabyte
    ok so Nvidia fix my gigabyte rtx2080 too... last week after installing latest nvidia driver i had same problem too, when booting to desktop screen goes black. It took me like 2h to find that displayport was problem, changing to hdmi fixed it.
     
  9. Astyanax

    Astyanax Ancient Guru

    Messages:
    12,046
    Likes Received:
    4,562
    GPU:
    GTX 1080ti
    disable fast startup
     
    IceVip likes this.
  10. Valkyrie743

    Valkyrie743 Active Member

    Messages:
    66
    Likes Received:
    1
    GPU:
    Evga GTX 1080 FTW
    can someone open GPU Z and post the bios version that it updates to.

    there was a beta bios that was uploaded to techpowerup's database a while back and i installed it and it a few months ago and it fixed the issue, but wanted to see if its that same bios or if its different (updated)

    the bios i have is 94.02.71.00.CA

    (3080 Ti)
     

  11. Sentenced

    Sentenced Member

    Messages:
    29
    Likes Received:
    8
    GPU:
    GTX 1650
    Is this also applicable to laptops?
     
  12. Astyanax

    Astyanax Ancient Guru

    Messages:
    12,046
    Likes Received:
    4,562
    GPU:
    GTX 1080ti
    it doesn't update the bios, it dumps the existing one, modifies the relevant region and flashes it back.
     
  13. IceVip

    IceVip Master Guru

    Messages:
    811
    Likes Received:
    151
    GPU:
    RTX 3080 Ti
    I actually did right after i tried this tool and it fixed it. Read somewhere in google someone in w10 had the same thing and that was the fix, turns out its the same in this case too.
     

Share This Page