NVidia Inspector 1.9.7.6 + FPS limit 59.7 = microstutter

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by 2mg, Aug 31, 2016.

  1. 2mg

    2mg Member

    Messages:
    36
    Likes Received:
    1
    GPU:
    760
    Hi,

    I am currently testing Portal Stories: MEL (Portal 2 mod). This problem is also seen in other games (Borderlands 2), but I'm using this one for reference.

    FPS_max command is 300 default.
    Vsync is triple buffered, exclusive fullscreen.
    Win 7 x64, 372.54 driver.

    Using the NV Inspector with ~59.7 limit causes microstutter even though FPS is at 59.x ingame. Frametimes are mostly 10-17ms, but with a short hiccup to 20ms.

    If I limit FPS_max to anything around 60, or use RTSS limiter, there is no microstutter, and frametimes become ~16ms.

    Can anyone explain this phenomenom?

    Why is NV Inspector not playing along?



    Videos:
    Microstutter, no limit - www.sendspace.com/file/tojxm8
    FPS limit 60fps - www.sendspace.com/file/8kgnik

    PS: ignore frametimes in first video, they double because of recording!
     
    Last edited: Aug 31, 2016
  2. khanmein

    khanmein Ancient Guru

    Messages:
    1,646
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    try use 60 fps frame limiter v2
     
    addeya likes this.
  3. 2mg

    2mg Member

    Messages:
    36
    Likes Received:
    1
    GPU:
    760
    (delete post)
     
    Last edited: Aug 31, 2016
  4. 2mg

    2mg Member

    Messages:
    36
    Likes Received:
    1
    GPU:
    760
    Frame Rate Limiter 2 Control? Whats the difference between them?
     

  5. X7007

    X7007 Ancient Guru

    Messages:
    1,805
    Likes Received:
    63
    GPU:
    ZOTAC 4090 EXT AMP

    What are the different really ?
     
  6. 2mg

    2mg Member

    Messages:
    36
    Likes Received:
    1
    GPU:
    760
    Frame Rate Limiter 2 Control doesn't do a thing, I can't find limiter v2 !?
     
  7. khanmein

    khanmein Ancient Guru

    Messages:
    1,646
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    @X7007 try ask @Orbmu2k if no mistake v2 able to lock the fps better.


    @2mg;

    Frame Rate Limiter - 60 fps ( Frame Rate Limiter v2 )

    Frame Rate Limiter 2 Control - 0x00000008 (Default)

    play around until u get the best solution.
     
    Last edited: Aug 31, 2016
  8. X7007

    X7007 Ancient Guru

    Messages:
    1,805
    Likes Received:
    63
    GPU:
    ZOTAC 4090 EXT AMP

    So you enable Vsync in game + FRL 2 ? or do you enable Vsync in NVCP + FRL2 ?

    If I'm using 59 Hz cause 60 Hz is not properly works when I open games, they open in 59 Hz all the time and Alt+Tab cause a small black screen delay , so in movies.
     
  9. 2mg

    2mg Member

    Messages:
    36
    Likes Received:
    1
    GPU:
    760
    Putting any number ie 58 59 60 into "Frame Rate Limiter" doesn't work ingame, it's unlimited. I can only choose ~XX.X values ie ~59.7.

    And I still don't know why you call it v2, it's the only Frame Rate Limiter.
     
  10. aufkrawall2

    aufkrawall2 Ancient Guru

    Messages:
    2,251
    Likes Received:
    744
    GPU:
    3060 TUF

  11. Pyrage

    Pyrage Master Guru

    Messages:
    414
    Likes Received:
    51
    GPU:
    580 CF@ 1470
    Pic for the people having issues finding the v2 setting..on the frame limiter setting, just scroll all the way down until you see the "v2" options:

    [​IMG]
     
  12. khanmein

    khanmein Ancient Guru

    Messages:
    1,646
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    disable v-sync in game setting

    NVIDIA Profile Inspector;

    Vertical Sync - Force off
    Vertical Sync Smooth AFR behaviour - Off (On if u enabled v-sync)
    Vertical Sync Tear Control - Standard/Adaptive (depend games)

    i also using 59 Hz 1440p but no more issue with this new 372.70. previously 372.54, i got no choice but to use CRU set 60 Hz to prevent shuttering & tearing during gaming..
     
  13. yobooh

    yobooh Master Guru

    Messages:
    260
    Likes Received:
    15
    GPU:
    Gigabyte 970 G1
    Just use CRU as written here and it will fix the 59hz.
    I've an LG Monitor TV and this fixed the problem.

    HERE
     
  14. yobooh

    yobooh Master Guru

    Messages:
    260
    Likes Received:
    15
    GPU:
    Gigabyte 970 G1
    @khanmein
    With 369.09 I cannot open ProfileInspector anymore, there is a fix?

    EDIT: fixed with THIS!!!
     
    Last edited: Sep 1, 2016
  15. X7007

    X7007 Ancient Guru

    Messages:
    1,805
    Likes Received:
    63
    GPU:
    ZOTAC 4090 EXT AMP

    But I have Philips 3D TV 7007 , I asked the CRU creator, he said it's going to be a problem to "fix" the issue with a 3D TV while keeping everything as is.
     

  16. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,375
    Likes Received:
    265
    GPU:
    Gigabyte 3080 Ti
    Why not simply use RTSS to set a 60FPS limit?

    I've never personally had problems with 60FPS stutter that didn't come from a game issue.

    As for the 59.94 problem however, just another bystanding issue from stupid HDTV/HDMI EDID standards. FFS TVs still ship with Overscan ON.
     
  17. khanmein

    khanmein Ancient Guru

    Messages:
    1,646
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    @MrBonk, my dell monitor come with 59.94 Hz so not bout HDTV/HDMI EDID standards but other thang & i tried RTSS but can't even limit the frames at all.

    i personally suggest nvidia profile inspector is way better than RTSS.
     
  18. 2mg

    2mg Member

    Messages:
    36
    Likes Received:
    1
    GPU:
    760
  19. khanmein

    khanmein Ancient Guru

    Messages:
    1,646
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    @2mg

    try copy 2.1.2.15 the latest version.
     
  20. 2mg

    2mg Member

    Messages:
    36
    Likes Received:
    1
    GPU:
    760
    Working!

    Can I ask what is the difference between v1 and v2 limiter?
     

Share This Page