Nvidia HDMI Full Range and Limited Toggler Tool

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Penal Stingray, Jan 7, 2013.

  1. maur0

    maur0 Master Guru

    Messages:
    830
    Likes Received:
    59
    GPU:
    point of view gtx 570 1gb
    [​IMG]

    [​IMG]


    [​IMG]
    up to 60.002 and ok



    more quality on tv windows vista 7 8 and 8.1 run with 59 hz this options enable real 60 hz and results is image with more contrast and brightness and color more intense using full quality of HDMI conection :)
     
    Last edited: Mar 28, 2014
  2. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    745
    Likes Received:
    9
    GPU:
    Geforce GTX 970 @1420
    I'm also using Windows 8.1 and the tool in the OP works for me whenever I install new drivers.

    Also if your TV doesn't have an option to set 0-255 in the menu or a way to label the input as 'PC' I wouldn't mess with an HDMI Black Level setting in the menu, that will probably crush blacks if you set it to low, it should be set to Normal for 0-255 PC mode AFAIK. This is true for my 2013 Samsung LED and 2010 Panasonic plasma set, I don't have to mess with the HDMI Black Level setting, it is only useful to set to low for component sources like the OG Wii to fix the black levels.
     
    Last edited: Mar 28, 2014
  3. Redmist

    Redmist New Member

    Messages:
    5
    Likes Received:
    0
    Excellent! Thanks, Mangix. It works with the newest Nvidia drivers.

    For anyone else with a Samsung TV, I can confirm the correct settings are -:

    HDMI Black Level -:
    Low - 16-235 signal
    Normal - 0-255 signal

    A lot of people on other forums say that it's the other way around but they're definitely wrong. To make things more complicated, I found out my Denon receiver chops off everything outside of 16-235 even if you set it to "bypass" mode. I'm going straight to the TV now and it's all good.
     
  4. Shadowdane

    Shadowdane Maha Guru

    Messages:
    1,429
    Likes Received:
    71
    GPU:
    MSI RTX 3080 Suprim
    Hmm that sucks with the Denon Receiver... I'll have to check but I'm pretty sure my Denon AVR-1610 had an option in the HDMI settings for RGB Range.
     

  5. Redmist

    Redmist New Member

    Messages:
    5
    Likes Received:
    0
    Found this in a Denon FAQ...

    "•RGB RANGE: This setting is irrelevant unless you switch to RGB in COLOR SPACE. The RGB RANGE toggles between "video levels" and "computer levels" for color output range. As with COLOR SPACE, most modern video devices will be using "video levels" and so just leave this on "Normal" unless you specifically know what you are doing. Note that this setting is no longer available on current models."

    My 3312 doesn't have this setting. I'm told that the very latest Denons (X3000, X4000 etc.) just work in whatever color space they are given and don't need to be set.
     
  6. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,314
    Likes Received:
    227
    GPU:
    MSI RTX 2080
    I can also confirm this.

    I have a 2012 Samsung Eh4000 and this is true. (A 1366x768 set)

    Using PC mode and HDMI 1 (DVI) correctly selects the correct RGB/black levels.
     
  7. bjoswald

    bjoswald Member Guru

    Messages:
    156
    Likes Received:
    6
    GPU:
    Intel UHD 630
    Works perfectly every time I update my drivers. Thanks!
     
  8. billypit

    billypit Member

    Messages:
    25
    Likes Received:
    1
    GPU:
    MSI
    Works perfectly. I am happy. Thanks.
     

Share This Page