NVIDIA Geforce GTX 860M/ 2Gig

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Behrad, Aug 20, 2020.

  1. Behrad

    Behrad New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GTX 860M/2G
    Hello Everyone!
    I am just created this Topic because for more than 1 year i can't update my Graphic Driver!!! I have tried every possible way ...even with fresh Windows also couldn't install new drivers .

    The only Last Driver which I can install on my laptop is 425.31!!!!

    if anyone can please Help me to understand why NVIDIA do that! in support website shows me 860M can install all new drivers but on my laptop when trying to install getting this Error:

    https://pasteboard.co/Jni2Ih6.jpg
    [​IMG]
    [​IMG]
     
  2. EugeneJackKhoros

    EugeneJackKhoros Active Member

    Messages:
    71
    Likes Received:
    29
    GPU:
    Asus RTX 3080 Ti
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    14,025
    Likes Received:
    5,658
    GPU:
    GTX 1080ti
    There are no further drivers for this version of the 860m
     
  4. EugeneJackKhoros

    EugeneJackKhoros Active Member

    Messages:
    71
    Likes Received:
    29
    GPU:
    Asus RTX 3080 Ti
    If you succeed in installing - respond
    There is also an option to use DDU to completely remove the driver. After that, you may be able to install the DCH driver
     
    Last edited: Aug 26, 2020
    Behrad likes this.

  5. KingpinZero

    KingpinZero Master Guru

    Messages:
    916
    Likes Received:
    2
    GPU:
    MSI Armor GTX1080
    That gpu is considered legacy, and it's old. It's normal for a gpu vendor to cut the older gpus from their driver package as it would require more effort than anything. Therefore don't bash your head into a wall finding a solution, there's none.
     
  6. Behrad

    Behrad New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GTX 860M/2G
    i have tried everything, with ddu too and dch or legacy drivers...i think before when i installed drivers from nvidia then something else was seems tobe installed with driver...if i am not wrong something little runtime vulkan-runtime...and it's dissappear !!! i have changed my windows 10 many times and tried with fresh one but still i can't use DCH or any newer driver after 425v!!!
     
  7. Behrad

    Behrad New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GTX 860M/2G
    and the strange things are that NVIDIA support shows me latest version driver for my GPU ,and for 880m and 870m seems only 425v the latest one. I am sure about that my GPU is 860m not the others!!!!
     
  8. Behrad

    Behrad New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GTX 860M/2G
    even Geforce Experience recognizing my driver has update and after download and run installer ,it's the same error appears!! maybe it's really Vulkan-runtime related! i don't know how to install Vulkan separately !
     
  9. Yxskaft

    Yxskaft Maha Guru

    Messages:
    1,489
    Likes Received:
    121
    GPU:
    GTX Titan Sli
    As has been said, driver 425.31 is the last official driver for the mobile Kepler based GPUs, and all of 800M series were Kepler and the even older Fermi.

    If Geforce Experience does say newer drivers are compatible it's wrong.
     

Share This Page