Nvidia GeForce 384.94 Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by zandathrax, Jul 24, 2017.

  1. zandathrax

    zandathrax Active Member

    Messages:
    83
    Likes Received:
    37
    GPU:
    RTX 2080 TI AMP Ext
  2. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    15,694
    Likes Received:
    1,699
    GPU:
    Sapphire 5700XT P.
    384.94

    Doesn't seem to be a PDF yet for the changes.

    EDIT: Ah there was one. :)

    EDIT: Alright let's start quoting it.


    [GeForce GTX 1070][Doom]: The GPU clocks remain running at high performance speeds after exiting from the game. [1954033]

    That one came up with the previous driver didn't it?
    (So they're aware of it and as such it'll probably be fixed soon, hotfix driver perhaps?)
     
    Last edited: Jul 24, 2017
  3. Venomsword

    Venomsword Member Guru

    Messages:
    172
    Likes Received:
    18
    GPU:
    Asus STRIX-GTX1080
    Topic is a bit incorrect. Driver still not accessible but must be 384.94 WHQL
    Edit - accessible, but number differs as per article name
     
  4. zandathrax

    zandathrax Active Member

    Messages:
    83
    Likes Received:
    37
    GPU:
    RTX 2080 TI AMP Ext

  5. Barry J

    Barry J Ancient Guru

    Messages:
    2,768
    Likes Received:
    120
    GPU:
    RTX2080 TRIO Super
    Game Ready Drivers provide the best possible gaming experience for all major new releases, including Virtual Reality games. Prior to a new title launching, our driver team is working up until the last minute to ensure every performance tweak and bug fix is included for the best gameplay on day-1.

    Game Ready
    Provides the optimal gaming experience for LawBreakers, ARK: Survival Evolved, Fortnite Early Access, Dark and Light, and Hellblade: Senua’s Sacrifice

    Game Ready VR
    Provides the optimal gaming experience for EVE: Valkyrie’s “Ultra” graphics update
     
  6. zandathrax

    zandathrax Active Member

    Messages:
    83
    Likes Received:
    37
    GPU:
    RTX 2080 TI AMP Ext
    \ o /
     
    Last edited: Jul 24, 2017
  7. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,980
    Likes Received:
    322
    GPU:
    RTX 2080 OC
    r384_00-203, 07/18/2017

    Same weird Vulkan setup with included RT being 1.0.42 while the driver itself is supporting 1.0.46.

    Doom clocking bug isn't fixed in these.
     
    Last edited: Jul 24, 2017
  8. khanmein

    khanmein Ancient Guru

    Messages:
    1,649
    Likes Received:
    71
    GPU:
    EVGA GTX 1070 SC
    Not only Doom, but other games too. The temporary solution is not set prefer maximum performance.
     
  9. Alberto

    Alberto Master Guru

    Messages:
    260
    Likes Received:
    68
    GPU:
    2080 Ti Lightning Z
    Dear friends, I smell hotfix driver :D
     
  10. khanmein

    khanmein Ancient Guru

    Messages:
    1,649
    Likes Received:
    71
    GPU:
    EVGA GTX 1070 SC
    No issue so I don't think so.
     

  11. peppercute

    peppercute Master Guru

    Messages:
    441
    Likes Received:
    91
    GPU:
    Msi 2080 TI TRIO
    x299 and sli users waiting fix... :nerd: later i try this driver
     
  12. khanmein

    khanmein Ancient Guru

    Messages:
    1,649
    Likes Received:
    71
    GPU:
    EVGA GTX 1070 SC
    x299 still new so is the same like the old days of x99.
     
  13. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    750
    Likes Received:
    3
    GPU:
    Geforce GTX 970 @1420
    I don't have that option set to prefer maximum performance and I still get the issue.
     
  14. Alberto

    Alberto Master Guru

    Messages:
    260
    Likes Received:
    68
    GPU:
    2080 Ti Lightning Z
  15. pstlouis

    pstlouis Master Guru

    Messages:
    401
    Likes Received:
    1
    GPU:
    GTX 1080Ti SC2 2038
    Video card downclock in idle ?

    The bug not downclocking at 139Mhz when we quit Doom for Pascal card still present. need a fix.
     

  16. khanmein

    khanmein Ancient Guru

    Messages:
    1,649
    Likes Received:
    71
    GPU:
    EVGA GTX 1070 SC
    If you don't have the option then must be something wrong with your side.

    What I know is that as long you didn't select 'Prefer maximum performance' under Doom profile then you're unable to reproduce the issue.

    Try to use 'Adaptive' or 'Optimal power' under Doom profile & left the global setting default - Optimal power.

    [GeForce GTX 1070][Doom]: The GPU clocks remain running at high performance speeds after exiting from the game. [1954033]
     
  17. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,717
    Likes Received:
    372
    GPU:
    EVGA 1070Ti Black
    still using 375.70 here, not sure i care to update just yet, maybe when I get around to play Deus Ex: MD I Will update drivers seeing it only game i have that is new

    But like DX:MD and Witcher 3, my gpu really isnt up to the task

    Code:
    Windows 10 Issues
    
    [GeForce GTX 1070][Doom]: The GPU clocks remain running at high performance speeds after exiting from the game. [1954033]
    
    
    I gona go out limb and say the reports of gpu not down clock to idle on desktop is an issue with the game only and effect everyone as result, It took nvidia 6 months to fix there drivers from not down clocking in windows 10 when they were set to prefer maximum upon it initial launch.
     
    Last edited: Jul 24, 2017
  18. Sajittarius

    Sajittarius Master Guru

    Messages:
    360
    Likes Received:
    21
    GPU:
    2080ti Windforce
    Looks like they fixed the windows/HDR problems with Creator's Update? Will try when i get home..
     
  19. Michalko

    Michalko Member Guru

    Messages:
    169
    Likes Received:
    0
    GPU:
    a good one
  20. khanmein

    khanmein Ancient Guru

    Messages:
    1,649
    Likes Received:
    71
    GPU:
    EVGA GTX 1070 SC

Share This Page