Nvidia Geforce 372.54 Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by peppercute, Aug 16, 2016.

  1. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,611
    Likes Received:
    267
    GPU:
    MSI 970 Gaming 4G
    WU, on win10 has never installed drivers on my end (it did install old ones though when it updated to win10).
    My understanding now is it doesn't automatically install new drivers always, unless you uninstall and there no driver for HW, then it will right away.
    Also while those settings are there I thought those don't work in win10, at least that was what everyone was saying back when win10 was new, maybe now they work.
    That is how I had win7, don't install drivers from WU.

    Edit: if you look at the options now, it just says about "chose when manufacture apps updates and custom icons" not drivers.
     
    Last edited: Aug 18, 2016
  2. rauf

    rauf Member

    Messages:
    13
    Likes Received:
    5
    GPU:
    2x Titan X Maxwell
    I would ask same question. Previously it required v-sync settings to Vertical Sync 0x18888888 (Inspector). Under NV 372.54 i can't see it anymore?

    btw SLI Maxwell here
     
  3. Cyberdyne

    Cyberdyne Ancient Guru

    Messages:
    3,581
    Likes Received:
    297
    GPU:
    2080 Ti FTW3 Ultra
    Driver install went fine. I just did a simple upgrade, not even a clean install.
    No issues installing.

    SSAO is broken on Fallout 4. Textures get covered in a black blobby mess. Switching to HBAO+ fixes it.
     
  4. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,989
    Likes Received:
    337
    GPU:
    RTX 2080 OC
    The problem is that WU will try to install a new driver if you uninstall the current one. It won't happen with "clean install" option as the installer control this. But it might happen if you uninstall the current driver manually or with DDU.
     

  5. EdKiefer

    EdKiefer Ancient Guru

    Messages:
    2,611
    Likes Received:
    267
    GPU:
    MSI 970 Gaming 4G
    Ahh, I see now, yes, that makes sense.
    I normally just let the driver do its thing with clean option.

    Thanks for clarification of the problem.
     
  6. Fedorov

    Fedorov Member Guru

    Messages:
    103
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX-1070 X4
    Just to clarify, as well as being unable to install this latest driver on AU, before all of this I had the issue of Windows Update trying to install it's own (thanks Microsoft) driver which led to a complete "black screen of death" - ticking those options in the screenshots above do nothing at all in most cases, which shows how utter garbage Windows 10 is - I manually disabled the Windows Update service and also the DDU tool sets something which blocks windows from trying to put it's own garbage driver on too.

    I guess the only thing I haven't tried is to just run this driver over the top of the current 368.69 driver and don't do any uninstall/clean install to see if it just goes on?
     
  7. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    Well, this driver is obviously messed up in more ways than one and since I don't play any of the games it provides improvements for, I went back to 368.95. ROTTR DX12 mGPU runs just fine now and doesn't freeze/stutter/crash/break all the time, so I guess I'm skipping 372.54.
     
  8. Mott

    Mott Master Guru

    Messages:
    846
    Likes Received:
    173
    GPU:
    MSI RTX 2080 GXT
    Had to go back to 368.81 because this driver was making me crash like an alcoholic going through an intersection in ARMA 3. Reverted and so far no more crashing. I wonder if it messed up my overclock which has been stable for years as some on other forums were complaining that their 24/7 overclocks were no longer stable with the new 372.54 drivers. Anyone else have an issue like this?
     
  9. Vidik

    Vidik Master Guru

    Messages:
    597
    Likes Received:
    177
    GPU:
    MSI 1070 Gaming Z
    Played around 7 hours of ARMA 3 with this driver both MP and SP without an issue on Altis and Tanoa:camo:
    You're probably crashing because lower power states aren't getting enough volts under OC. I had this on 970. As you know arma barely uses GPU most of the time:pc1:
     
    Last edited: Aug 18, 2016
  10. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    I haven't had OC related instability but for some reason my top card ran like 5C hotter in the same games with the same settings. Doesn't happen anymore on the old drivers. I use a custom fan curve too, so it's not like they simply changed the default fan profile.
     

  11. Mott

    Mott Master Guru

    Messages:
    846
    Likes Received:
    173
    GPU:
    MSI RTX 2080 GXT
    Very interesting! I noticed lots of the crashes were coming out of the map which would lend support to your theory. So, forcing the gpu into full clocks the whole time would theoretically combat this issue? I usually sit around 30% GPU usage while playing ARMA 3... talk about the worst optimization of any game ever. Imagine ARMA at 90 fps... that would just be so amazing. I hear they have DX 12 in the works which might bring multi-threaded performance.
     
  12. mojoba

    mojoba Active Member

    Messages:
    95
    Likes Received:
    9
    GPU:
    Nvidia RTX 2070 8gb
    Yes BSOD here within 5 minutes of installing. Also background textures are black in Victor Vran. Don't think these have been properly tested on last gen cards like my 980ti.
     
  13. Mott

    Mott Master Guru

    Messages:
    846
    Likes Received:
    173
    GPU:
    MSI RTX 2080 GXT
    All my games ran perfectly except for ARMA 3 while everything in windows was perfect as well. I think it might be a power state problem with ARMA 3 and not necessarily the fault of the drivers. I might go back to them as they were great drivers and running my GPU at full clocks in ARMA might fix the problem. Sorry to hear you are having way more problems than I did. Witcher 3, Ashes of the Singularity and Overwatch ran perfectly!
     
  14. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,118
    Likes Received:
    1,902
    GPU:
    Zotac GTX980Ti OC
    This is how I disabled mine @run: gpedit.msc, it can still tell you there is a update but won't force you to install it.

    [​IMG]

    Still works now in RS1.
     
  15. akbaar

    akbaar Master Guru

    Messages:
    314
    Likes Received:
    16
    GPU:
    ASUS 2080 STRIX
    after I installed this driver... this happened to me in Survarium game.

    [​IMG]
     

  16. Undying

    Undying Ancient Guru

    Messages:
    14,596
    Likes Received:
    3,763
    GPU:
    Aorus RX580 XTR 8GB
    akbaar i lol'd. :D
     
  17. jiminycricket

    jiminycricket Master Guru

    Messages:
    203
    Likes Received:
    4
    GPU:
    GTX 1080
    This driver is broken on my notebook with i7-4720HQ + 980M (Optimus), Windows 7 x64. Driver installs successfully, but after first reboot, Windows hangs on Welcome screen with spinning wheel forever. Clean install with DDU made no difference.

    Back to 368.95 I go.
     
    Last edited: Aug 19, 2016
  18. Vidik

    Vidik Master Guru

    Messages:
    597
    Likes Received:
    177
    GPU:
    MSI 1070 Gaming Z
    Yes, even better use custom bios. Personally I stopped using any GPU OC on maxwell in arma simply because in this game it's not worth it.

    and DX12 well.. wouldn't get my hopes up.
    https://dev.arma3.com/post/sitrep-00151
     
  19. akbaar

    akbaar Master Guru

    Messages:
    314
    Likes Received:
    16
    GPU:
    ASUS 2080 STRIX
    hahaha
     
  20. JupiterGFX

    JupiterGFX New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    NVIDIA GeForce GTX 745
    I'm hoping someone can help me... I don't really know much about computer specs/parts/etc... I recently updated to this driver, and now when I play smite, my driver crashes.. and says the kernel something or other has stopped responding.. It enters my computer into power saving mode, and comes back up fine several seconds later.. except SOMETIMES, it logs me out on the computer entirely, and when i log back in, my game is not playable, it lags miserably until i restart my computer.. Can someone help me fix this?? thank you!
     

Share This Page