Nvidia Geforce 372.54 Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by peppercute, Aug 16, 2016.

  1. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    I reinstalled MSI AB and updated to the latest version of GPU-Z, both are now reporting VRAM usage correctly. This is very odd, I didn't even do a clean install of AB (kept settings), I wonder what could cause this sort of issue to require an application reinstall.

    As for boost clocks, I haven't noticed any real difference on my system.

    LE: And VRAM monitoring is broken again, it happened randomly while AB was running, it suddenly jumped from ~200 to ~4M again, without starting a game or touching AB at all. I guess reinstalling didn't get to the core issue. Maybe I need to try a clean sweep with DDU too, I'll have to see.
     
    Last edited: Aug 18, 2016
  2. Noirgheos

    Noirgheos New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970 4GB
    So, general consensus from the users here... has this helped with the DPC latency?
     
  3. Fedorov

    Fedorov Member Guru

    Messages:
    103
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX-1070 X4
    Had a bit of a nightmare with these I'm afraid guys, was hoping to see others with similar issues but no....

    Windows 10 64-bit Anniversary update

    Prior to the Anniversary update going into my Windows 10, early July I got my GTX 1070 card and installed the 368.69 drivers that came out day before.

    My whole machine has been running 100% rock solid since that day on these drivers on the new card, playing all my games in 4K, no overclocking required, all stock speeds.

    Luckily I took a full image of my PC before I tried these (thanks Macrium Reflect)

    1) Uninstall Nvidia PhysX driver
    2) Uninstall Nvidia 368.69 driver (I don't install experience or other stuff I don't need)
    3) Reboot Windows 10 into Safe Mode with Networking
    4) Run DDU, choose first option
    5) After cleaning, normal boot into Windows 10
    6) Run latest installer for 372.54
    7) Custom install, choose only Driver and PhysX and tick button for "Clean install"

    Installation completes, the Nvidia icon is in my system tray, right-click for Nvidia Control Panel, nothing happens despite the fact I can see it running in task manager.

    Also, right-click desktop, no Nvidia Control Panel in that menu either...

    Okay, reboot after the install anyway....

    After reboot, my display is using "Basic Graphics Driver" and if I go into Display settings, Advanced display settings my resolution is fix at 1024x768 with no other choices.

    I've even tried going into Device Manager, choosing to manually update the GTX 1070 driver, pointing to the Nvidia folder but the same result every time... Basic Display Driver, no Nvidia Control panel, even though all appear to be running in Task Manager.

    I've restored my entire machine 4 times using Macrium Reflect to get back to last nights working 368.69 machine.

    I appear unable to get these new drivers onto my machine - I'm happy to wait for the next drivers on this crazy Anniversary update to see if I have success, I've basically spent enough hours on this tonight already so I'm giving up and enjoying my games on a good working driver.

    Completely baffled as I've NEVER had this in over a year of Windows 10 and installing new Nvidia drivers all the time previously on my 970 card.

    All sensible suggestions accepted - gutted I can't get latest drivers on ready for Battlefield 1 beta but hopefully these reliable ones I've had since early July will be fine as they are perfect on all other games.

    I don't want to be stuck on this driver set though :/

    Thanks
     
  4. blackdragonbird

    blackdragonbird Member Guru

    Messages:
    102
    Likes Received:
    14
    GPU:
    GTX 1070 G1 Gaming
    New version of nVidia Pixel Clock Patch now work with this driver.

    Download it from the official site.
     

  5. wsarahan

    wsarahan Master Guru

    Messages:
    408
    Likes Received:
    1
    GPU:
    Evga Titan X SLI
    Manuel from Nvidia just said 20 minutes ago that it's a driver bug

    We should wait a hotfix

    At least now we know that the issue is with nvidia
     
  6. siriq

    siriq Master Guru

    Messages:
    791
    Likes Received:
    14
    GPU:
    Evga GTX 570 Classified
    Looks like another fail driver , as i am reading from comments.
     
  7. Fedorov

    Fedorov Member Guru

    Messages:
    103
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX-1070 X4
    I see over on the geforce.com forums there are quite a few threads popping up where people on Windows 10 (Anniversary update???) seem unable to install this or any other driver now.

    Any official statement from an Nvidia representative on this please.

    Windows 10 Anniversary update is terrible, my Father now has READ I/O errors on one of his drives when trying to back it up, he did not have these issues before the update and is restoring his machine to pre-anniversary.
     
  8. pittiez

    pittiez Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    680x2
    ddu does that, i had that happen the first time i tried it
     
  9. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,179
    Likes Received:
    722
    GPU:
    EVGA 1070Ti Black
    I was gona install these then i heard report os black blotches on textures in in some games and flicker specially in swtor and see I mostly play swtor I guess i will pass on these
     
  10. robertmor52

    robertmor52 Master Guru

    Messages:
    220
    Likes Received:
    0
    GPU:
    GTX 1070 Gaming G1
    Sorry man, Im on win 7 64 so I guess this is not the problem...going back to previous driver fixed the problem. Really weird, never ever saw such an incredible performance DROP in a game due to drivers, I do repeat, never EVER!!!!:flame:
     

  11. khanmein

    khanmein Ancient Guru

    Messages:
    1,648
    Likes Received:
    71
    GPU:
    EVGA GTX 1070 SC
  12. Kersey

    Kersey Active Member

    Messages:
    88
    Likes Received:
    0
    GPU:
    Nvidia
    Usually, you can just restart Afterburner and it corrects. It happens when installing new drivers sometimes and when AB is already running.
     
  13. otimus

    otimus Member Guru

    Messages:
    170
    Likes Received:
    1
    GPU:
    GTX 1080
    I don't want to discount your situation, but I do feel like I should mention that I have the exact same videocard as you (Gigabyte G1 GTX 970) and I am not having the same problems. In fact, I have better performance in some stuff (like the stuttering in Vulkan Doom being gone!), and everything else either is running exactly like it was before or slightly better.
     
  14. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,062
    Likes Received:
    43
    GPU:
    Merc 319 6800 XT
    You may have forgotten but they do have 3GB versions of the GTX 580.

    Put two of those in SLI, and 1080p is still possible in a lot of games.

    https://www.amazon.com/EVGA-Mini-HDMI-Lifetime-Warranty-03G-P3-1584-AR/dp/B004YJVUBG

    Not that anybody would WANT to buy this NOW...but those who are on these setups from when they were Flagship material. They still have life in them.

    the 1.5gb models? Not so much.
     
  15. Blackfyre

    Blackfyre Maha Guru

    Messages:
    1,089
    Likes Received:
    73
    GPU:
    RTX 2070 Super
    Yes, 100%. At least in my case it did. Micro-stuttering is gone in every game I've tried so far too that was having issues, and frame-pacing looks a lot smoother in DX12 (at least it does in Tomb Raider).
     

  16. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    Yeah, figured as much when I saw it happen on the fly. If AB always showed an incorrect value it could mean it's not properly compatible with the new driver, but since it went from correct values to incorrect ones before my very eyes, it looks like something must've happened driver side.

    I've also had a very weird crash with Overwatch, I got a W10 notification telling me that "Application Overwatch.exe has been blocked from accessing Graphics hardware." Never seen one of these before. The game simply froze and I had to kill the process, it ran fine when I reopened it though.

    ROTTR DX12 mGPU is also very unstable, but I don't know if the driver or the game should be blamed on that one.
     
  17. venturi

    venturi Master Guru

    Messages:
    314
    Likes Received:
    137
    GPU:
    dual 3090 FE SLI
    This driver re-enables Titan x pascal 4 way sli

    Awesome performance
     
  18. bigfutus

    bigfutus Master Guru

    Messages:
    529
    Likes Received:
    56
    GPU:
    MSI GTX 1080 Ti
  19. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,036
    Likes Received:
    86
    GPU:
    RTX 3090 ROG Strix
    Several AMD users also have had the same problem with the Anniversary Update. I'd assume it might have to do with the OS not playing along nicely, not so much with the video card itself.

    My mother's PC was freezing randomly with the Anniversary Update (clean install) at first, especially when copying files, error logs pointing towards HDD issues, which wasn't really the case. I disabled the BITS service and everything has gone smoothly since.
     
    Last edited: Aug 18, 2016
  20. Fedorov

    Fedorov Member Guru

    Messages:
    103
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX-1070 X4
    Yea the more posts I read it sounds like it's everyone who is on Windows 10 Anniversary struggling to get any drivers to install.

    Not good for any of us and hopefully Nvidia can identify where the problem lies and work around or fix the issue - either that or we are stuck on our current drivers until Microsoft sort this out from their side :(
     

Share This Page