Nvidia Geforce 372.54 Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by peppercute, Aug 16, 2016.

  1. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    This driver broke used VRAM monitoring in MSI AB (4.3.0 Beta 4) for me, now all I get is a number around 4M that doesn't change no matter what game I run, or even if I run no game at all (so it's not like they switched reporting from MB to B or something). Ah well, not a big deal and I expect it to be fixed with a new version of MSI AB most likely. GPU-Z is broken too, it reports negative values now. :)
     
  2. robertmor52

    robertmor52 Master Guru

    Messages:
    220
    Likes Received:
    0
    GPU:
    GTX 1070 Gaming G1
    Are you referring to me pal??
     
  3. Prophet

    Prophet Master Guru

    Messages:
    828
    Likes Received:
    18
    GPU:
    Msi 680 Gtx Twin Frozr
    Had that, reinstalled ab, now working.
     
  4. Vidik

    Vidik Master Guru

    Messages:
    615
    Likes Received:
    217
    GPU:
    MSI 1070 Gaming Z
    Try reinstalling everything because it's working fine on my end, both graphs and OSD
     

  5. pato9

    pato9 Member

    Messages:
    46
    Likes Received:
    16
    GPU:
    RTX 2060 S
  6. KingK76

    KingK76 Member Guru

    Messages:
    108
    Likes Received:
    14
    GPU:
    Pascal Titan X Under H2O
    I have a Pascal Titan X and i had lockups amd visual corruption with this driver. I went back to 369.05 and haven't had any issues.
     
  7. chuchicoupe

    chuchicoupe Active Member

    Messages:
    67
    Likes Received:
    1
    GPU:
    MSI GTX 1080ti GX3
    yes, try to deactivate GAMEDVR in XBOX app
     
  8. Vegtro

    Vegtro Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    Gigabyte 970 G1
    Anyone getting the return of Desktop flickering on Gsync/1080?
     
  9. Denial

    Denial Ancient Guru

    Messages:
    13,879
    Likes Received:
    3,559
    GPU:
    EVGA RTX 3080
    Yes -- multiple people have posted about it
     
  10. robertmor52

    robertmor52 Master Guru

    Messages:
    220
    Likes Received:
    0
    GPU:
    GTX 1070 Gaming G1
    Thanks for your reply man, but I cant find any "xbox app" nor "gamedvr" anywhere :O...where is it supposed to be??
     

  11. wsarahan

    wsarahan Master Guru

    Messages:
    408
    Likes Received:
    1
    GPU:
    Evga Titan X SLI
    Same here

    Also this driver makes the BOOSt 3.0 from my 1080 SLi setup to be less efective, old drivers i can get 2079, this drivers without touching a thing i only get 2050 in the MSI afterburner monitoring OSD
     
  12. chuchicoupe

    chuchicoupe Active Member

    Messages:
    67
    Likes Received:
    1
    GPU:
    MSI GTX 1080ti GX3
    Last edited: Aug 17, 2016
  13. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,408
    Likes Received:
    265
    GPU:
    RTX 3090 ROG Strix
    I can't get Ansel to work for some reason. I have updated The Witcher 3 to 1.24 on Windows 10 Pro 64 bit 1607 and the 372.54 drivers installed with everything including 3D Vision stuff since I read somewhere you need that for Ansel, the only thing I didn't install from the driver set was GeForce Experience. I hit Alt+F2 in The Witcher 3 (GOG Galaxy version) and nothing happens.
    Is there anything else I'm missing? Or is Ansel not supported for the Nvidia Titan X (Pascal)? Or could it have to do with me having a GTX 680 as a dedicated PhysX card in my rig (I'm currently playing through Arkham Knight, so that old 680 as dedicated PhysX card allows me to keep the framerate above 60 at all times at 4k with all details and PhysX maxed).
    Is there any way to force Ansel on in The Witcher 3 via .settings file or anything else I could try?


    Update: Nevermind, I got it to work. Hat do start "..\NVIDIA Corporation\Ansel\Tools\NvCameraConfiguration.exe" and enable Nvidia Camera there. After this it works fine.
     
    Last edited: Aug 17, 2016
  14. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    I reinstalled MSI AB and updated to the latest version of GPU-Z, both are now reporting VRAM usage correctly. This is very odd, I didn't even do a clean install of AB (kept settings), I wonder what could cause this sort of issue to require an application reinstall.

    As for boost clocks, I haven't noticed any real difference on my system.

    LE: And VRAM monitoring is broken again, it happened randomly while AB was running, it suddenly jumped from ~200 to ~4M again, without starting a game or touching AB at all. I guess reinstalling didn't get to the core issue. Maybe I need to try a clean sweep with DDU too, I'll have to see.
     
    Last edited: Aug 18, 2016
  15. Noirgheos

    Noirgheos New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970 4GB
    So, general consensus from the users here... has this helped with the DPC latency?
     

  16. Fedorov

    Fedorov Member Guru

    Messages:
    103
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX-1070 X4
    Had a bit of a nightmare with these I'm afraid guys, was hoping to see others with similar issues but no....

    Windows 10 64-bit Anniversary update

    Prior to the Anniversary update going into my Windows 10, early July I got my GTX 1070 card and installed the 368.69 drivers that came out day before.

    My whole machine has been running 100% rock solid since that day on these drivers on the new card, playing all my games in 4K, no overclocking required, all stock speeds.

    Luckily I took a full image of my PC before I tried these (thanks Macrium Reflect)

    1) Uninstall Nvidia PhysX driver
    2) Uninstall Nvidia 368.69 driver (I don't install experience or other stuff I don't need)
    3) Reboot Windows 10 into Safe Mode with Networking
    4) Run DDU, choose first option
    5) After cleaning, normal boot into Windows 10
    6) Run latest installer for 372.54
    7) Custom install, choose only Driver and PhysX and tick button for "Clean install"

    Installation completes, the Nvidia icon is in my system tray, right-click for Nvidia Control Panel, nothing happens despite the fact I can see it running in task manager.

    Also, right-click desktop, no Nvidia Control Panel in that menu either...

    Okay, reboot after the install anyway....

    After reboot, my display is using "Basic Graphics Driver" and if I go into Display settings, Advanced display settings my resolution is fix at 1024x768 with no other choices.

    I've even tried going into Device Manager, choosing to manually update the GTX 1070 driver, pointing to the Nvidia folder but the same result every time... Basic Display Driver, no Nvidia Control panel, even though all appear to be running in Task Manager.

    I've restored my entire machine 4 times using Macrium Reflect to get back to last nights working 368.69 machine.

    I appear unable to get these new drivers onto my machine - I'm happy to wait for the next drivers on this crazy Anniversary update to see if I have success, I've basically spent enough hours on this tonight already so I'm giving up and enjoying my games on a good working driver.

    Completely baffled as I've NEVER had this in over a year of Windows 10 and installing new Nvidia drivers all the time previously on my 970 card.

    All sensible suggestions accepted - gutted I can't get latest drivers on ready for Battlefield 1 beta but hopefully these reliable ones I've had since early July will be fine as they are perfect on all other games.

    I don't want to be stuck on this driver set though :/

    Thanks
     
  17. blackdragonbird

    blackdragonbird Member Guru

    Messages:
    104
    Likes Received:
    15
    GPU:
    GTX 1070 G1 Gaming
    New version of nVidia Pixel Clock Patch now work with this driver.

    Download it from the official site.
     
  18. wsarahan

    wsarahan Master Guru

    Messages:
    408
    Likes Received:
    1
    GPU:
    Evga Titan X SLI
    Manuel from Nvidia just said 20 minutes ago that it's a driver bug

    We should wait a hotfix

    At least now we know that the issue is with nvidia
     
  19. siriq

    siriq Master Guru

    Messages:
    791
    Likes Received:
    15
    GPU:
    Evga GTX 570 Classified
    Looks like another fail driver , as i am reading from comments.
     
  20. Fedorov

    Fedorov Member Guru

    Messages:
    103
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX-1070 X4
    I see over on the geforce.com forums there are quite a few threads popping up where people on Windows 10 (Anniversary update???) seem unable to install this or any other driver now.

    Any official statement from an Nvidia representative on this please.

    Windows 10 Anniversary update is terrible, my Father now has READ I/O errors on one of his drives when trying to back it up, he did not have these issues before the update and is restoring his machine to pre-anniversary.
     

Share This Page