Nvidia GeForce 331.65 WHQL - Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Cyris, Oct 28, 2013.

  1. flimbo

    flimbo Master Guru

    Messages:
    758
    Likes Received:
    7
    GPU:
    MSI GTX 970
    Do these driver play ball nicely with the GTX 560Ti?
    When I tried the drivers prior to these ones, Firefox hardware acceleration was broken and this meant the scrolling wasn't as smooth when it was turned off, so I'd like to be able to leave it on.
     
  2. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    Please put the IMG inside the spoiler, it is too big for the screen...
    Thank.
     
  3. somebody2978

    somebody2978 Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    ZOTAC GTX 650 Ti 2GB AMP!
  4. b0uncyfr0

    b0uncyfr0 Member Guru

    Messages:
    184
    Likes Received:
    0
    GPU:
    Gaming XXX 1070
    Hmm i seem to be crashing with this drive in Arkham Origins. The specific error is always DPC Watchdog Violation. Id never seen that before and it turns out its something related to the my Crucial M4 SSD which has been humming along nicely.

    So i reverted back to 331.58 and it hasnt crashed inalmost 2 hours of gameplay. Has anyone experienced this? And what does it have to do with my beloved SSD?
     

  5. VultureX

    VultureX Banned

    Messages:
    2,577
    Likes Received:
    0
    GPU:
    MSI GTX970 SLI
    Yea, the 6 series just pack a whole bunch of extra features built into the hardware of which the use is finally made visible. That's why I just skip all the refresh products when buying new graphics cards, because they merely bring a few extra percent performance of which we have plenty anyways.
    As soon as a brand new series introducing new features starts to show and you are at least two series behind, you know it's a good time to upgrade!
     
  6. kosh_neranek

    kosh_neranek Master Guru

    Messages:
    341
    Likes Received:
    0
    GPU:
    Palit GTX 1070@2101 Boost
    Ever since the beta driver for bf4beta i get random lock ups in games with an error that the Directx device hung(SLI both enabled or disabled) .. plus when I disable or enable SLI my monitor goes blank and I have to restart to get it working again...:bang: Did clean install each time. Disappointed..Think am going back to 314.22 all drivers since then were just brutal and don't tell me that GTX660Ti is an old card please
     
  7. Robbo9999

    Robbo9999 Maha Guru

    Messages:
    1,455
    Likes Received:
    244
    GPU:
    GTX1070 @2050Mhz
    Sounds like a good plan!
     
  8. dnottis

    dnottis Master Guru

    Messages:
    699
    Likes Received:
    0
    GPU:
    EVGA SSC 970 GTX 4GB
    Nothing likes AMD...other than next gen consoles.
     
  9. FordLynx07

    FordLynx07 Member Guru

    Messages:
    199
    Likes Received:
    6
    GPU:
    Zotac GTX 1070 FE
    My EVGA GTX560Ti FPB is working fine with this driver. Internet browsing is showing no problems too. I'm using google chrome btw.
     
  10. somebody2978

    somebody2978 Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    ZOTAC GTX 650 Ti 2GB AMP!

  11. Cyris

    Cyris Master Guru

    Messages:
    302
    Likes Received:
    50
    GPU:
    GTX 1080 TI
    The VSync Problem will be fixed in the next Beta Driver coming in November. Source is a official NVidia beta tester.
     
  12. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,669
    Likes Received:
    1,641
    GPU:
    Zotac GTX980Ti OC
    Yeah its bizarre, I got 4 in a row yesterday.. And I was also doing my usual desktop work, never had such stuff ever.. Same win8.1.


    Now that I reinstalled it over again it didnt happen, yet.
     
  13. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,849
    Likes Received:
    394
    GPU:
    EVGA GTX 1080 Ti SC2
    That's interesting, considering you have the same CPU and motherboard as me. Hmmmmm, I wonder if it could be some incompatibility between the GPU and motherboard because I never experience driver crashes while gaming, only every now and then (infrequent enough to not be a concern at the moment) when booting into Windows, specifically when selecting the Desktop tile on the Start screen. The Start screen will appear to be frozen for 5-10 minutes before the desktop appears but I can still move my mouse. I've found that if I press Ctrl-Alt-Del that I can bring up Task Manager and it resets (black screen) the driver and the desktop then appears and my PC works as normally thereafter. It's really weird. I'm not sure what the GPU is doing at that point other than rendering a 2D image.

    Previously, I have only had these sort of driver crashes when attempting extreme overclocks on the GPU but I'm not overclocked at all and, as I said, games continue to work without issue. I've no idea whether I should be worried or not... I guess not but it's something that has ONLY started happening since upgrading to Windows 8.1. Windows 8.1 has WDDM 1.3 rather than the WDDM 1.2 of Windows 8 and that is responsible for 2D rendering I believe. I wonder if the real problem lies with that and how it works with the graphics driver?
     
  14. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,849
    Likes Received:
    394
    GPU:
    EVGA GTX 1080 Ti SC2
    I had a fair few errors in the event log too but I've managed to fix all of them through driver updates and uninstalling ASUS AI Suite 3. This reduced the number of display driver crashes on boot up from 1 in 5 times to, currently, 1 in 20. I haven't had one in a week so it looks like I am more stable and it isn't fatal anyway as Windows eventually recovers whether I wait 5 minutes or press Ctrl-Alt-Del to force it to appear. Thereafter everything, including games, work normally.

    I just wish I knew why this error is occurring. The fact that is intermittent and rare makes it much harder to solve than one that occurs every time. Reinstalling Windows 8.1 is not an option for me as I've only just installed a clean copy of Windows 8 back in June this year when I built my current Haswell system. I spent almost a month installing games and setting everything up so I really do not wish to go through that again.
     
  15. BoSL

    BoSL Active Member

    Messages:
    74
    Likes Received:
    2
    GPU:
    KFA2 GTX1060 6GB OC
    I think that the upgrade leaves all kinds of redundant s**t in your registry and files hence 8.1 is fubared from the get go..
     

  16. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,849
    Likes Received:
    394
    GPU:
    EVGA GTX 1080 Ti SC2
    That doesn't make sense considering everything else is working perfectly. True, there are a couple of games that don't work properly in Windows 8.1, including FIFA 13, but I've confirmed via a NoDVD crack that the issue lies with Origin and not the game because it otherwise works! I can play games for hours with no crashes or glitches and I haven't had any fatal bluescreens of death or anything like that. This is clearly a minor issue and not one that I deem necessary to reinstall Windows over. I'm sure there is an easier and quicker fix than that!

    By the way, has anyone else experienced texture corruption issues when recording video via ShadowPlay at anything other than the native resolution? I mentioned it earlier but no-one has replied (likely because my post got lost among all the others after it). The 1920x1200 recordings are terrific but if I set the ingame resolution to 1920x1080 so it isn't squashed then the textures in games starts to flicker and get progressively worse, although the game never crashes. If I change the resolution back to 1920x1200 without restarting it then the corruption disappears. The videos recorded at 1920x1080 are blank too (black screen) and I can only hear the audio. I'm guessing this is a possible bug?
     
  17. ESlik

    ESlik Ancient Guru

    Messages:
    2,405
    Likes Received:
    20
    GPU:
    EVGA x2 1080 Ti SC Black
    I'm convinced that the majority of Nvidia driver issues are directly related to Win. 8.1. Not all issues,but the majority for sure. Members here that report issues, should also include the OS in their reports. I'm betting I'm right.
     
  18. John Dolan

    John Dolan Ancient Guru

    Messages:
    2,247
    Likes Received:
    0
    GPU:
    2x GTX 780 SLI
    Origins benchmark 331.58 max settings
    min = 55
    max = 127.
    avg = 86

    Origins benchmark 331.65
    min = 60
    max = 128
    avg = 86

    SLI 780s
     
  19. Violentum

    Violentum Banned

    Messages:
    326
    Likes Received:
    0
    GPU:
    ASUS GTX760 OC
    The only issue I have noticed with this new driver is it seems to be stuck on "adaptive" mode and doesn't seem to stay on "prefer max performance" At first I thought it was strange that my GPU temps dropped 10C then I fired up GPU-Z and sure enough my card is running half speed.. Firs time I have had this issue...

    EDIT: Turns out a reboot was needed, problem gone away.
     
    Last edited: Oct 29, 2013
  20. aayman_farzand

    aayman_farzand Master Guru

    Messages:
    823
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FTW
    I am not getting any errors like you guys but my CPL refuses to open. SLI working perfectly, performance is great, system is stable. But the CPL refuses to open after I enable SLI and restart my computer.

    Edit: Btw you guys have any memory overclocks in place? My friend was getting BSODs with the normal nvidia codes and RAMs on stock fixed it for him.
     

Share This Page