Nvidia GeForce 310.90 Download & Discussion - WHQL

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by mypc, Jan 5, 2013.

  1. Noisiv

    Noisiv Ancient Guru

    Messages:
    8,185
    Likes Received:
    1,449
    GPU:
    2070 Super
  2. -=WolverinE=-

    -=WolverinE=- Active Member

    Messages:
    76
    Likes Received:
    0
    GPU:
    Asus GTX560Ti DirectCu II
    Oooo Jericho! An awesome game indeed! I have to replay it...again. :)
     
  3. Pvfc-Epic

    Pvfc-Epic Maha Guru

    Messages:
    1,188
    Likes Received:
    0
    GPU:
    ASUS GTX560Ti DirectCU II
    this driver causes the cross on any sights in farcry 3 to disappear

    this only happened in 310.70 when tryin to force AA

    i installed over the top of 310.70 could that be the issue ?
     
  4. milamber

    milamber Maha Guru

    Messages:
    1,261
    Likes Received:
    50
    GPU:
    MSI 1080 Gaming X
    Happening to me too, from a clean installation. Restarting the PC fixes it but it's still annoying.
     

  5. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,825
    Likes Received:
    1,882
    GPU:
    NVIDIA GTX 1070 8GB
  6. °L°

    °L° Master Guru

    Messages:
    288
    Likes Received:
    4
    GPU:
    GTX 970
    I have had a problem too, after installing the drivers, i couldn't launch the nvidia 3d settings (black screen and application stopped), i just had to restart the computer and now everything is OK.
     
  7. RedSeptember

    RedSeptember Master Guru

    Messages:
    471
    Likes Received:
    0
    GPU:
    Asus GTX 690 4gb
    Yeah its annoying. Come home from work turn pc on have to restart. Shouldn't happen Nvidia.

    It would be interesting to know why this is happening.. what does the restart process recognize that shutting down doesn't? :3eyes:
     
  8. dem2k

    dem2k Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    295GTX
    Gw2 seems to go to black screen to me when I alt tab, out or exit the game have to bring up the task manager to for explorer to appear.

    on Windows 8, 2x 680GTX SLI
     
  9. Iruwen

    Iruwen Master Guru

    Messages:
    307
    Likes Received:
    0
    GPU:
    EVGA GTX 670 FTW
    Not getting this on Win 7 x64 single GTX 670. SLI still broken?

    Never noticed that with any driver. Maybe our settings are different, I have everything on High/Ultra except Reflections. Is your LOD Distance set to Ultra?
     
    Last edited: Jan 7, 2013
  10. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    good drivers for FarCry 3. however, they didnt fix multiplayer running SLi crashing at the end of a round, guess thats all on Ubi now...
     

  11. beppe_7

    beppe_7 Master Guru

    Messages:
    220
    Likes Received:
    0
    GPU:
    EVGA GTX 980
    same here. 3rd times a charm? :puke2:
     
  12. Mythril

    Mythril Member Guru

    Messages:
    129
    Likes Received:
    2
    GPU:
    EVGA GTX 2080
    I've seen a few people say that when playing Battlefield 3 the game seems to run slightly stuttery. I too have seen this with these new drivers but I have also seen it running butter smooth. This leads me to believe that it is not the drivers but more of a server problem.

    I played several hours yesterday on Caspian Border and some Aftermath. I noticed stuttering on some servers but nothing on others. Just food for thought :)
     
  13. milamber

    milamber Maha Guru

    Messages:
    1,261
    Likes Received:
    50
    GPU:
    MSI 1080 Gaming X
    Seems most 600 series cards are having this issue. I saw a Nvidia rep on another forum acknowledge people's feedback on the issue.
     
  14. milamber

    milamber Maha Guru

    Messages:
    1,261
    Likes Received:
    50
    GPU:
    MSI 1080 Gaming X
    Fixed the crap DX11 performance but DX11Mulithreading still causes glitches.
     
  15. Mraz

    Mraz Master Guru

    Messages:
    664
    Likes Received:
    12
    GPU:
    /
    Its a driver problem, I've noticed it right away after the installation of these drivers.

    I went back to 306.97 and the stutter is gone, its like it stutters every 5-10 seconds no matter what you do, stand in place or move around.

    But I have definetly noticed FPS improvements over 306.97, but still its too bad it stutters like this. -.-
     

  16. Dragondale13

    Dragondale13 Ancient Guru

    Messages:
    1,512
    Likes Received:
    228
    GPU:
    GTX 1070 AMP! • H75
    I got the stutters too after every 310.xx driver installation.This may or may not work for you or others as your cpus are not the bottleneck as in my situation but I've solved my problem by resetting cpu overclock to default before uninstalling drivers.After installing the drivers, setting up precision x, rebooting, applying cpu oc and everything runs as it should with no jitters.I've done this with 310.54, 310.70 & 310.90 and they all work out pretty much the same.Maybe you can try that and see.
     
  17. RedSeptember

    RedSeptember Master Guru

    Messages:
    471
    Likes Received:
    0
    GPU:
    Asus GTX 690 4gb
    We should not need to do that, but thanks for the tip. Will give it a shag.
     
  18. Dragondale13

    Dragondale13 Ancient Guru

    Messages:
    1,512
    Likes Received:
    228
    GPU:
    GTX 1070 AMP! • H75
    My sentiments exactly! But considering how powerful these new cards are with just driver updates (and better ones in the future) I won't be surprised if the cards themselves are having some sort of major impact on most if not all the other components including mb chipsets.I'm just going off of common sense and observation here as I'm by no means an expert, just trying to help.
     
  19. Mythril

    Mythril Member Guru

    Messages:
    129
    Likes Received:
    2
    GPU:
    EVGA GTX 2080
    I've uninstalled the 310.90's and gone back to the 310.70's just to see if there are any more stutters. I've just had one full game on Caspian Border and did not notice any stuttering. Only time will tell as I had games before with the 310.90's that were stutter free. Bite to eat then back to killing "dem n00bs" hehe.
     
  20. kakarot

    kakarot Maha Guru

    Messages:
    1,121
    Likes Received:
    7
    GPU:
    gigabyte 3060ti oc
    Works fine with 580 sli/win 8 so maybe a 6 series issue


    Thanks, it's quite rare but annoying when i see it happen. Its seems limited to a rogue building or bridge here and there. I'm running everything maxed out in game with no AA and the only changes to nvcp profile are HQ filtering, single display performance and max performance
     

Share This Page