NVIDIA GeForce 310.33 Beta Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Michalko, Oct 23, 2012.

  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    P.S. Is the grey screen issue from installing beta drivers because Windows 8 is kicking up a stink about them not being certified or would that stop them from being installed at all if they weren't certified?
     
  2. Wanny

    Wanny Guest

    Darren I suggest that you reboot immediately after installing 310.33 even if they don't ask you for. My first "blink of death" happened when I didn't reboot. Ever since I reboot after the installation, it doesn't seem to bug much.

    edit: I did 2 successful installations so far with reboots on my own. 1 installation was unsuccessful without a reboot.
     
    Last edited by a moderator: Nov 2, 2012
  3. rewt

    rewt Maha Guru

    Messages:
    1,279
    Likes Received:
    15
    GPU:
    Yes
    I got these to install on a fresh install of Win8 x64, however I did see some abnormal artifacts and a black screen during install which worried me for a few seconds (since some dumb guy at Microsoft decided to make safe mode nearly inaccessible). I'm not impressed with performance. WinXP still performs better in most pre-DX10 apps I tested, due to better CPU utilization.

    And what's with that forced vsync on the Windows 8 desktop? It's laggy and it sucks. Maybe that's something Nvidia can help with? It feels to me like a game with hardware cursor but too many pre-rendered frames.
     
    Last edited: Nov 2, 2012
  4. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    @ Wanny - I *did* restart immediately after installing the v310.33 beta drivers! I would have done anyway because of SLI (Afterburner shows a weird memory figure for GPU2 if I don't) but, unlike Windows 7, these drivers requested I restart.

    If I do try these again then I'll do a Custom > Clean install as the process for those is different, as I found out when I installed the v306.97 drivers using that method, over the v310.33 ones, which I didn't. With the v306.97 drivers, my PC uninstalled the drivers, restarted, installed some (presumably) generic VGA drivers, installed the driver then restarted again. That never happened with Windows 7 even when I chose a clean install.
     

  5. GabeA

    GabeA Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    550M@823/1140RAM (GF116)
    Huge improvement in Skyrim (latest non-beta w/Dawnguard and Hearthfire) at 1080p on an OC'd 550m with the mobile 310.33 drivers versus the 306 WHQL. Nice and stable for me so far on this Dell XPS lappy.

    144-shader 823MHz @ 1140MHz RAM -- From 33 to 36fps in Whiterun plains (south), 30 to 34 in the large falmer dungeon (Dawnguard), and 42 to 45 inside Breezehome looking at the fire pit. All graphics settings are on max or above except shadows (high). Also, Anisotropic is driver-forced at 16x for better quality.

    All in all, something like a 10% increase in performance -- a little more where the fps was super low (so the increases there are most welcome!).

    I'm delighted the Nvidia team is still optimizing these drivers for Skyrim. Looks like I'm not the only Skyrim player left, in other words (also, newsflash: new DLC coming soon! Woot!).

    [edit] Also noticed the shrub rendering in particular seems a bit quicker for whatever reason. Extending the range of shrub rendering to something like 15000 now doesn't drop FPS noticeably at all (former "Ultra" setting was 7000). That's a lot of free bushes/foliage!
     
    Last edited: Nov 3, 2012
  6. Pey

    Pey Master Guru

    Messages:
    710
    Likes Received:
    11
    GPU:
    ASUS GTX 980 STRIX @ SLI
    With the last whql i had power limit +132 +180 core +375 mem :( now my boost won´t go over 1100, wtf? :(
     
  7. seaplane pilot

    seaplane pilot Maha Guru

    Messages:
    1,295
    Likes Received:
    2
    GPU:
    2080Ti Strix
    If you overclock these drivers don't play well.
     
  8. GabeA

    GabeA Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    550M@823/1140RAM (GF116)
    6XX series only then. My 550m is nearly at 2x overclock. But yeah, in general Nvidia has been clamping down on OC since the 6XX series and all drivers since 3XX for clocks > 1ghz on older chips.
     
  9. Radical_53

    Radical_53 Ancient Guru

    Messages:
    4,061
    Likes Received:
    115
    GPU:
    EVGA RTX 3080 FTW3
    No issues at all with my overclocks. The same clocks that worked fine before still work fine.
     
  10. Pey

    Pey Master Guru

    Messages:
    710
    Likes Received:
    11
    GPU:
    ASUS GTX 980 STRIX @ SLI
    Yeah, went back to whql, no issues with those.
     

  11. evgenim

    evgenim Master Guru

    Messages:
    237
    Likes Received:
    17
    GPU:
    RTX 2060 OC
    How to diasble PowerMizer ?
    Old utilites are not working with this driver. :(
    Please help...
     
  12. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    745
    Likes Received:
    9
    GPU:
    Geforce GTX 970 @1420
    My overclocks are the same as always with these drivers. Something else probably went wrong with your install.
     
  13. JahPahZzZ

    JahPahZzZ Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    4-Way SLI GTX 670 2GB
    Hey guys, sorry if I'm posting in the wrong section, actually I don't know if my problem is with the hardware, software or driver.

    Well, I'm a proud owner of 4x GTX 670 2GB but unfortunately I can not take properly because my Nvidia Driver crash all the time when I'm playing or even when I'm watching videos. Sometimes the Driver just Crash and the sound freezes, other times Nvidia Driver crashs and the monitor can't find signal but the sound continues.

    Mobo: Rampage IV Extreme (high precision event timer off / using extra power alimentation plug)
    CPU: 3930K
    PSU: Enermax MaxRevo 1500W (voltages OK)
    Driver: 310.33 beta and 306.97 WHQL

    Temps are okay too (Watercooled System).

    What I tried:

    - I tested ALL the possible combinations to find the problem's source.
    All the 4 GPUs are working with no problems when running Single GPU or even 2-Way SLI, but when running 3-Way or 4-Way the driver always crashs, some times in about 15 minutes, sometimes with 45 minutes.

    - I tried flash all the 4 gpus with the same updated BIOS (80.04.31.00.70) but the problem still persists.

    - decreased Core Clock
    - increased GPU voltages

    All the drivers are up to date and using Windows 8 x64 - although the problem also happens with Win 7.


    sorry for my english.
     
  14. Mufflore

    Mufflore Ancient Guru

    Messages:
    12,970
    Likes Received:
    1,430
    GPU:
    Aorus 3090 Xtreme
    As it works ok for some time and then fails, it could be a memory leak of any application/program or heat.

    Blow a large housefan at your graphics cards and see if it improves.

    Check if any process reaches 2GB memory space or if your swapfile sees a lot of activity, be sure to monitor all processes.


    Its also possible that you are running out of video memory and are encountering a bug causing a crash.
    Check video memory use with MSI Afterburner.
    Try turning Anti Aliasing off (to reduce the video memory footprint) and see if it helps.
     
  15. JahPahZzZ

    JahPahZzZ Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    4-Way SLI GTX 670 2GB
    But as I said, I use WC system and temps never go over 48~49ºC. I'm not running out of memory neither.

    Pics with MSI:

    [​IMG]

    [​IMG]

    Lately I've played the new NFS MW and I'm still having problems even with the low gpu usage. :(

    I used MSI Afterburner 2.2.5 and latest EVGA Precision X.
     

  16. Slikar

    Slikar Master Guru

    Messages:
    368
    Likes Received:
    0
    GPU:
    GTX970 WF3
    Do you have fps drops? Why do u need more usage if ur fps is 60?
     
  17. Mufflore

    Mufflore Ancient Guru

    Messages:
    12,970
    Likes Received:
    1,430
    GPU:
    Aorus 3090 Xtreme
    Answered in your other thread.
     
  18. JahPahZzZ

    JahPahZzZ Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    4-Way SLI GTX 670 2GB
    Almost none. Just put "Low Geometry".

    Btw i made a custom driver settings for NFSMW:

    AF: 16x
    FXAA: On
    SLI Rendering Mode: Force Alternate Frame Rendering 2.
    Vsync: Adaptive Vsync Half Fresh - Because I'm using 120hz monitor and the game is 60fps locked.

    You can try override the AA too if you want, but only a few people were successful with that.
     
  19. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,049
    Likes Received:
    569
    GPU:
    EVGA GTX 1080 Ti SC2
    I posted about my dark grey screen (of death!) on a newly upgraded Windows 8 Pro installation over on the newly launched NVIDIA forum and ManuelG has confirmed that they've also been able to replicate the issue but do not know as yet what actually causes it. As such I've held off trying to install these again even though I'd very much like to. Hopefully, NVIDIA will release a certified v310.xx driver in due course, which can't be that far away, surely?
     
  20. buddybd

    buddybd Master Guru

    Messages:
    828
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FTW
    I was successfully able to install it after I uninstalled and deleted the driver from the device manager. And then used Driver Fusion to do another sweep.

    Even after I installed 310.33, Windows Update still showed an update for 306.97 WHQL. I think the Nvidia installer is not good at removing files installed from WU.

    Edit: I just did the Intel INF update (without compatibility mode and using -overall) and my WEI score jumped from 6.5 to 8.1. At least it got something right :p
     
    Last edited: Nov 6, 2012

Share This Page