Nvidia GeForce 185.85 WHQL and Rivatuner 2.24 seem messed up

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by bobmitch, May 7, 2009.

  1. bobmitch

    bobmitch Master Guru

    Messages:
    356
    Likes Received:
    5
    GPU:
    EVGA 1080 TI SC Bl
    Once I had these new drivers installed (185.85 released 5/6/09)...low level fan control still seems to work, BUT, now my ambient and core temps read exactly the same, and the software says No supported drivers detected for thi s display adapter. This could be an issue, because when in 3D mode, bith temps always remain the same...not sure if fan speeds will increase and decrease as needed. Unwinder...any thoughts on how to get these two sets of software to work together? I think the Core temp is correct, but now the ambient, which is normally 6-8 degrees less is locked at exactly the same as the core temp.

    Specs:

    EVGA 3XSLI X58 with i7 920
    EVGA GTX 260 / 216 OC
    Windows Vista Ultimate 64 Bit
    6 GB Corsair Dominator 1600

    Thanks
     
    Last edited: May 7, 2009
  2. 357

    357 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    2x 9800GTX
    I have the same issue after installing 185.85 drivers. Rivatuner says, in the Driver Settings, "No supported drivers detected for this display adapter."

    I'd like to change the fan control from the forceware window.
     
  3. burebista

    burebista Ancient Guru

    Messages:
    1,708
    Likes Received:
    15
    GPU:
    MSI GTX 1060 GAMING X 6GB
    Yep, me too.
    ForceDriverVersion 18585 and all profiles and temps are back.

    [​IMG]

    But no driver setting in main window.

    [​IMG]
     
  4. GanjaStar

    GanjaStar Maha Guru

    Messages:
    1,150
    Likes Received:
    0
    GPU:
    MSI 4G gtx970 1506/8000
    same problem vista64 gtx260
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,250
    Likes Received:
    278
    There are changes in internal driver versioning scheme in this family, the changes need to be supported inside RivaTuner to get these drivers detected properly. So until 2.25 is released (ETA is June), use the workaround provided by burebista a few posts above.
     
  6. bobmitch

    bobmitch Master Guru

    Messages:
    356
    Likes Received:
    5
    GPU:
    EVGA 1080 TI SC Bl
    Unwinder...thanks...

    Also...I do believe that even though the temps are not reporting properly...I did fire up 3D mode and saw that the fan on my GTX 260 did increase as the Core temp did...so I don't think the control is broken..just the temps...are not reporting properly. Also,, when you click on burebista's guide...it says page no longer available...

    Bob
     
  7. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,250
    Likes Received:
    278
    What guide? Just do what he said in his posting in this therad: set ForceDriverVersion to 18585 in Power User tab, that all you need to do to get it working.
    Also, temperatures are not reported improperly, you're just seeing a temperature read from different source. With no supported driver detected RT just defaults to external ADT7473 sensor as a core temperature graph provider. You can get the same readings with any older driver if you manually change provider in core temperature graph properties and select ADT7473 as a temperature provider there.
     
  8. bobmitch

    bobmitch Master Guru

    Messages:
    356
    Likes Received:
    5
    GPU:
    EVGA 1080 TI SC Bl
    I went to the Power User tab, where is the place to forcedriverversion?

    Never mind...found it
     
  9. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,250
    Likes Received:
    278
    Congrats ;)

    Anyway, here is short instruction for those who never used Power User tab before:

    Open <Power User> tab -> Press <Open database> button -> Browse for RivaTuner.rtd database file (located in the application root folder) -> Expand <System> node -> Ensure that <Hexadecimal display> button is NOT pressed (otherwise 18585 will be treated as a hexadecimal value instead of decimal one) -> Double click <ForceDriverVersion> and enter 18585
     
  10. bobmitch

    bobmitch Master Guru

    Messages:
    356
    Likes Received:
    5
    GPU:
    EVGA 1080 TI SC Bl
    What I did was open Power user...then RIVATUNER System...Scrolled down to Forcedriverversion and manually typed in 18585. I got there in a different way, but my two temps are now 7 degrees apart.
     

  11. _Rnesto

    _Rnesto Master Guru

    Messages:
    264
    Likes Received:
    0
    GPU:
    8800GTS 320MB
    I never install drivers that aren't RivaTuner certified.
     
  12. Venomsword

    Venomsword Member Guru

    Messages:
    139
    Likes Received:
    1
    GPU:
    Asus STRIX-GTX1080
    No problems with last 185.85 WHQL and Riva Tuner on Win XP 32 bit.
     
  13. alxtorrentazos

    alxtorrentazos Master Guru

    Messages:
    216
    Likes Received:
    0
    GPU:
    MSI 980Ti ArmorX2.
    WISE WORDS!!! :)

    BTW and maybe a little offtopic question, right now I´m using XP32bits and I want to try Windows 7100 x64......how do I export rivatuner settings (scheduler, launcher, plugin settings, etc) to import later in Win7??
    TIA.
    Alx
     
  14. LatinoRamon

    LatinoRamon New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    nVidia EVGA 9800 GX2
    Riva Tuner is not working with the last driver 185.85 WHQL, on Windows Vista.
    Not supported drivers detected. :(
    sorry, your right @Unwinder
     
    Last edited: May 8, 2009
  15. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,250
    Likes Received:
    278
    LatinoRamon

    Really? That's something really new for this thread. Take reading lessons, mate.
     

  16. damnit72

    damnit72 Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    2x8800GTs | 5770
    ROTFL ... thanks for the workaround Unwinder :)
     
  17. zagood

    zagood Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    BFG GTX 260
    Thanks UW. Working for me.
     
  18. bardcan

    bardcan Guest

    legend unwinder
     
  19. sm007h

    sm007h Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    NVidia 8800 GTS 512mb
    I found all the settings in registry keys, so I export the ones I want to keep and back them up that way.
     
  20. Warl0rd

    Warl0rd Member Guru

    Messages:
    108
    Likes Received:
    0
    GPU:
    Asus R9 280X DirectCU II
    Thanks, it works (as expected lol).

    it still shows the same message but at least we can open the costumize option and change things :)
     

Share This Page