nVidia Forceware 195.39 Beta

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by TeethDestroyer, Oct 29, 2009.

  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,071
    Likes Received:
    585
    GPU:
    EVGA GTX 1080 Ti SC2
    So it reads to me like even with a clean install of these drivers, RivaTuner is still a tad unstable.

    I did do an upgrade install of 195.39 from 191.07 admittedly so I was going to try doing a clean install tonight. Don't think I'll bother now. Instead I'll monitor the feedback on these drivers first while I wait for newer official WHQL drivers. In my experience the WHQL drivers tend to be (but not always) less problematic overall. The 191.07 ones for example performed flawlessly in Vista.
     
  2. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    the perfomance for Shift went right down the crapper! i only got 11 fps at the start of a race. wow ... WTF.
     
  3. Squall Leonhart

    Squall Leonhart Banned

    Messages:
    1,331
    Likes Received:
    0
    GPU:
    Geforce GTX 275 896
    i strongly suggest you do a clean install if you stick with these, the mixture of nvapi and old cpl's and all the rest of that stuff can lead to interesting results...... like a gpu suddenly overclocking 300mhz and frying itself...
     
  4. Squall Leonhart

    Squall Leonhart Banned

    Messages:
    1,331
    Likes Received:
    0
    GPU:
    Geforce GTX 275 896
    its following the need for speed franchise exceedingly well :banana:
     

  5. sideband

    sideband Member Guru

    Messages:
    149
    Likes Received:
    1
    GPU:
    GTX1070
    os??
     
  6. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    it ran smooooth before on all the latest drivers. :bang:
     
  7. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    Win7 x64
     
  8. Francko1979

    Francko1979 Member

    Messages:
    44
    Likes Received:
    0
    GPU:
    EVGA GTX 980Ti SC SLIĀ“ed
    Check the links again, NVIDIA just reuploaded the drivers with some changes and they are now dated 10/30/2009.

    They say they solved the performance issue on NFS Shift on the updated release notes.

    http://www.nvidia.com/Download/Find.aspx?lang=en-us
     
  9. Grahf

    Grahf Ancient Guru

    Messages:
    1,817
    Likes Received:
    0
    GPU:
    MSI N580GTX Lightning
    Do these still have the alt+tab bug on XP 32 bit?
    I browsed through the thread and didn't see any mention of it...
     
  10. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    great. thx for the heads up.
     

  11. Taint3dBulge

    Taint3dBulge Maha Guru

    Messages:
    1,133
    Likes Received:
    3
    GPU:
    3080
    I dont know how people can have all the problems they have with installing new drivers Iv been doing this for years now. Iv never had a lock up never had BSOD never had a single problem. I just installed these and ran Crysis for 6 hours without a hickup! Great drivers for that, Also played COD w@w... Amazing quality and smoothness. Also tryed GTA4 got afew extra FPS there no big diffrance in anything on that game.

    I dont know why you guys have all your problems there has to be something going on with the way you have windows set up... Im using old crap and it works great... LOL Anyways sorry for gettin alittle off topic. Im just tired of seeing the same posts and Iv never had a problem once! :nerd::pc1:
     
  12. Shadowdane

    Shadowdane Maha Guru

    Messages:
    1,434
    Likes Received:
    71
    GPU:
    MSI RTX 3080 Suprim
    I'm going to have to give these a try when I get home. I've been meaning to finish Crysis Warhead, might as well do that on the new drivers! :)
     
  13. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    still the same crap performance. 11 fps at the start of a race. everything else ive tried sofar runs good. what the heck did NV do to screw up Shift ....
     
  14. Killersjp

    Killersjp Member Guru

    Messages:
    127
    Likes Received:
    36
    GPU:
    Nvidia RTX 3090 FE
    yes burnt_ram I have the same problem with shift, but mine flashes aswell, If I disable AA then it seems to run fine. whoever said it fixes shift is wrong.
     
  15. v4npro

    v4npro Master Guru

    Messages:
    749
    Likes Received:
    0
    GPU:
    MSI GTX 1080TI Duke
    So what other changes did they do to the new set?
     

  16. chispy

    chispy Ancient Guru

    Messages:
    9,225
    Likes Received:
    1,480
    GPU:
    Strix RTX 3090 H2O
    Not good drivers for NFS Shift :( , tried on my spare rig GTX 285 on W7 x64 , Shift runs 25fps lol , back to 191.07 whql and all its fine again +80fps smooth as butter in Shift :).
    In my opinion dont install this if you are playing Shift.
     
  17. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    your 25 fps sure beats my 11 fps lol. sure hope they fix this for the final release!

    and why such a big jump from 191 to 195. things that make you go HMMMM.
     
  18. Taint3dBulge

    Taint3dBulge Maha Guru

    Messages:
    1,133
    Likes Received:
    3
    GPU:
    3080
    Im going to try NFS Shift tonight see if i chitty performance in it... I wonder if its just shotty programing in the game. seems like u guys always complaining about stutters and this and that. always blaming NV when it could be the games fault and its hard to get ride of something when a game has shotty programing like fallout 3
     
  19. chispy

    chispy Ancient Guru

    Messages:
    9,225
    Likes Received:
    1,480
    GPU:
    Strix RTX 3090 H2O
    :giggle2:
     
  20. TheHunter

    TheHunter Banned

    Messages:
    13,405
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    I've been using these 195 from yesterday just fine..hm lol, dunno whats your issues, NFS Shift starts ok, usually 55fps or so and camera stutters a bit when it circles around the car, but when the race starts it goes back to steady 60-80fps..and maybe it stutters on some parts of the race but it gets better in 2nd lap.
    I saw allot worse performance with 191.07, i actually had a black screen for a millisecond on that part where it usually stutters, never saw that before... i went back to 186.18, now i gonna try this oct 30 again.


    Btw, Cod waw works and looks much sharper with these 195, TF2 worked fine too.. RE5 maybe lost 1-2fps, GTA4 much much better compared to 191.07; thats in win7u 32bit.
     

Share This Page