NVIDIA Forceware 163.67 Download & Discussion here!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Copper, Sep 10, 2007.

  1. Flukester

    Flukester Banned

    Messages:
    1,505
    Likes Received:
    0
    GPU:
    eVga GTX 260 Core216 896M
    Awesome, thanks man. That's helpful too because I play most of those. I didn't have problems with Lost Planet but likely cuz I'm playing DX9...eh, I think. MOH:A very hopeful this will get rid of the blur+lag thingie... only real prob I had with MOH:A and Ghost Recon 2, I was actually a little laggy and was gonna drop my resolution thinking I was going a little crazy.. Can't wait! Oh, looky here my watch says, Time to Leave! Woo.. going to give em a run and will post back!
     
  2. Jasonz302

    Jasonz302 Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    8800GTS 320 @ 648/1890
    I haven't done any extensive testing yet, but thus far I've noticed no difference with these.

    I OC'd my 8800GTS to 621/1800 as before with no problems under XP32.

    3dMark score is the same (a tad higher, actually, but that's probably a normal variance), and I ran some Bioshock FRAPS benchmarks which yielded no differences from before.

    I did notice some stuttering with the old drivers, but I haven't really played anything long enough yet to see if it still occurs.
     
  3. iZomBaDi

    iZomBaDi Active Member

    Messages:
    95
    Likes Received:
    0
    GPU:
    Asus Titan X no oc
    So far I have had lockups in Stalker and Bioshock using this latest beta, with SLI enabled; Stalker worked fine in the previous beta: 163.44.

    Other games such as CSS, COD2 and Far Cry work fine. I will continue the testing and report back later.

    Getting the latest demo of Enemy Territory :)
     
  4. TylerTron21

    TylerTron21 Guest

    i hope like hell this accually improves performance for 8 cards....


    downloading.
     

  5. DES_MX

    DES_MX Master Guru

    Messages:
    770
    Likes Received:
    1
    GPU:
    GTX480 850/4400 1.075v
    Ok done some extensive Bioshock playing, and i can confirm - it does perform even better with these. No problems OC'ing as well. 675/1900 as before, rock solid! Installing Quake Wars...
     
  6. D_worth

    D_worth Maha Guru

    Messages:
    1,041
    Likes Received:
    0
    GPU:
    nvidia
    downloading going to see if aa works with bioshock DX10.
     
  7. Layne

    Layne New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    PNY GeForce 8800GTS 320MB
    Just in case anyone else has the same question I did, I found the answer @ NVIDIA's site:
    http://www.nvidia.com/object/vista_driver_x86_installation_instructions.html

    Thanks.
     
  8. mart280

    mart280 Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    Palit GRP 1070-2075-9314
    What are your stock speeds m8.
     
  9. TylerTron21

    TylerTron21 Guest

    does the same for me with the 163.16's

    but riva says my oc is workign in 3dmode. but i get ZERO score difference in anything. like aqua3, 3dmark03 and 06
     
  10. -=GQ=-

    -=GQ=- Member

    Messages:
    35
    Likes Received:
    0
    GPU:
    GTX 260 @ 722/1485/1220
    Did you try adding " -dx9" to the end of your bioshock desktop shortcut target (this works for me in Vista x64 with an 8800GTX - AA forced in the nvidia control panel of course)?
     

  11. DES_MX

    DES_MX Master Guru

    Messages:
    770
    Likes Received:
    1
    GPU:
    GTX480 850/4400 1.075v
    Well the same as for anyone else with non OC'd 8800GTS... around 500 core and 1600 memory...
     
  12. _RA_

    _RA_ Master Guru

    Messages:
    223
    Likes Received:
    0
    GPU:
    Gigabyte GTX 970 Mini ITX
    what's this "slowdown" bug?
     
  13. Sasquatch

    Sasquatch Master Guru

    Messages:
    383
    Likes Received:
    0
    GPU:
    Msi GTX 970 Gaming 4G
    not installing - no hardware found

    before I install manually, is anyone else having issues with this driver not installing?
    After is extracts & initializes setup, it stops & says unable to find compatible hardware.
    I'm running an eVGA Geforce 6800 GT 256MB PCI-E. Its a discontinured card but it always shows up as a "Geforce 6800 series" which the .ini file shows support for.
    WinXP SP2 32bit

    Any ideas?
     
  14. moab600

    moab600 Ancient Guru

    Messages:
    6,421
    Likes Received:
    311
    GPU:
    Galax 3080 SC
    Damn, again like the 163.67 i have wierd smooth-mouse lag, hard to explain i hope it can be figured out, also CNC Generals+UT2004 does not load with this driver.
     
  15. blunden

    blunden Master Guru

    Messages:
    929
    Likes Received:
    8
    GPU:
    ASUS RTX 3080 TUF
    Will try them out. Seems like a good set of drivers.
     

  16. DooGie

    DooGie Master Guru

    Messages:
    567
    Likes Received:
    10
    GPU:
    EVGA GTX 970 SC
    moab600, what do you mean "wierd smooth-mouse lag"?
    Is it like a sort of reverse acceleration where if you move your mouse fast you get negative acceleration. If so i'm getting the same with the last few nVidia drivers but had started blaming my mouse.
    Using a Razer Copperhead.
     
  17. Jasonz302

    Jasonz302 Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    8800GTS 320 @ 648/1890
    Well I've tried more extensive Bioshock testing, and my results are actually very positive.

    I don't think my raw FPS has improved to any noticeable degree, however, stuttering is nearly eliminated. Before, I'd get slight hitches when entering a new and/or large area, or when a group of enemies would first leap out, but that issue is almost completely gone with these drivers.

    I didn't really give the problem much attention before, since I'd gotten used to it, but now that it's nearly eliminated, it's impressive to see how much more smoothly the game runs.
     
  18. ogheeren

    ogheeren Master Guru

    Messages:
    244
    Likes Received:
    0
    GPU:
    SLI 8800 GTS 512 760C/1900S/2100R
    Same bulls*** like all 163.xx drivers for vista, they don't work with many dvi/hdmi connections to hdtv. nvidia still sucks donkeyballs. well, at least better performance on oldschool crt and small cheap tfts. yeah, nvidia knows to satisfy their well paying customers....
     
  19. Waylander

    Waylander Guest

    Tried these, think I'll keep 'em...

    played a bit of bioshock not sure there any fps increase, but the game feels smoother, if that makes sense..

    Played DIRT, big difference there, much improved...

    Lost planet DX10 feels much better as well..
    gonna rake back to see if I have a note of previous fps so I can compare..

    but these do feel like keepers for now...
     
  20. K2D

    K2D New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    XFX 8800GTS XXX
    Still I've got the "nvlddmkm" error :'(

    I was so happy about this update, as I've been suffering from an error which seems to show up very often on users with Windows Vista and Geforce G80 (8800GTS for instance) on their pc's

    Problem discription:
    While playing (Bioshock) suddenly the screen freezes (while the sound continues) then the screen turns black...and returns to the desktor giving me the system tray notification:
    Display Driver Stopped Responding and Has Recovered - nvlddmkm nVidia Driver


    After Installing this driver, the game did not crash for almost 15 minutes.
    Then I had to quit the game for a second...as I started it again the error came back...as I had it before...after 1-2minutes of gaming (or even during loading screen) the game crashes as mentioned...

    Is there still no solution at all?
    I'm just about to send back my GPU...please help me!!!
     

Share This Page