NVIDIA Forceware 163.67 Download & Discussion here!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Copper, Sep 10, 2007.

  1. eRa`

    eRa` Ancient Guru

    Messages:
    1,825
    Likes Received:
    1
    GPU:
    Palit GeForce GTX 570
    Power User -> RivaTuner / NVIDIA / Overclocing / ShaderClockRatio
     
  2. RavenY2K3

    RavenY2K3 Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    RTX 3080 MSI Gaming
    Tried these over the weekend, they were the only set of Forceware drivers that caused crashes, "the system has recovered display driver blah blah blah" errors. Gone back to 163.44 they seem to be more stable for me, that was on the system in my sig running Vista U x64, Bioshock only ran for 30 mins max as did MoH Airbourne, although GRAW2 worked better for me. Just my 2 cents. :D
     
  3. dabrooks

    dabrooks Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    SLI EVGA GTX 980Ti Gaming
    Had me going there for a minute, thought there were new ones hot off the press. Those are the hotfixes that were available as betas a couple of months ago, final versions released last month. Indeed, if you haven't applied yet, do so, they will help.
     
  4. Bi2L

    Bi2L Active Member

    Messages:
    52
    Likes Received:
    0
    GPU:
    2x9800gt 1x9500gt
    Problem with nvidia 5950ultra and 163.67 at winXP32. When i trie to open any program using Direct Draw or OpenGL computer just hold on, strange litle lines apears to whole screen and i need to reset it. (programs like: Pinnacle Studio, Starry Night 6 plus, ).
    Same other problem With nvidia 6600 and 163.67 at winxp32 is: when i uses any program using direct draw or OpenGL after a little time (10-15 minutes) computer hold on, no responce at all and i need to reset it.
    i am back to 162.18 whdl and all are alright, works perfect.
     

  5. MwR

    MwR Master Guru

    Messages:
    218
    Likes Received:
    0
    GPU:
    GTX 980/4GB SLi
    Ok, so this whole "setup seperately" thing starts from 163.67 onwards, right?
    Say, how do I setup those?
     
  6. eRa`

    eRa` Ancient Guru

    Messages:
    1,825
    Likes Received:
    1
    GPU:
    Palit GeForce GTX 570
    Just read the RivaTuner context menu, there is all info you need.
     
  7. blue5

    blue5 Banned

    Messages:
    3,964
    Likes Received:
    0
    GPU:
    evga 9800GTX (685/1115)
    when I tried to apply the patches it said "these updates do not apply to your system"
     
  8. MwR

    MwR Master Guru

    Messages:
    218
    Likes Received:
    0
    GPU:
    GTX 980/4GB SLi
    [​IMG]

    Nevermind what I said a day before, and now I've got the things worked, seems to be in good order, ran 2 3DMark06 in a row, World in Conflict and Company of Heros benchmark to see how things works, the pic is the monitoring stat...

    This runs @610/1000MHz, shader ratio setup @ -1 as suggested, and 70 degrees at full load, 10 minutes needed to cool down to idle temp of 56 degrees.

    Is this still a good stat?
     
    Last edited: Sep 18, 2007
  9. chuckdizzle03

    chuckdizzle03 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    GeforceFX 6800GT 256mb SLI
    Well I must say most of you all are lucky. I still have no SLI option whatsoever!
    I am running 2 Evga 6800GTs 256mb both show up in the hardware list but I have no option to enable SLI. I reinstalled the drivers time and time again with no success. I used both control panel to remove the old drivers and the driver cleaner. I downloaded and installed all of the appropriate hotfixes. Anyone have any suggestions?
     

Share This Page