Nvidia Fast Sync Thread

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Vbs, May 28, 2016.

  1. mr1hm

    mr1hm Active Member

    Messages:
    83
    Likes Received:
    0
    GPU:
    GTX 970 G1 Gaming
    been using it now for a few days and i'm pretty sure i have to re-apply fast sync after i reboot/shut down my computer.

    in inspector, it still shows that fast sync is the setting selected but, in-game, the FPS behaves oddly (fluctuates wildly all the time as if there was no v-sync at all). it's only after i re-apply the fast sync setting, my FPS starts locking onto 144.

    this is on 368.25
     
  2. OrdinaryOregano

    OrdinaryOregano Master Guru

    Messages:
    426
    Likes Received:
    1
    GPU:
    MSI 1080 Gaming X
    Same here.
     
  3. boogertwilliams

    boogertwilliams New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GTX970 / 4GB
    I just discovered this yesterday and I am blown away. Using GTX970 with a 75hz screen. My Fallout 4 and Witcher 3, and also Dead Island Definitive edition became smooth as silk! I could not believe my eyes. Felt like I had got a new GPU.
     
  4. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    6,193
    Likes Received:
    632
    GPU:
    MSI GTX 1070
    Did it remove the terrible Mouse Lag for Fallout 4?
     

  5. boogertwilliams

    boogertwilliams New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GTX970 / 4GB
    I dont feel any mouselag in Fallout 4 now.

    I just enabled it on Dying Light too, it's so fast and smooth it's unreal. WTF? Never imagined how much the sync to the monitor was affecting the speed of the graphics.
     
    Last edited: Jun 5, 2016
  6. VAlbomb

    VAlbomb Member Guru

    Messages:
    146
    Likes Received:
    4
    GPU:
    Nvidia G1 Gaming GTX 970
    If you have to play with Vsync enabled and have CPU/GPU to spare lowering the Maximum Pre-rendered frames to 1 can make mouse lag feel almost as no vsync at all not there but pretty close and without tearing.

    I personally have it set to 1 on global settings, it's a good compromise between image quality, gameplay and power consumption specially if you play at 1980x1080 60Hz without a G-sync monitor and strong GPU/CPU combo.

    I have yet to try FastSync in most games but I probably won't want my GPU to work at max trying to pull 200FPS so pre randered frames is a good compromise for without having to buy a g-sync monitor.

    The GTX1080 whitepaper says "Fast Sync is best tested with high FPS DX9 games"

    http://international.download.nvidi...al/pdfs/GeForce_GTX_1080_Whitepaper_FINAL.pdf
     
  7. Pyrage

    Pyrage Master Guru

    Messages:
    381
    Likes Received:
    32
    GPU:
    580 CF@ 1470
    Do you guys set the vsync tear control to adaptive instead of standard when using fast sync or something?

    I can't help but get massive stuttering when using this. Considering that some people with 970's are getting good results from this, I can't help but feel like i'm doing something wrong :/
     
  8. Krzyslaw

    Krzyslaw Member Guru

    Messages:
    197
    Likes Received:
    52
    GPU:
    MSI GTX1060 6GB
    I set tear control to 0x00000000.

    On laptopvideo2go they said to set it like this
     
  9. HonoredShadow

    HonoredShadow Ancient Guru

    Messages:
    4,266
    Likes Received:
    10
    GPU:
    MSI 980Ti+KS800 TV
    I have a few questions. When I enable this with Nvidia Inspector is it global or per game?

    If it's global how do I then select it? Thanks guys.
     
  10. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,412
    Likes Received:
    1,466
    GPU:
    GTX980 SLI
    afaik it's global, and it kicks in when vSync is disabled in-game

    Did with DOOM for me, vSync off, locked itself at 60fps, but there was still tearing, in menus it was like 200fps or something
     

  11. HonoredShadow

    HonoredShadow Ancient Guru

    Messages:
    4,266
    Likes Received:
    10
    GPU:
    MSI 980Ti+KS800 TV
    Ok thanks for that so it's auto as long as game has VSync off and game is proper fullscreen. I guess it's ok to limit game to 60? My TV is 60 so will it still auto lock fps to 60?

    Thanks for your help. Will try this downstairs in a bit.
     
  12. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,412
    Likes Received:
    1,466
    GPU:
    GTX980 SLI
    I think fast sync does the limiting for you yea, if your card can push 120, it will lock to multiples of your refresh rate (I think)

    Only played around with it in DOOM so don't know that much about it tbh
     
  13. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,821
    Likes Received:
    1,260
    GPU:
    MSI RTX 2070 Armor
    Yeah, max prerendered frames = 1 with triple buffering on should theoretically give no input lag with Vsync.
    As long as triple buffering works correctly. It can be enabled from NV CPL but doesn't work in all games anyway, depends on the way the renderer operates I think.

    Plus most games with built-in triple buffering don't actually do proper triple buffering but double buffer + render-ahead queue.
    Especially with such games limiting the number of prerendered frames can help with input lag.

    (http://www.anandtech.com/show/2794)
     
  14. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,980
    Likes Received:
    324
    GPU:
    RTX 2080 OC
    As with any setting this depend on where you enable it. If you enable it in Global Profile then it's global, if in an app profile then it's for that app only.
     
  15. Terepin

    Terepin Master Guru

    Messages:
    654
    Likes Received:
    4
    GPU:
    GTX 1080
    VSync + frame limit significantly reduces, or even completely removes input lag. I was with VSync by accident and it was awful. I didn't know why mouse felt so laggy. Then I noticed I forgot to re-enable frame limit. And BUM, it was pitch perfect again.
     

  16. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,980
    Likes Received:
    324
    GPU:
    RTX 2080 OC
    Frame limit here just removes some frames from flip queue. You can get the same result by using prerender limit = 1 which would be a more proper way of doing this.
     
  17. dreamlord

    dreamlord Member Guru

    Messages:
    111
    Likes Received:
    0
    GPU:
    MSI GTX650 1GB GDDR5 OC
    kepler not supported for fast sync?

    i don't have that option with latest drivers...
     
  18. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,411
    Likes Received:
    1,497
    GPU:
    Zotac GTX980Ti OC
    Just 1 frame to render is still laggy at times. Try Quake4 vsync, imo it has the worst input lag by far.


    1frame+60fps limit makes it near 0, or not really noticeable at all, just like Terepin said.
     
  19. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,717
    Likes Received:
    372
    GPU:
    EVGA 1070Ti Black
    its hidden in nvcp you have use nvidia inspector 0x18888888

    it all said in the original post
     
  20. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,980
    Likes Received:
    324
    GPU:
    RTX 2080 OC
    Pre-render limit is a D3D only setting, no? Quake 4 is OpenGL.
     

Share This Page