Nvidia Control Panel does not install?.Driver install takes a long time? - Read This!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by RaXelliX, Jun 24, 2009.

?

Have you had any problems with this bug?

  1. Yes - Driver install takes abnormally long time

    0 vote(s)
    0.0%
  2. Yes - Nvidia Control Panel does not install properly

    4 vote(s)
    23.5%
  3. Yes - Both previous options

    1 vote(s)
    5.9%
  4. Yes - Some other nvidia installer related bug

    0 vote(s)
    0.0%
  5. No - Everything always installs fast and control panel is present

    12 vote(s)
    70.6%
  1. RaXelliX

    RaXelliX Member Guru

    Messages:
    181
    Likes Received:
    2
    GPU:
    Nvidia GeForce GTX 1080
    Im not sure exactly when it started or with what version,but i started hearing this issue with 180+ series drivers and to date nvidia has not fixed it!

    Symptoms:
    *Installing drivers takes more than 8 minutes even on a fast PC
    *Nvidia Control Panel is nowhere to be found after install
    *Driver fails to install properly on DualGPU cards

    Solution:
    *Use either WinRAR on 7zip to extract drivers to subdirectory(The driver exe is nothing more than zip archive).
    *Remove(or delete) the PhysX and 3DVision installers from folder and install driver trough setup.exe


    Feel free to report any other issues this solution solved and i`ll add them to the first post.

    Note that this solution does not solve all problems you have while installing nvidia display drivers.Such problems include:
    *Not removing old drivers properly
    *Driver does not support your card
    *Invalid INF

    And so on...

    3 videos.See for yourself:
    http://www.youtube.com/watch?v=xMYvpuUvhps
    http://www.youtube.com/watch?v=fc9sbu5PAs8
    http://www.youtube.com/watch?v=Lx7pp0GQM8M
     
    Last edited: Nov 27, 2009
  2. philheckler

    philheckler Master Guru

    Messages:
    775
    Likes Received:
    0
    GPU:
    gtx470 SLI
    This solution worked for me! - but i can see a problem here if your having this issue with a fresh install of windows and you actually want the physx software... for me it was ok as I aready had the same ver of Physx installed that came with this package.
     
  3. RaXelliX

    RaXelliX Member Guru

    Messages:
    181
    Likes Received:
    2
    GPU:
    Nvidia GeForce GTX 1080
    Well just move the PhysX installer to some other folder and install separately.
    My guess is that the nvidia installer(setup.exe) tries to install PhysX first and succeeds but after that it cant properly install the driver.Not to mention all this takes way too long.PhysX and drivers installed separately in total of 2 minutes.Nvidia really needs to adress this problem eiter by:

    *Providing separate PhysX and Driver installers by def(current def is both in same exe although you can get PhysX separately)

    Or:

    *Create a new and better unified/optimized installer that installs both things properly within a reasonable time.I have also notified Nvidia of this problem.If i get any response i`ll post it here
     
  4. philheckler

    philheckler Master Guru

    Messages:
    775
    Likes Received:
    0
    GPU:
    gtx470 SLI
    In my case the i found the driver component had installed (new driver version was installed when i checked in device manager) but no control panel , so it seems the physx installer somehow breaks the control panel install...
     

  5. Squall Leonhart

    Squall Leonhart Banned

    Messages:
    1,331
    Likes Received:
    0
    GPU:
    Geforce GTX 275 896
    The driver inf triggers the installation of the physx driver, the most likely issue is the driver isn't elevating the physx installer properly causing it to error out.
     
  6. GSXR1300K

    GSXR1300K Banned

    Messages:
    27
    Likes Received:
    0
    GPU:
    8800gts g92x2 sli
    i get this problem and always have. it happens after a total cleanup with driver sweeper or dh driver cleaner "back when it was free" and ccleaner. it is a conflict between the chipset cp and the gpu cp. for some reason if the gpu cp isnt updating an existing chipset cp on an nvidia board then you will ened up with no cp at all, at least on my board. i just reinstall my ide drivers from the chipset install gui and then restart and do the gpu drivers. has worked like a charm for going on three years.
     
  7. Squall Leonhart

    Squall Leonhart Banned

    Messages:
    1,331
    Likes Received:
    0
    GPU:
    Geforce GTX 275 896
    never had that problem. ever.
     
  8. RaXelliX

    RaXelliX Member Guru

    Messages:
    181
    Likes Received:
    2
    GPU:
    Nvidia GeForce GTX 1080
    Nvidia response:

    See.Even Nvidia itself reccommends Driver Sweeper :) .
     
  9. GSXR1300K

    GSXR1300K Banned

    Messages:
    27
    Likes Received:
    0
    GPU:
    8800gts g92x2 sli
    what nvidia boards have you had. this is my only one and it has needed the chipset cp reinstalled prior to installing the gpu drivers every time i do a thorough cleanup in between gpu drivers.
     
  10. RaXelliX

    RaXelliX Member Guru

    Messages:
    181
    Likes Received:
    2
    GPU:
    Nvidia GeForce GTX 1080
    Maybe you clean bit too much and components of the chipset driver are cleaned too?.Hence the need to reinstall them.Maybe when parts of the chipset driver are not present there may be unforseeable complications installing display drivers.

    Ofcorse the fact thet those with non-nvidia cipset MB-s are having the same problem blows this out of the water.
     

  11. HarryRag

    HarryRag Member Guru

    Messages:
    117
    Likes Received:
    0
    GPU:
    ASUS GTX680-DC2O-2GD5
    He/she may be lucky not to be on a raid install :nerd:

    If you uninstall a nvidia gfx driver, only uninstall thatone if you also have a nvidia chipset base motherboard, if you uninstall all, that's a horror scenario

    But DS does lots of nice stuff, just run it in safe mode.
    If you restart the PC and get an error that the grafics stuff isn't supported, just reboot to safe mode, install gfx driver, and to make sure all is installed well (for troubleshooting manner) install the same driver again in normal mode after the reboot from safe mode :banana:
     
  12. philheckler

    philheckler Master Guru

    Messages:
    775
    Likes Received:
    0
    GPU:
    gtx470 SLI
    I first saw this problem after a fresh install of win7 so i doubt it's a driver cleaning issue...
     
  13. RaXelliX

    RaXelliX Member Guru

    Messages:
    181
    Likes Received:
    2
    GPU:
    Nvidia GeForce GTX 1080
    Yep i also saw this when i tested Win7 RC.I mentioned this in my response to nvidia too.Win7 RC was clean install...
     
  14. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,062
    Likes Received:
    578
    GPU:
    EVGA GTX 1080 Ti SC2
    I've been installing all the 18x.xx series drivers and they've all worked fine for me. I usually install over the older ones though as that method generally works great for me. All my games run OK anyway.

    I think I had a "couldn't install control panel" error with the first 185.xx drivers, the ones with ambient occlusion, but oddly the control panel was actually working fine and displayed the correct version number.

    Since then all the newer drivers have installed perfectly along with the PhysX ones too. Whatever is causing the issue for some people is related to their setups rather than the driver installation itself otherwise everyone would have the same problem right?
     
  15. GSXR1300K

    GSXR1300K Banned

    Messages:
    27
    Likes Received:
    0
    GPU:
    8800gts g92x2 sli
    i think it actually has to do with me running a raid array and in doing so the twp cp's become intertwined because of showing the array storage information. i only use the display driver cleaning method with driver sweeper and the problem still exists whether or not i use ccleaner.
     

  16. XcroN

    XcroN Master Guru

    Messages:
    332
    Likes Received:
    0
    GPU:
    GTX 1080Ti Aorus xtreme
    i had some problems to open the control panel,it took too long to open.reinstalled the driver,working fine
     
  17. RLCF

    RLCF Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    Crossfire R9280X/3GB
    This NvCP installer problem started when I used the driver sweeper.
    I try everything to fix this : registry and files cleaners, only GPU driver (no nforce), first nforce 15.23 after GPU driver and vice versa , erased via DOS all files (less NV raid infs) in the System32 and SysWOW64 folders, . In safe mode the windows installer service doesn't work. NVcp just works with 182.xx to below. I can only hope a new driver version and if does not solve a new installation of Windows (maybe WIN7 X64, I'm tired of 1.5 minutes WIN6 X64 Boot time) :bang:
     
  18. RaXelliX

    RaXelliX Member Guru

    Messages:
    181
    Likes Received:
    2
    GPU:
    Nvidia GeForce GTX 1080
    You clearly have some bigger issues here why NVCP does not work.
     
  19. Squall Leonhart

    Squall Leonhart Banned

    Messages:
    1,331
    Likes Received:
    0
    GPU:
    Geforce GTX 275 896
    run the driver installer with admin elevation set in the compatibility settings, the MSI file might not be getting elevated to be able to run properly. :\
     
  20. RaXelliX

    RaXelliX Member Guru

    Messages:
    181
    Likes Received:
    2
    GPU:
    Nvidia GeForce GTX 1080
    Current status in Nvidia help is:Researching

    In my response i asked them to forward this issue to someone in the driver writing/assembly team.Doubt it happens tho as Nvidia is a big company but i suppose its better than sitting and complaining how bad nvidia is
     

Share This Page