Nvidia bios mod to fix random downclock?

Discussion in 'Videocards - NVIDIA GeForce' started by cutepuppy671, Jul 19, 2009.

  1. Stonedofmoo

    Stonedofmoo New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Geforce GTS250 1024M
    Hi there

    I will give another manufactueres BIOS a try then. The asus is certainly meant to have a low power mode as demonstrated in the model they sent to Tomshardware, you can see those results here

    http://www.tomshardware.com/reviews/geforce-gtx-260,2286-20.html

    However I wonder if they sent out a special card to them because having posted in a few places on the net other people have had my issue.

    I'll keep you updated.
     
  2. Stonedofmoo

    Stonedofmoo New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Geforce GTS250 1024M
    Well as an update I tried an EVGA GTS250 1024Mb BIOS, flashed it and instantly I just had a screen of corruption :(
    Luckily I could remember the commands and files in dos and was able to flash back to the old bios while running blind :)

    So it looks like Asus has a modified BIOS. I guess there is nothing else that can be done to activate the 2D mode?
     
  3. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Yes, it definitely wouldn't surprise me that ASUS had provided a "special" card for the Tomshardware evaluations ?

    Just for interest, which GTS250 bios did you try; and where did you get it ??

    If it was the bios at link below, then that is actually a 9800GTX+ bios and therefore your problem may lie with it being programmed for different type memory chips ?

    http://www.mvktech.net/component/option,com_remository/Itemid,26/func,fileinfo/id,2988/

    By the way, which "timingset" does NiBitor show your ASUS card/bios runs at ?


    With ASUS bioses, the first thing to identify is whether they are currently using the standard "nvidia parameter tables", or have created their own. And easiest way to check would be to change "Extra" core speed in your ASUS bios from 740 to 700, flash this bios and check that 3D is now running at 700MHz?

    If 700MHz found, then do following "hex" changes to your ASUS bios:-

    Load your original bios into NiBitor, and then open it with the "Hexview" function at the "Tools" option.

    Scroll down to line identified as "0xC2F0". Now within that line change the "00FF" 4 bit word to "0003".

    At line "0xC300", change "0115" 4 bit word to "0100". And at next line "0x0308", change FIRST "01A0" 4 bit word to "00A0".

    Save this modded Bios file then Flash it and see if 2D mode works any better than before?


    And if 2D still not right, then add following changes to your already modded bios,

    At line "0xC308", change "01A03300" 8 bit word to "01403000"

    Now flash and try again?

    :)


    EDIT,

    And instead of groping around in the dark, so to speak: To recover from "bad" flashes, you should be using the "Blind" flash method. Which is where you have the nvflash program and a copy of your original bios on a DOS Bootable Floppy (this of course could be a DOS booting CDROM, USB stick, etc), with the flashing commands within the Autoexec.bat file ?

    :)
     
    Last edited: Jul 24, 2009
  4. NomadicX

    NomadicX Master Guru

    Messages:
    429
    Likes Received:
    0
    GPU:
    EVGA GTX 1660 Ti
    Jimmor wow...glad to see you're still around. With you're help and that of Unwinder's RT I was able to unlock the pipes on my 6800, overclock and lock it all in to bios. Good to see you're still helping about. To all of you here in this thread...well you have a good one when it comes to bios mods.
     

  5. Stonedofmoo

    Stonedofmoo New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Geforce GTS250 1024M
    Hi there

    I used a EVGA Geforce GTS250 1024Mb bios downloaded from www.mvktech.net. It was almost the same build number as mine, just slightly later.

    I'll try the changes you suggest this evening when I get home. I know something can be changed in the extra clock speeds because I updated my memory speed from 1000Mhz to 1050Mhz which is closer to reference spec, and it worked correctly.

    By the way I appreciate you taking the time to help me with this. If it works it will save me buying another card just to get a feature I thought I had anyhow. :)

    Regards
    Chris
     
  6. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Was happy to help you achieve what you wanted for your now very old 6800.

    And yes, still occasionally around, and still poking my nose in to help if I can.

    Think I preffered things in past days though, when dealing with 5xxxx, 6xxxx, 7xxxx and even 8xxxx series cards. Not only had I more free time...but there also seemed a real buzz in forums like this with all sorts of people wanting to be directly involved in learning and trying to make their "sow's ear" hardware into "silk purses"...in other words, the lifelong never ending chase to achieve something for nothing. I just don't feel the same kind of buzz is around these days...of course, maybe it's just part of my knock-on effect of getting older?

    :)
     
  7. Stonedofmoo

    Stonedofmoo New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Geforce GTS250 1024M
    Hi there

    I tried all of those changes, but unfortunately it's like before. The minute I change the '"0xC2F0". Now within that line change the "00FF" 4 bit word to "0003" bit, all I get at the windows desktop is a black screen.

    I tried the additional section at the bottom and flashed that too, but unfortunately that didn't work either so I'm back on the original unmodded BIOS.

    Out of interest what does changing the 00FF value to 0003 do?

    Cheers :)
     
  8. Stonedofmoo

    Stonedofmoo New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Geforce GTS250 1024M
    Yes, that was the BIOS I tried. It said GTS 250 so I assume it was correct. But you're saying it's actually a 9800GTX BIOS, hmm. Perhaps thats the issue then...

    Can you recommend me another one? I figured I'd try EVGA's as they are commonplace.

    Also about the timings, I loaded my BIOS in NiBiTor and took a screenshot of the timings page. Hopefully this is what you were looking for

    [​IMG]

    Update: Actually regarding the BIOS issue. I've downloaded and tried all 3 GTS 250 1024Mb BIOS's on that website, and they all do the same thing. Massive screen corruption. Asus clearly did a number on it's BIOS and board.
     
    Last edited: Jul 24, 2009
  9. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    So you made all the changes I posted to the 4 different locations of your bios and 2D still didn't work... weird... must still be something in their bios software which is "blanking" 2D?

    And unfortunately not easy for me to investigate since I don't have access to your type of card!

    As for the "00FF" and "0003" data: I usually indicate hex changes in 4 (or more) bit words in order to minimise mistakes. Changing the wrong Hex data in your bios can cause all sorts of issues, so must be avoided. In this instance, the only bits that matter are the "FF" and "03" parts. Basically, during driver initialisation, a "03" essentially just acts as an activation of the "2D" part of the Bios's Performance Mode Table (PMT). Whereas a "FF" at that same location would cause the driver to ignore the 2D part and just continue scanning through the PMT looking for another activitation trigger value. And where none are encountered, the driver will then just automatically activate against the "Extra" mode; which is always located at the end of the PMT.

    All the other hex changes I identified were just for tweaking to some of the 2D modes operating parameters.

    :)
     
    Last edited: Jul 25, 2009
  10. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    There is a XFX GTS250 bios which may be more suitable for your card since it has same 62.92.7D.00.11 rev as yours... and as it happens, 2D is enabled as a default?

    http://www.mvktech.net/component/option,com_remository/Itemid,26/func,fileinfo/id,3020/

    On a possible negative side, you will find that although the Rev number is same as yours there are actually many differencies between the two bioses. So let's keep our fingers crossed that the differencies are not enough to stop the XFX bios working in your ASUS card?

    This may in fact be one of the bioses you have already tried, and if so then it definitely looks like ASUS just may have created a "unique monster" of a card...just like with a lot of previous generation cards...which is why I usually therefore told people to avoid them like the plague. ASUS vga cards have had a long history of being user_unfriendly and therefore not for people interested in serious "tweaking" of their hardware?

    Another thing you could try is setting 2D Core volts at 1.2v instead of the bios default of 0.95 ---> maybe the asus card doesn't have a 0.95v option. Meaning it may in fact be the bios's Core Volts selection Table structure that is causing the 2D problem ---> which could require that you change the Core Voltage Table of EVERY BIOS you try to be same as that set for your ASUS Bios, ie, at NiBiTors "Voltage Table" editor (under "tools" option) set Table structure to "4" active entries and values to following,

    Entry1: 0.95v, VID 00
    Entry2: 1.1v, VID 01
    Entry3: 1.2v, VID 02
    Entry4: 1.3v, VID 03



    And to show the default Memory "Timingset" used by your card, you need to actually select the "Autoselect timings" button/option?

    :)

    EDIT:-

    The actual Vcore voltage options of a vga card are hard-wired into the card. So it is always most important that the bios's vcore voltage table VID selections reflect only what the hardware can provide. In the "old" days, if you just wanted to have vcore at max for your particular card, it was only necessary to make your Bios VID settings higher that actually available from hardware. This was because the driver would typically scan the VID table options for a VID that was equal or greater to that listed in the PMT. And therefore when no match had been found after scanning the complete VID table, core volts was just defaulted to max available from card hardware. Meaning you never needed to know max volts available from your particular card, you only needed to set a "ficticious" high VID value knowing that the driver would automatically set max vcore volts for you.

    Unfortunately this rule didn't work for every card, and certainly may not work with the newer generation cards ---> only way to know actual hardware programmed-in vCore Voltage levels and how they relate to VID table settings is unfortunately, as has always been the case, by using a Voltmeter to measure directly on the card?

    By the way, because of some real life commitments, I cant be around to provide any help for a while. So good luck with finding "the" cure for your ASUS GTS250 2D problem...although unfortunately in the end it just might require that your next purchace be almost anything but a ASUS product?

    :)
     
    Last edited: Jul 25, 2009

  11. Max021

    Max021 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    XFX GTX260 65nm 216sp
    Hello everyone first post from me,
    @Jimmor: I've a different kind of problem as problems go on this thread. I have a XFX GTX260 65nm sp216 card and on windows XP SP3 the downclocking works perfectly (driver version 190.38WHQL) and when I load up Windows 7 (same driver version), so it's the Vista's display engine the downclocking still happens but it seems that Windows Aero activates the full 3D clocks. When I disable it, the clocks stay 2D on the desktop. This is very annoying since when Aero is turned off, my XP desktop looks better :) . Anyway, I've read all the entries in this thread and checked the "0xCD60 line of my BIOS (rev 62.00.1A.00.90) and it doesn't have the 0003 16bit value but rather 00FF but downclokcing still works.
    Is there a way to tweak anything anywhere to make the sensitivity of 3D detection lower?
    The other worrying thing is that the bios doesn't seem to have the FX core slowdown temp defined. Could this possibly be because the NiBiTor didn't read the value correctly or does in fact my bios not have the required protection against high temps? Not that i don't keep an eye on temps but still...

    I'm asking you directly because you seem the one with all the hands on knowledge and I just have to say respect to you and people like you that do all the legwork for their own benefit, and are willing then to share what they've learned with laymen like me and others here. I'm a computer sciences student so I've some basic knowledge of how things work. Feel free to explain as much as you want if you've got the time :)

    I see that you won't be around for a while, but when you get the chance I'd be grateful for the response. I'm a patient man :D
     
  12. cutepuppy671

    cutepuppy671 Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Nvidia GTX 970
    hmm the bios change didn't help, while theres no clock entry for the 2D, a 2d mode is still seen, but low power 3d is not seen

    when the card feels like switching to 2D, the screen goes black and after a few seconds, the system freezes and I have to reset the PC, when i do a reset, I get no picture, the bios just does a long beep(that gets a little distorted near the end) then windows boots but no picture, I have to turn the pc off and back on to get picture)
     
  13. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb

    For your bios, the "0003" is at line "0xC828" ---> change to "00FF" if you don't want 2D switching?

    And as far as I know, there is no way for you to play around with 3D detection sensitivities.

    The fact the NiBiTor doesn't currently show a FX slowdown temp for your particular Bios is nothing to worry about. Nibitor is a evolving tool that tries to provide bios tweaking options for many different designs of nVidia Video cards (ranging all the way from very old 5xxxx series to current generation cards like yours). So, barring there being a fault condition, if a NiBiTor option isn't indicating any value for your particular card then it should generally be accepted as not applicable or just not important to that particular bios/card design?

    Usually the best way to control a cards temps is by controlling the fan speed. You can use a software tool like Rivatuner, etc; or just change the bioses default "fanspeed IC" settings using NiBiTor?

    :)
     
    Last edited: Aug 18, 2009
  14. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Once 2D is disabled ---> it is disabled!!

    If, after modifying your bios, your card is still switching back to "2D type" speeds then it looks like your card may simply be being throttled down to it's safety shutdown settings...which usually happens when core and/or memory chip(s) are way overstressed or just running too hot. This kind of "ultimate" protection is built into the design of just about every vga card...where it more than often becomes the "last stand" protection against people overclocking their cards way too high?

    So, if you are overclocking ---> don't? If not overclocking, then reduce Core and memory speeds by 10-20% and see if same throttling takes place? Also, maybe your problem is just due to the Heatsink not making good contact with core/memory chips; or the fan not running fast enough for 3D loading?

    Of course, "wrong" switching between 2D/3D core speeds can also be caused by "BAD" drivers ---> Although the Bios provides the initial "default" settings, it is down to the nVidia Driver to actually run things... meaning when using a "bad" driver, anything can happen?

    :)
     
  15. er557

    er557 Master Guru

    Messages:
    423
    Likes Received:
    17
    GPU:
    2x 1080 sc acx 3.0 sli
    this thread is very interesting....

    @jimmor
    Maybe you can help me with my gtx 280 which does not downclock properly with some drivers only , or am I wrong here to think it is a bios issue?
    Thanks!
     

  16. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    In this instance, you would be wrong to think it is a Bios issue!

    Since your "non-downclocking" problem only happens with some drivers, it is obviously a driver related issue?

    Your type of problem appears very common these days. Which is maybe not too surprising considering that many people are continually upgrading with latest "Beta" drivers just as fast as they are released. Presumably hoping that the next beta (or whql) release will finally solve their particular gaming issues ---> as if that is ever likely to happen?

    :)
     
  17. er557

    er557 Master Guru

    Messages:
    423
    Likes Received:
    17
    GPU:
    2x 1080 sc acx 3.0 sli
    Yeah o.k. thanks, I am now upgrading to 191.00 and see how it goes
     
  18. Tempest261

    Tempest261 Master Guru

    Messages:
    204
    Likes Received:
    0
    GPU:
    AMD Radeon R9-290
    I tried this (well the reverse) to DISABLE 2D throttling on my EVGA GTX260 (55nm, 216 core). So I'm changing from 0003 to 00FF. Unfortunately, I noticed no effect. Eventually, the game still drops down to 400 MHz. Any ideas?

    Thanks!
     
  19. Tempest261

    Tempest261 Master Guru

    Messages:
    204
    Likes Received:
    0
    GPU:
    AMD Radeon R9-290
    I just made a YouTube video characterizing this problem: http://www.youtube.com/watch?v=KaHZ9CcoaJw
     

Share This Page