Nvidia bios mod to fix random downclock?

Discussion in 'Videocards - NVIDIA GeForce' started by cutepuppy671, Jul 19, 2009.

  1. cutepuppy671

    cutepuppy671 Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Nvidia GTX 970
    I currently have a Nvidia GTS 250 (512MB memory)

    with a stock speed of 756MHz gpu and 1100 for memory (by EVGA)

    while gaming, the card will sometimes drop to the 2D clock speeds of 300MHz core, 100MHz memory

    [​IMG]

    when this happens, theres nothing I can do to get it back to the 3d performance clock speeds, (forcing performance levels does not help and launching a game does not help)
    the only way to fix this is to restart the PC (I have tried many different driver versions)

    this problem happens on both stock speeds and overclocked speeds

    I was thinking about editing the bios to my overclocked settings for both 3d and 2d

    and using the voltage table editor to change the voltage from the stock 1.2V, to 1.22V

    I was wondering if someone can look at the bios settings and tell me if these will work



    here are the changes

    [​IMG]
    [​IMG]
    [​IMG]
    for the memory timings, I did not make any changes
    [​IMG]

    I uploaded the original unmodified bios to mediafire.com

    http://www.mediafire.com/?qinnmtwyt13

    if anyone doesn't like mediafire, I can upload it to any other file hosting place as requested


    PS 1 other question, do I have to worry about the memory timings for the 2D mode and does the voltage for 2D mode differ from 3D mode?
    so all in all, what I want to do is

    1, stop the random down clock by giving both 3D and 2D modes the same clock speed and voltage
    2, I want to do a slight voltage increase to ensure stability
     
  2. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Available Vcore levels are fixed into your card's hardware design, so using NiBitor to create a "really would like to have" Vcore level of 1.22v will not work !!

    Also, having your card run at only 3D speeds can be done as a Bios Mod to either, disable 2D mode, or, set 2D and 3D levels to be same ?

    Disabling 2D would require modding the bios with a Hex editor, whereas fixing 2D/3D operating conditions to be same only requires that you use NiBitor to change the Bios's 2D Speeds and Volts to be same as currently set for 3D?

    It is important however that you NEVER set Bios Speeds at levels your card cant maintain, or all you will likely achieve is Artifacts and/or Lockups !

    And memory timings are same for both 2D and 3D mode!

    :)
     
    Last edited: Jul 19, 2009
  3. cutepuppy671

    cutepuppy671 Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Nvidia GTX 970
    went with the standard 1.2V

    and stock speeds, the card completely distorted during bootup. I think the card also lowers the memory voltage for 2D and theres no option to increase that

    so I re flashed to the original, i think the only way to fix this is to disable the 2D mode completely. nibitor can set to 1 performance level but then the clock speeds go from extra, to just 3d and it takes on the clock speeds of the 2D mode and this leaves me to believe that the card will take on the same voltages and will have the same distort problem

    I wish evga can release a bios that just has 1 set clock speed for the card
     
  4. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    You did change 2D "speeds" and "volts" to be exact same as "EXTRA" mode values ---> on these and many other nvidia cards, the bios's "extra" mode is actually the 3D performance mode?

    Of course if that doesn't work then next thing to try would be to disable 2D mode?

    I will try to keep this simple:-

    Load your original bios into NiBitor, and then open it with the "Hexview" function at the "Tools" option (this is actually a "hex editor").

    Scroll down to line identified as "0xC2D0". Now within that line change the "0003" 4 bit word to "00FF".

    The 2D mode should now be disabled !

    ;)
     
    Last edited: Jul 20, 2009

  5. cutepuppy671

    cutepuppy671 Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Nvidia GTX 970
    k I did the change

    [​IMG]

    doesn't seem like much happened but I guess the change took effect, should I save the bios file now and try flashing it?
     
  6. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb

    You appear to be asking permission to save and flash the modded bios ---> why?

    However, the answer of course is YES !

    :)
     
    Last edited: Jul 20, 2009
  7. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Well...don't keep us in suspense...did it work?
     
  8. cutepuppy671

    cutepuppy671 Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Nvidia GTX 970
    I flashed it again, and the card was able to display picture properly, I will test some games and see if the problem still happens
     
  9. sykozis

    sykozis Ancient Guru

    Messages:
    22,012
    Likes Received:
    1,201
    GPU:
    MSI RX5700
    Try changing the Power Management setting in nV control panel to "prefer maximum performance"
     
  10. cutepuppy671

    cutepuppy671 Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Nvidia GTX 970
    going to try the new drivers with the new bios and game for a all day and see if it happens today
     

  11. reeven

    reeven Member Guru

    Messages:
    168
    Likes Received:
    0
    GPU:
    XFX GTX280 750/1450/3000
    Wow, i need your bios cutepuppy671 . On net there are only bioses with Samsung ram, with letters in the bios numbers, your's is with Hynix, with diggits.
    Could you pls upload your bios on rapidshare, megaupload, etc?

    Thanks.

    EDIT THIS: Bios is in the first post, im stupid:D:banana:

    Try old drivers, like 182xx, and you have an low voltage on 2d mode, 0.95v, mine is 1v...I never seen this problem like yours....
     
    Last edited: Jul 22, 2009
  12. greenblood82

    greenblood82 New Member

    Messages:
    3
    Likes Received:
    0
    Hi there,
    have the exact opposite problem. My XFX GTX260 Core Edition (216 shader 55nm) has 2D throttling disabled and I want to enable it.
    So i want to ask if there is such a hex tweak for my card to enable 2D-Mode.

    Here is my original bios: http://www.mediafire.com/?mod1mtgm2wn
     
  13. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    That's one heck of a bios you have there. Looks like the manufacturer had been trying with different Throttling levels, and then just gave up ?

    So just maybe throttling to 2D was disabled because the manufacturer couldn't make it run as they wanted ---> who knows??

    However, lets give you something to go with:-

    Load your original bios into NiBitor, and then open it with the "Hexview" function at the "Tools" option.

    Scroll down to line identified as "0xCD60". Now within that line change the "00FF" 4 bit word to "0003".

    Save this modded Bios file then Flash it and the 2D mode should now be Enabled !

    ;)
     
    Last edited: Jul 23, 2009
  14. cutepuppy671

    cutepuppy671 Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    Nvidia GTX 970
  15. greenblood82

    greenblood82 New Member

    Messages:
    3
    Likes Received:
    0
    Thanks for your effort jimmor.

    I just did the bios mod and flashed it onto my card. It's now correctly throttling to 2d-mode when idle.
    I'm still wondering why xfx disabled this since only a small tweak was needed and my cards are running alot cooler now when idle.

    Thanks again :)
     

  16. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    No prob's, glad to help!

    Without sombody related your card's manufacturer coming clean, there's no way to know why they abandoned 2D for your particular card?

    However, keep in mind that my small tweak has only activated whatever 2D operating parameters were left behind by the Bios's original manufacturer. So I would play around for a while (including games, etc) before declaring your present venture into having 2D mode is a complete success?

    :)
     
  17. Stonedofmoo

    Stonedofmoo New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Geforce GTS250 1024M
    Jimmor, can you help me too? I have a similar issue with my new Asus Geforce GTS250. Basically since buying it I have tried everything and have been unable to get it to downclock to 2D mode. It sits at 3D mode all the time, and according to the review on Tomshardware it should not be doing this.

    The correct 2D clocks are in my BIOS, I can see that in NiBiTor 5.1, but could you look at my BIOS and tell me if the mode is enabled because otherwise I'm out of ideas. Nothing I do will get it to downclock :(

    The BIOS is here: http://homepage.ntlworld.com/stonedofmoo/CPU/Asus GTS250.zip

    I tried looking at the hex entries you posted above, but mine was not the same.
     
  18. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Load your original bios into NiBitor, and then open it with the "Hexview" function at the "Tools" option.

    Scroll down to line identified as "0xC2F0". Now within that line change the "00FF" 4 bit word to "0003".

    Save this modded Bios file then Flash it and the 2D mode should now be Enabled !

    But, as said before, the manufacturer may have had a very good reason for disabling 2D. Which means having a 2D mode may not turn out to be particularly beneficial with your version of card . Of course, without manufacturer feedback, only time and your personal experiences will prove the value of this 2D mode one way or the other?

    :)
     
    Last edited: Jul 23, 2009
  19. Stonedofmoo

    Stonedofmoo New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus Geforce GTS250 1024M
    Hi Jimmor

    Thanks for that speedy reply! :)
    Are you certain about that hex edit?

    I just tried it, flashed the card but then once I get onto the desktop the screen is black and I cannot see anything. I had to reflash my backup BIOS to get my screen back.

    Any ideas?

    Cheers

    p.s. do I take it the BIOS is set so 2D is disabled then? If so thats bad service by Asus as the card they supplied to Tomshardware was working with 2D mode and it was that feature that sold it to me.
     
  20. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb

    The "hex" change was correct for the nVidia "standard design" bios. The fact that your 2D doesn't appear to work is therefore probably down to ASUS being weird again by creating their own special bios....for some reason they like to be different from everyone else....been that way for many previous generations of vga cards.

    Actually wouldn't matter if ASUS's particular design changes ever proved beneficial to anyone...but to my knowledge they never have!

    As for your Tomshardware comment, are you sure they were talking about a asus card having a 2D mode ---> and if so, are you sure it was your particular model. Also, it must be kept in mind that the original nVidia Bios Design definitely has a seperate 2D mode and it was therefore up to the manufacturers whether it should be enabled or not?

    For the present, providing bios programming changes to try to UNDO the ASUS uniqueness is not that straightforward since I don't actually have a GTS250, asus, or otherwise. Meaning I have no way of checking the effectiveness of any offered changes?

    However, if it were my GTS250, I would be more likely to flash it with another manufacturers "nVidia standard" bios. Which would then allow the original design of 2D mode to be active . And a good bios to try would be cutepuppy671's EVGA version at first post of this thread ---> or maybe even the standard GTS250 bios used at the link below.

    http://www.cpu3d.com/article/7481-2...gtx-into-a-gts-250/flashing-the-vga-bios.html

    :)
     
    Last edited: Jul 24, 2009

Share This Page