1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NVidia Anti-Aliasing Guide (updated)

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Cyberdyne, Jan 29, 2012.

  1. Tasteful Bloom

    Tasteful Bloom New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GeForce GTX 1070, 8GB
    OGL
     
  2. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,803
    Likes Received:
    19
    GPU:
    ASUS GTX 980 STRIX
    You can just try forcing using MSAA+TrSSAA Option. If it works, then you are good. If not then you are SOL unless the game has built in MSAA you can enhance.
     
  3. Johnny99

    Johnny99 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    GTX 1060 6GB
    None of the border shaders are compatible, at least in my case, with NVidia Inspector. If I use any of them then anti-aliasing set via NVCP will not be applied in-game.
     
  4. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,803
    Likes Received:
    19
    GPU:
    ASUS GTX 980 STRIX
    Are you using ReShade? You have to set the depth bit in the anti aliasing flag (0x00400000) for newer versions of Reshade.
    The old version 1/2 I don't think needed it. And the old SweetFX injectors do not need it at all.(If you just want a border shader for dx9/11 games, find an old SweetFX download pre reshade days)
     

  5. NeoChaos

    NeoChaos Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 8 GB
    OK, so I just followed the nVidia forums link that I quoted in this post, and apparently there's a new way to work around the blurred textures w/SGSSAA in OGL issues - enable the FXAA option in Inspector. Just tested this in Anachronox, Hexen II (with UQE H2 source port) and Jedi Academy to make sure it was working. Yes, for once applying FXAA actually makes textures less blurry.
     
    Last edited: Aug 19, 2018 at 9:08 AM
  6. dezo

    dezo Member

    Messages:
    12
    Likes Received:
    2
    GPU:
    GTX 1080
    @NeoChaos: This actually works in old OGL games with 398.x drivers, thats great. But FXAA on top of TrAA is just weird - I don't like how FXAA affects 2D overlays and texts. I hope there will be another hidden driver parameter to sort this out without FXAA... o_O

    Edit: Well scratch that. Just tested in OGL Doom 3 with 398.11 and FXAA on top of TrAA just deactivates TrAA completelly so all the specular aliasing is back. So much for "repairing" the blur. Don't know what others see, but for me it just doesn't work.
     
    Last edited: Aug 19, 2018 at 5:12 PM

Share This Page