1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NVidia Anti-Aliasing Guide (updated)

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Cyberdyne, Jan 29, 2012.

  1. tesseract

    tesseract New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 1060
    What games have a good SMAA T2x implementation? The only one that I am familiar with is the one in Alien Isolation that doesn't do much to most of the temporal aliasing. The modded-in TAA worked a lot better, apart from the ghosting artifacts and smoothing out some of the particle effects.
     
  2. Terepin

    Terepin Master Guru

    Messages:
    637
    Likes Received:
    1
    GPU:
    GTX 1080
    Far Cry 4 has the best SMAA T2x implementation to this date. Even TXAA looks like crap compared to it.
     
  3. SpookySkeleton

    SpookySkeleton Member Guru

    Messages:
    119
    Likes Received:
    16
    GPU:
    GTX 1080
    Does transparency AA works on any game since is unlocked for every app, or it need bits too
     
  4. mysignupname

    mysignupname New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 1080
    Anyone have any good settings for GTA 5?
    Hardware wise I am running 3440 x 1440p ultra wide gsycn with an 8700k & GTX 1080.

    I played around with nvida inspector but I am not sure what Gsync application state does.
     

  5. BuildeR2

    BuildeR2 Ancient Guru

    Messages:
    2,756
    Likes Received:
    101
    GPU:
    EVGA 1080 Ti FTW3
    I've messed around in GTA 5 quite a bit to get it right. I used the in game 4xTXAA enhanced by inspector for a while but found it to be too soft and my helicopter shadows always had a huge discolored box around them, which is also caused by just using MSAA for me. I settled with all settings under "Graphics" maxed out, but in the "Advanced Graphics" section all of the "on or off" settings are ON while the extra draw and shadow distance cause frequent stutter if they are beyond halfway. Those last 2 settings are the ones that dogged me for the longest time until I just turned them off and had a 2 hour session with no lag or stutter. Maybe it is my older CPU, RAM or something else but those are the smoothness killers for me so I keep them at half.

    Because the game is terribly jaggy when using no AA, I also up the resolution scale factor to 3/2 (150%) from my base resolution of 1080p and it looks nice with no shadow bugs or other issues caused by the AA options in this game. One last thing, if you don't mind trying a flyover in a helicopter just in the middle of the city area with the "Advanced Setttings" all maxed out to see if it stutters or not, that would be awesome. I'm curious if the "4770k+DDR3 versus 8700k+DDR4" factor would fix it or if it is more of an engine limitation. Good luck.
     
  6. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI GTX 1060 6GB
    How can I force anti aliasing in Kingdoms Of Amalur Reckoning without those terrible flickering border lines? I seem to be getting them with every AA setting in NVidia Inspector.
     
  7. NeoChaos

    NeoChaos Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 8 GB
    BlazBlue Cross Tag Battle can be forced to use 8xSGSSAA with no flags needed and no noticable issues. However, in-game AA (windowed or fullscreen depending on your settings) has to be enabled and Antialiasing - Mode in Nvidia Inspector has to be set to "Application-controlled" for the override to work.

    No AA:
    [​IMG]

    8xSGSSAA:
    [​IMG]

    In game 4x AA, no Inspector AA applied:
    [​IMG]
     
    Last edited: Aug 9, 2018
  8. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,854
    Likes Received:
    32
    GPU:
    ASUS GTX 980 STRIX
    You can't. Just use a border shader. There are a bunch of different injectors out there you can use to do so.

    Also: With BlazBlue, did you try the enhance application setting as well? Though in situations like this it should work either way. Just having the AA set on the profile and the game using MSAA internally will cause it to work.

    Either way, added to the list. Thanks.
    Can you provide a shot with *just* the in game Aa enabled as well?
     
    Last edited: Aug 8, 2018
  9. NeoChaos

    NeoChaos Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 8 GB
    On second look, Enhance and Override settings do in fact work on BBCTB. For some reason with my testing last night, it didn't seem to - maybe I just forgot to hit the Apply Changes button but whatever. Strangely, the SGSSAA will still apply even when Mode is set to Application-controlled as long as the in-game AA is enabled.

    And I've added a screenshot of just the in-game AA set to it's highest setting, 4x, to my original post. I've heard rumblings that the in-game AA was non-functional and considering I don't see any differences between it and the no AA screenshot I think that just might be the case.
     
    Last edited: Aug 9, 2018
  10. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,854
    Likes Received:
    32
    GPU:
    ASUS GTX 980 STRIX
    Yeah clearly the in game AA doesn't work. Did they even bother to check it before release? Reminds me of EDF4.1. Says it has AA, but it doesn't actually work. (Well in that case it works in the main menu and that's it)
     

  11. NeoChaos

    NeoChaos Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 8 GB
  12. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,854
    Likes Received:
    32
    GPU:
    ASUS GTX 980 STRIX
    Well crap that's gonna suck when new cards come out.

    i'm on 388.59 and it doesn't happen in Doom 3 for me, anyone ever seen it happen there?
     
  13. Tasteful Bloom

    Tasteful Bloom New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GeForce GTX 1070, 8GB
    Does anyone know Sparse Grid compatibility bits for Cry of Fear?
     
  14. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,854
    Likes Received:
    32
    GPU:
    ASUS GTX 980 STRIX
    Is it DX9?
     
  15. Tasteful Bloom

    Tasteful Bloom New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GeForce GTX 1070, 8GB
    OGL
     

  16. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,854
    Likes Received:
    32
    GPU:
    ASUS GTX 980 STRIX
    You can just try forcing using MSAA+TrSSAA Option. If it works, then you are good. If not then you are SOL unless the game has built in MSAA you can enhance.
     
  17. Johnny99

    Johnny99 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI GTX 1060 6GB
    None of the border shaders are compatible, at least in my case, with NVidia Inspector. If I use any of them then anti-aliasing set via NVCP will not be applied in-game.
     
  18. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,854
    Likes Received:
    32
    GPU:
    ASUS GTX 980 STRIX
    Are you using ReShade? You have to set the depth bit in the anti aliasing flag (0x00400000) for newer versions of Reshade.
    The old version 1/2 I don't think needed it. And the old SweetFX injectors do not need it at all.(If you just want a border shader for dx9/11 games, find an old SweetFX download pre reshade days)
     
  19. NeoChaos

    NeoChaos Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 8 GB
    OK, so I just followed the nVidia forums link that I quoted in this post, and apparently there's a new way to work around the blurred textures w/SGSSAA in OGL issues - enable the FXAA option in Inspector. Just tested this in Anachronox, Hexen II (with UQE H2 source port) and Jedi Academy to make sure it was working. Yes, for once applying FXAA actually makes textures less blurry.
     
    Last edited: Aug 19, 2018
  20. dezo

    dezo Member

    Messages:
    17
    Likes Received:
    2
    GPU:
    GTX 1080
    @NeoChaos: This actually works in old OGL games with 398.x drivers, thats great. But FXAA on top of TrAA is just weird - I don't like how FXAA affects 2D overlays and texts. I hope there will be another hidden driver parameter to sort this out without FXAA... o_O

    Edit: Well scratch that. Just tested in OGL Doom 3 with 398.11 and FXAA on top of TrAA just deactivates TrAA completelly so all the specular aliasing is back. So much for "repairing" the blur. Don't know what others see, but for me it just doesn't work.
     
    Last edited: Aug 19, 2018

Share This Page