Nvidia 355.60 WHQL Windows 10 drivers out now

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by flimbo, Aug 13, 2015.

  1. Webhiker

    Webhiker Master Guru

    Messages:
    706
    Likes Received:
    223
    GPU:
    EVGA GTX 1080Ti SC2
    I also get weird frame drops with these drivers in Armored Warfare. Those drops goes away, if I change Power Management mode from "Adaptive" to "Prefer Maximum Performance", so I suspect these driver are a tad to aggressive on the power saving side.

    On a side note. There is absolutely no difference performance wise between these drivers and the 353.82 Quadro drivers.
     
  2. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,578
    Likes Received:
    1,492
    GPU:
    MSI 3080 Gaming X
    Tried without reinstalling, worked great. That 980Ti is a beast :)

    Gah, if they only could fix the damn RAM memory leak too -.- Sorry for repeating myself, but it's annoying.

    I read a rumour on the GeForce forum that a hotfix driver will be released, hopefully fixing that.
     
  3. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,986
    Likes Received:
    334
    GPU:
    RTX 2080 OC
    That's not a rumor, ManuelG said this on NV's forums prior to 355.60 release.
     
  4. rgnuyda

    rgnuyda Member Guru

    Messages:
    165
    Likes Received:
    0
    GPU:
    MSI560GTX Ti Twin Frzr2OC
    win desktop manager broken with this driver

    error message when launching games "Witcher 3 has stopped working" so i rolled back to previous driver and voila! it worked. This is not for me.
     

  5. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,578
    Likes Received:
    1,492
    GPU:
    MSI 3080 Gaming X
    Oh, that's good news!
     
  6. cookieboyeli

    cookieboyeli Master Guru

    Messages:
    300
    Likes Received:
    43
    GPU:
    Gigabyte 1070 @2126
  7. caleb59

    caleb59 Member Guru

    Messages:
    154
    Likes Received:
    6
    GPU:
    MSI GTX 1070 X 8GB
    OMG so that's why Assassin's Creed Brotherhood sometimes weird stutters for me, PC restart solved that problem - god damn Nvidia for that memory leak! :banana:
     
  8. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,000
    Likes Received:
    517
    GPU:
    EVGA GTX 1080 Ti SC2
    I can confirm I had the exact same bug and had to uncheck that mouse option to fix it. The odd thing was that it only seemed to affect the NVIDIA control panel option as other pulldowns worked fine with that mouse option checked.
     
  9. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,578
    Likes Received:
    1,492
    GPU:
    MSI 3080 Gaming X
    Yea no more long gaming sessions for us now, having to restart PC every hour or so :/
     
  10. David Ryder

    David Ryder Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    EVGA GTX 980 ti SC ACX2
    I got my Nvidia Card for 2 months now and I'm starting to doubt switching from an AMD card was a good idea.
     

  11. CK the Greek

    CK the Greek Maha Guru

    Messages:
    1,278
    Likes Received:
    11
    GPU:
    GB 2060S,Gsync,3DV2
    It has to do something with Win10, right? Cause I am on Win 7 with no such issues.
     
  12. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,578
    Likes Received:
    1,492
    GPU:
    MSI 3080 Gaming X
    Yep, that's right. I didn't have any issues like that when running on Win7 either.
     
  13. dsbig

    dsbig Ancient Guru

    Messages:
    4,041
    Likes Received:
    37
    GPU:
    EVGA RTX 2070
    tested on new insider build


    was able to play GTA V, even though memory leak was still happening.

    but I was able to play at 30fps until memory and pagefile max out.....:bang:

    then it all went to hell.




    im done.

    I will be in windows 8.1 if anybody needs me....
     
    Last edited: Aug 19, 2015
  14. AdamK47

    AdamK47 Banned

    Messages:
    207
    Likes Received:
    0
    GPU:
    Verite V1000 & Voodoo 4MB
    The SLI memory leak bug is horrendous with 4 Titan X cards. When I run Unigine Heaven @ 3840x2160 with 8x AA the memory usage automatically shoots to 12GB right off the bat. It will eventually crash.

    I'm now using the Windows 10 x64 352.63 drivers. Unigine Heaven is now able to loop forever.
     
  15. WhiskeyOmega

    WhiskeyOmega Master Guru

    Messages:
    209
    Likes Received:
    2
    GPU:
    1080Ti
    I dont have that issue i got something like 3308 with my 2 970s on Heaven with 355.60 and it doesnt crash. BF4 still does though. Hopefully it will be soon.
     

  16. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,039
    Likes Received:
    1,863
    GPU:
    Zotac GTX980Ti OC
    Ryse of Rome has some weird slowdowns as well..
    Memory usage is lower compared to Win8.1, at least win8.1 didnt have these fps drops - gpu usage 99% all the time..


    But in win10 it has hard time utilizing gpu properly, lots of gpu drops, lowest so far was 40%! :pc1:

    And this was just 5 min into the game, 1st level... Please fix this mess.


    1st column % number between °C and gpu freq.
    [​IMG] [​IMG]

    [​IMG] [​IMG] [​IMG] [​IMG]
     
    Last edited: Aug 20, 2015
  17. SSJBillClinton

    SSJBillClinton Master Guru

    Messages:
    743
    Likes Received:
    118
    GPU:
    2080Ti Zotac AMP!
    Was SLI scaling for Metro 2033 Redux/Last Light Redux always this bad? Getting around 60%~ on both cards maxed out with around 70-90FPS. I can raise SSAA which doesn't improve scaling and just drops my fps further. 2560x1440
     
  18. Monchis

    Monchis Maha Guru

    Messages:
    1,304
    Likes Received:
    36
    GPU:
    GTX 950
    Setting physx to CPU in the control panel also fixes stuttering in Mortal Kombat X (just like in the witcher 3). :thumbup:
     
  19. Li4m79

    Li4m79 Ancient Guru

    Messages:
    5,155
    Likes Received:
    3
    GPU:
    2xPalit GTX770 Jetstream
    GTAV FIXED!!!: Well for me anyway..... I was having a few other win10 issues, so I RESET my installation.. I lost a lot of programs, and just reinstalled GTA V (luckily I had the disc version) now it runs like a dream, no frame drops or stutters!!! Only tested for about 20mins and will test further, but it is infinitely better than it was.

    Also Resetting sorted out every other win10 issue I was having.
     
  20. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,000
    Likes Received:
    517
    GPU:
    EVGA GTX 1080 Ti SC2
    Eurgh! Is that bug STILL there?

    It's about time NVIDIA sorted out PhysX properly...it really should not be necessary to force an API that is designed to work with both the CPU and GPU depending on the game to one or the other to fix issues like stuttering.

    *sigh*
     

Share This Page