[Nv Optimus] Win 10 May Update removes nvidia context menu: Run with gpu processor

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by sirDaniel, Jul 8, 2020.

  1. sirDaniel

    sirDaniel Member Guru

    Messages:
    105
    Likes Received:
    2
    GPU:
    940MX
    Unfortunately, latest Windows 10 update intentionally removes option for manually choosing GPU processor to run with application. It was context menu that appeared, when right clicked on program icon. Now it is gone. It was handy to test intel gpu as it has ogl 4.5 and vulkan 1.2 support nowadays.

    Now, the only option is to manually open Nvidia Panel, switch to tab, manually add program, and change option to run with nvidia. Switching back to intel is the same process.

    Can anybody know a way to make it faster (reg edit maybe?) OR is that possible to make a tool for fast switch between gpu processors?
     
    tiliarou likes this.
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    14,948
    Likes Received:
    6,114
    GPU:
    GTX 1080ti
    tiliarou likes this.
  3. sirDaniel

    sirDaniel Member Guru

    Messages:
    105
    Likes Received:
    2
    GPU:
    940MX
    Yes, thanks. I am still thinking about faster, slickier method.
     
    tiliarou likes this.
  4. ivanosky

    ivanosky Active Member

    Messages:
    91
    Likes Received:
    15
    GPU:
    NVIDIA RTX 3060
    Does this mean that the ability to change GPU for apps will be removed from the Nvidia Control Panel? If the Nvidia GPU is set for an app the Windows Settings, I would still need to add it to the Nvidia Control Panel to change settings for it, like the Framerate limiter or Anisotropic Filtering, right?
     

  5. sirDaniel

    sirDaniel Member Guru

    Messages:
    105
    Likes Received:
    2
    GPU:
    940MX
    Hello Ivanosky,
    The ability is still there. No change in nvidia control Panel.

    Laptop users had ability to manually choose GPU at every run.
    It was like this:
    [​IMG]

    Now its gone.
     
  6. aufkrawall2

    aufkrawall2 Ancient Guru

    Messages:
    2,383
    Likes Received:
    858
    GPU:
    3060 TUF
    Have you already reinstalled the driver?
     
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    14,948
    Likes Received:
    6,114
    GPU:
    GTX 1080ti
    its intended.
     
  8. ivanosky

    ivanosky Active Member

    Messages:
    91
    Likes Received:
    15
    GPU:
    NVIDIA RTX 3060
    Yes, the ability is still there. But the message that shows on the Manage 3D Settings screen sounds like if choosing the GPU through the Windows Settings is now the preferred method and that the ability to change it through the Nvidia Control Panel might be removed.

    Which is why I was asking this to Astyanax, since he seems to have some insider knowledge from his replies in other threads.
     
    tiliarou likes this.
  9. Astyanax

    Astyanax Ancient Guru

    Messages:
    14,948
    Likes Received:
    6,114
    GPU:
    GTX 1080ti
    the windows settings tends to have a better shot of making it stick.
     
  10. tiliarou

    tiliarou Active Member

    Messages:
    60
    Likes Received:
    12
    GPU:
    Nvidia 980M
    So they removed a useful shortcut to replace it with a longer shitty process...
    There must be a way to automate this and add shortcuts to context menu ?! Since it's now handled by default by Windows, there must be some reg trick that can be enable on the fly and thus added to context menu I hope...
     

  11. sirDaniel

    sirDaniel Member Guru

    Messages:
    105
    Likes Received:
    2
    GPU:
    940MX
    I use emulators. Even choosing manually in Nvidia panel an internal gpu and in emulation program, still dedicated gpu is used. Can anybody with nvidia optimus can confirm problems?
     
  12. mikolaj612

    mikolaj612 Member

    Messages:
    32
    Likes Received:
    5
    GPU:
    RTX2060
    Maybe a little old thread but I've got something to say ;)

    NV removed support for context menu, however MS support is quite easy to do (for someone with programming skills).
    Every change you made for app/game via MS Settings (like changing default GPU/or setting which GPU is high performance) are stored in few simple registry keys, that could be edited in the fly if required.
    Even OpenGL/Vulkan games are stored in the same place, UWP are also simple to add, but you need it's whole name.
     
  13. sirDaniel

    sirDaniel Member Guru

    Messages:
    105
    Likes Received:
    2
    GPU:
    940MX
    So there is a chance. Does it mean that gpu switch tool would need to have hardcoded values? Like profiles? Or is it posibble to do automatically, base on some patterns?
    I wish somebody woul program such tool.
     
  14. Bull11

    Bull11 New Member

    Messages:
    1
    Likes Received:
    2
    GPU:
    nvidia
    I've made a short registry change that will add a context menu shortcut to set an exe file as High Performance, as this is the most common case.

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\exefile\shell\Set High Performance\command]
    @="C:\\Windows\\System32\\REG.exe ADD HKEY_CURRENT_USER\\SOFTWARE\\Microsoft\\DirectX\\UserGpuPreferences /v \"%1\" /d GpuPreference=2;"

    Add this to a .reg file and run.

    Note: This could probably be improved with regards to functionality and user privileges.
     
    Cave Waverider and Astyanax like this.
  15. ilovcats

    ilovcats New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    RTX 3060 6GB
    I tried using this and even modifying it but couldnt get it to work, have you by any chance made it work upload_2022-11-26_12-41-13.png
     

  16. cricket bones

    cricket bones Master Guru

    Messages:
    864
    Likes Received:
    256
    GPU:
    EVGA RTX 3080 FTW
    You may not have the appropriate permissions to access the item.
     
  17. ilovcats

    ilovcats New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    RTX 3060 6GB
    Well i checked if i had given the account permissions to change the registry and i have so either thats not the probrem or there is something else I need to do to give it permissions which i dont know how to do
     

Share This Page