1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NTFS Disable Last Access Update File Time Stamp Windows 10 April 1803 Update

Discussion in 'Operating Systems' started by Watcher, May 27, 2018.

  1. Watcher

    Watcher Ancient Guru

    Messages:
    2,529
    Likes Received:
    173
    GPU:
    Gigabyte Windforce R9 380
    I have been applying this particular registry tweak for many years however with the Windows 10 April 1803 update, the value that I entered no longer worked and even caused an active foreground Window pane in use problem with inactive Window panes momentarily popping up or even steeling focus from the foreground Window pane on my box.

    The value and location that worked up until 1803 was:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
    "NTFSDisableLastAccessUpdate"=dword:00000001

    The value and location with Windows 10 April 1803 update is:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
    "NTFSDisableLastAccessUpdate"=dword:80000001

    Same KEY name, same DWORD32 name, different value

    Here is an older article from Windows XP days from the How-To Geek web site.

    https://www.howtogeek.com/howto/win...disabling-last-access-updating-in-windows-xp/

    You could download the " DisableLastAccessUpdate Registry Tweak file" from the web site, change the value as stated above and then import the registry file back into the registry if you are uncomfortable using the Windows Registry editor.

    As always, make a system restore point or back up the registry before making this change.
    A Registry back up tool that I use on a regular basis, description and download locations can be found here:

    http://www.tweaking.com/content/page/registry_backup.html
    http://www.softpedia.com/get/System/Back-Up-and-Recovery/Tweaking-com-Registry-Backup.shtml
    http://www.majorgeeks.com/download.php/Tweaking.com_-_Registry_Backup_d7786.html

    The reference I have found to this change was at this Windows 10 forums web site:

    https://www.tenforums.com/windows-1...pdate-now-available-monday-april-30-a-63.html

    This tweak can speed up file disk access times and is particular useful with preventing additional writes when using an SSD.
     
    norton and -Tj- like this.
  2. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,384
    Likes Received:
    1,476
    GPU:
    Zotac GTX980Ti OC
    Thanks, need to recheck, i used gameboost reg tweak that disables it, guess i have the same issue now with 00000001 instead of 80000001.
     
  3. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,900
    Likes Received:
    4,540
    GPU:
    GeForce GTX 1070
    I just tested on Win10 1803:
    - found text file,
    - looked at its "accessed" value in properties,
    - opened it in notepad,
    - closed notepad,
    - "accessed" value has not changed,
    - opened it in notepad, changed and saved,
    - "accessed" value has not changed (only "modified" one has).
    Obviously, last access time is not changed on my copy of Win10. And I am sure I have not tweaked this thing for ages.
     
  4. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,384
    Likes Received:
    1,476
    GPU:
    Zotac GTX980Ti OC
    At what value is it set in registry?



    EDIT: this is how its at mine atm


    so it looks like mine is at default default, guess because GB 3.4 is so old it doesn't set properly.


     
    Last edited: May 27, 2018

  5. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,900
    Likes Received:
    4,540
    GPU:
    GeForce GTX 1070
    NtfsDisableLastAccessUpdate = 80000003 (hexadecimal).
     
  6. joe187

    joe187 Master Guru

    Messages:
    480
    Likes Received:
    20
    GPU:
    Nvidia GTX1070 FE
    Best way to do this now is to use a command line:

    fsutil behavior set disablelastaccess 1

    This will set the reg key correctly either way, i tested in 1703 and 1803.
     
    DAW40 likes this.
  7. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,684
    Likes Received:
    362
    GPU:
    EVGA 1070Ti Black
    i have not done this tweak in years does stilll really speed up disk access speeds>?
     
  8. Watcher

    Watcher Ancient Guru

    Messages:
    2,529
    Likes Received:
    173
    GPU:
    Gigabyte Windforce R9 380
    Microsoft page in regards to this setting: https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/fsutil-behavior

    Very good information form Joe187

    The reason I started this thread was to inform anyone that uses this tweak that the value has changed with Windows 10 Spring update 1803.

    My box actually had issues with the value of 00000001 instead of 80000001

    Joe187 method ( which I concede to being the better method ) will query the OS installed, no matter which version you have and change to the correct value unless the following examples apply..

    I changed the value in my registry to a value of 00000004 and ran the "fsutil behavior set disablelastaccess 1" with a result of the registry value changing to 00000001 not 80000001?
    Responds to the command was " DisableLastAccess = 1 (Enabled)"

    I changed the value in my registry to a value of 80000004 and ran the "fsutil behavior set disablelastaccess 1" with a result of the registry value changing to 80000001.
    Responds to the command was "DisableLastAccess = 1 (User Managed, Enabled)"

    It looks like if you have never tweaked this value manually then "fsutil behavior set disablelastaccess 1" will set the value correctly.
    If however you have tweaked the value yourself or with a program that has not been updated to reflect the change in Win 10 build 1803, then you will need to manually go and change the value in the registry yourself.

    Cheers
     
    Last edited: Jun 17, 2018
  9. DAW40

    DAW40 Master Guru

    Messages:
    482
    Likes Received:
    38
    GPU:
    EVGA 1060 6GB
    Why don't you all just go to your drive, right click and properties and take out the check for indexing. Simple..
     
  10. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,900
    Likes Received:
    4,540
    GPU:
    GeForce GTX 1070
    This has nothing to do with OP.
     

  11. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,360
    Likes Received:
    896
    GPU:
    1080Ti H20
    DAW40 lately seems on a run to get his post count up; most of his posts are replies that make no sense.
     
    WareTernal likes this.
  12. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    15,623
    Likes Received:
    1,620
    GPU:
    Sapphire 5700XT P.
    Nothing here needs a high post count though does it?
    (And if it does and I'm forgetting about it such as say posting URL's it's probably 100 or something like that.)

    Well there's the title I guess but that doesn't really say anything much. Indexing can be a slowdown but it runs during idle activity and this feels like it's a different issue being more about reducing read and write count and perhaps gradual wear & tear on drives such as solid state but can something like this really be producing that many cycles? Then again it adds up I suppose over time. (And this doesn't seem like it's all that important so disabling it can be done if the user wants to do that.)
     
  13. dsbig

    dsbig Ancient Guru

    Messages:
    4,003
    Likes Received:
    27
    GPU:
    EVGA RTX 2070
    im finding that indexing is running when ever it wants. I had to disable it. because it would run when running applications, spent most of the day defragging the drive, found out it was because index was running at the same time.

    also disable superfetch, as I couldnt use the system for almost 5-10 minutes after booting up as it causing high disk usage.

    also disabled memory compression.

    my system is very responsive after these tweaks.
     
  14. Chilace

    Chilace New Member

    Messages:
    7
    Likes Received:
    1
    GPU:
    GTX 1050Ti 4GB
    https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/fsutil-behavior
     
  15. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,900
    Likes Received:
    4,540
    GPU:
    GeForce GTX 1070
    Namely that case I tested - I modified file in notepad and saved it: Last Modify Time was updated, Last Access Time was not updated.

    PS I just checked on work rig with Win10 1809 and the value of NtfsDisableLastAccessUpdate is the same "0x80000003", and I have never tweaked it here.
     
    Last edited: Feb 12, 2019

  16. Chilace

    Chilace New Member

    Messages:
    7
    Likes Received:
    1
    GPU:
    GTX 1050Ti 4GB
    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2003/cc781134(v=ws.10)#last-access-time

    some investigation:
    http://blog.livedoor.jp/nichepcgamer/archives/1071061265.html

    wait, you have "0x80000003"
     
    Last edited: Feb 12, 2019
  17. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,900
    Likes Received:
    4,540
    GPU:
    GeForce GTX 1070


    Have you noticed the target of that page:
    Applies To: Windows Server 2003, Windows Server 2003 R2, Windows Server 2003 with SP1, Windows Server 2003 with SP2
    ?

    That link doesn`t open here.

    But regardless of links you posted here, Last Access Time for the file I tested with was never updated. Even if NTFS holds that value in memory it is not saved to disk between starts of OS. To me that means that this attribute is not updated. If you have time and will you can test mentioned registry value - whether it enables and disables tracking of that Last Access Time attribute.
     
  18. Chilace

    Chilace New Member

    Messages:
    7
    Likes Received:
    1
    GPU:
    GTX 1050Ti 4GB
    Oh, my bad, just quick searching

    Ah, that resource is blocked in Russia by Roskomnadzor

    It is not updated because of your NtfsDisableLastAccessUpdate = 0x80000003 (System Managed, the “Last Access” updates are disabled).

    Sorry, I have no time to test all that new values. I just disable last access update by running
    Code:
    fsutil behavior set DisableLastAccess 1
    (NtfsDisableLastAccessUpdate = 0x80000001, User Managed, the “Last Access” updates are disabled).
     
  19. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,900
    Likes Received:
    4,540
    GPU:
    GeForce GTX 1070
    I just tried to query the value at home rig (Win10 1803):
    fsutil behavior query disablelastaccess
    and it showed
    DisableLastAccess = 3 (System Managed, Enabled)

    So I guess "fsutil behavior set DisableLastAccess 1" is for user managed disabling, while "fsutil behavior set DisableLastAccess 3" is for system managed disabling.

    I will try this tomorrow on work rig (Win10 1809).
     
  20. Chilace

    Chilace New Member

    Messages:
    7
    Likes Received:
    1
    GPU:
    GTX 1050Ti 4GB
    Code:
    Microsoft Windows [Version 10.0.17763.253]
    (c) Корпорация Майкрософт (Microsoft Corporation), 2018. Все права защищены.
    
    C:\Users\chila>chcp 437
    Active code page: 437
    
    C:\Users\chila>fsutil behavior set DisableLastAccess
    Usage: fsutil behavior set disableLastAccess <0-3>
    
     Values: 0x0 - User Managed, Last Access Updates Enabled
             0x1 - User Managed, Last Access Updates Disabled
             0x2 - System Managed, Last Access Updates Enabled
             0x3 - System Managed, Last Access Updates Disabled
    
     - When "System Managed" is enabled it allows the system to enable/disable
       last access time updates based on system policy.
     - If group policy is in effect or this registry key is uninitialized then
       the "System Managed" state can not be set and is not displayed.
    
    C:\Users\chila>
    More info https://dfir.ru/2018/12/08/the-last-access-updates-are-almost-back/
     
    mbk1969 likes this.

Share This Page