None of my games use Fullscreen Optimizations

Discussion in 'Operating Systems' started by DanielJG, Oct 15, 2021.

  1. DanielJG

    DanielJG New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    660ti
    For anyone that doesn't know Windows 10 should automatically run fullscreen games in a borderless windowed mode for faster ALT+TABing which they call Fullscreen Optimizations, but for some reason I've noticed that Windows has stopped running any of my games in this mode. I've tried Googling a solution but the only posts I can find are from people that hate this feature and want to disable it, but I would like the convenience of being able to ALT+TAB without my games crashing. Anyone know what the problem might be? Thanks.
     
  2. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,491
    Likes Received:
    9,205
    GPU:
    GF RTX 2070 Super
    Alt-Tabbing without fulscreen optimisations should not crush games though...

    There is another way to test it - adjust audio volume, and if you see the standard Windows indicator of audio volume (over the game window) then game is not running in old reliable exclusive fullscreen mode.
     
    Smough and fluidz like this.
  3. Mineria

    Mineria Ancient Guru

    Messages:
    4,989
    Likes Received:
    414
    GPU:
    Asus RTX 3080 Ti
    Think it depends on GameDVR, do you have it disabled via some tweak?
    It's fine to disable the bar and recording feature via the settings panel though.
    It might also depend on Windows Game Mode, got it enabled on my end.

    This registry entry enables FSO
    Code:
    Windows Registry Editor Version 5.00
    [HKEY_CURRENT_USER\System\GameConfigStore]
    "GameDVR_FSEBehavior"=dword:00000002
    

    2 = disabled
    0 = enabled

    While alt -tabbing doesn't crash games without FSO the games can loose keyboard and mouse input when doing so, RDR2 Vulkan as example.
     

Share This Page