No sound when using DTS

Discussion in 'The HTPC, HDTV & Ultra High Definition section' started by coldshot888, Jul 25, 2009.

  1. gamerk2

    gamerk2 Ancient Guru

    Messages:
    2,108
    Likes Received:
    1
    GPU:
    NVIDIA 570 GTX 1.2 GB
    Should be under 'sounds and audio devices' in the windows control panel.

    Never use 'Digital Output', as this was designed for uncompressed PCM audio and is limited to 2.0 sound. You keep the output as whatever the device you are using uses (EG, in Vista, this would be 'Speakers', and not 'Digital Output'), and set that device to use its digital output through its drivers.

    Still, if DD is getting through, there is no reason why DTS can't...
     
  2. Redemption80

    Redemption80 Ancient Guru

    Messages:
    18,495
    Likes Received:
    266
    GPU:
    GALAX 970/ASUS 970
    This is wrong, digital out or SPDIF is what is used to transmit Dolby Digital 5.1 and DTS 5.1 streams and PCM 2.0, its only limited to the bandwith of PCM 2.0 which is more than Dolby and the same as DTS is at 5/6.1.
     
  3. gamerk2

    gamerk2 Ancient Guru

    Messages:
    2,108
    Likes Received:
    1
    GPU:
    NVIDIA 570 GTX 1.2 GB
    ^^ Its the oposite; I have to use 'speakers' instead of 'digital output' to tranmit properly; I set to use the digital port via my soundcards drivers.

    The issue (as i understand it) is the way the new audio stack is handled in windows. According to what I've read, the 'digital output' setting was designed only to transmit 2.0 PCM, and not DD/DTS streams. (I've seen this before too; my moniter has a SPDIF output, but only 2.0 PCM works; DD/DTS streams become a garbled mess if i try to pass that). I'm guessing its a licensing thing to pass through DD/DTS or something of that sort. Hence, why I use 'Speakers', and not 'Digital Output' to pass through my data.

    Bascially, its Windows, not SPDIF.
     
  4. Redemption80

    Redemption80 Ancient Guru

    Messages:
    18,495
    Likes Received:
    266
    GPU:
    GALAX 970/ASUS 970
    Very strange, considering we have the same soundcard.

    For me, this is exactly how i have it set-up with the Beta Version 8.17.71 drivers in Windows7, but its the same in Vista too.

    S/PDIF Pass-through Device is set as default device, and default communication device, and the properties of it are set to Supported formats DTS Audio and Dolby Digital Checked, and sample rates 44.1/48/96khz checked, and in the advanced tab, i have "2 Channel, 24 bit, 96000hz (Studio Quality)" as the default format.
    Then in the Xonar D2 Audio Centre i have Audio Channel set to 6 Channels, Sample Rate as PCM 96 Khz, Analog Out set to 2 Speakers, and SPDIF Out set to PCM.

    This is for movies and music though, its very different for games if i decide to use DD:Live or DTS:Connect.

    But the above is the only way i can get bit perfect AC3 and DTS streams, so that i get DD:EX, DTS:ES. DTS 96/24 etc without any re-encoding
     

  5. gamerk2

    gamerk2 Ancient Guru

    Messages:
    2,108
    Likes Received:
    1
    GPU:
    NVIDIA 570 GTX 1.2 GB
    Odd...whatever then. I blame M$ for screwing with Directsound anyways :D

    Back on topic: If DD plays fine, I simply have no idea why DTS is being such a pain.
     
  6. coldshot888

    coldshot888 Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    ATI 4850
    Thanks man...let me go back and adjust my settings...can i find it under control panel?
     
  7. temp1abc

    temp1abc New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    x
    (came across this forum from google)
    Holy crap, I've been googling my head off trying to figure out how to set myriad settings to get my crap to work (various AC3/DTS/etc codec audio in VLC) and it WAS THIS! THIS ANSWER SOLVES ALL MY PROBLEMS.

    WHY IS THIS? GAAAH! What a stupid setup.

    Thank you for having posted this. Now my DTS:Connect works the way I'd expect it to.

    Silly me, thinking "SPDIF out" should be the default item out, I set that to default first thing after installing my new card. DDDUuuuuuuhhhh..

    Auzentech 7.1 Forte / w7x64

    I registered just to say Thank You, russ_tkd, for this post! :supercool
     
  8. RTS100x5

    RTS100x5 Member Guru

    Messages:
    121
    Likes Received:
    0
    GPU:
    ATI 5870 1GB w 54in Plsma
    Try reinstalling Auzentech drivers ..
     

Share This Page