No option for "Display Scaling"?

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by PeskyPotato, Dec 22, 2018.

  1. PeskyPotato

    PeskyPotato Member

    Messages:
    10
    Likes Received:
    1
    GPU:
    GTX 970 M
    I have an RTX 2080 with Windows 10 Home, 64-bit. I only have the option to use "GPU scaling" in my Nvidia Control Panel, and cannot seem to find a way to get "Display scaling" to pop-up.

    This is very frustrating for me, as I had always preferred display scaling in the past when using my previous set-up (GTX660 + Windows 7 Ultimate). I have the latest Nvidia drivers, but have also tried previous/older drivers as well... all have the same issue, no way to use display scaling.

    My monitor is the AW2518H (G-Sync/ULMB Capable), connected using a Display Port cable. When hooked up to the older setup with the GTX660 + Windows 7 Ultimate, there is the ability to use "Display Scaling" as expected & has always been normal... thus, I have ruled out the monitor being at fault here I believe.
    Note: I have turned off G-Sync & ULMB, and use regular refresh rate technology.

    That brings me to think it may be an issue with Windows 10, or the RTX 2080 specifically? However, I seem to have heard from multiple people that they are able to use Display Scaling on Windows 10 with various different Nvidia cards. This adds to my confusion then, as I'm not really able to understand why this option seems vacant for my current setup & leaves me wondering what I need to do in order to use display scaling again.


    Below I have attached an image of what the option screen looks like for me currently, using the new setup with the RTX2080 + Windows 10 Home + AW2518H (G-Sync/ULMB capable)
    Note: I have turned off G-Sync & ULMB, and use regular refresh rate technology.

    Link to the current option
    [​IMG]
     
  2. sapo_joe

    sapo_joe Master Guru

    Messages:
    601
    Likes Received:
    24
    GPU:
    ASUS RTX 3070 OC
    Is the 1920x1080 resolution the native on your display?? Have you tried other resolutions to see if that happens?
     
  3. PeskyPotato

    PeskyPotato Member

    Messages:
    10
    Likes Received:
    1
    GPU:
    GTX 970 M
    Yes, it is the native resolution. Changing resolutions doesn't change the issue at all, it's still the same sadly.
     
  4. The Goose

    The Goose Ancient Guru

    Messages:
    2,722
    Likes Received:
    182
    GPU:
    MSIrtx3070 gaming X
    Im guessing its your Display Port cable, have you tried dvi-hdmi or just an hdmi cable, I have windows 10 using 417.35 drivers on my Samsung tv on hdmi and i only have display as scaling option so that rules out Win10 and driver issue, perhaps your using an older version of dp cable.
     
    Last edited: Dec 23, 2018

  5. kurtextrem

    kurtextrem Master Guru

    Messages:
    244
    Likes Received:
    27
    GPU:
    NVIDIA GeForce GTX 970
    I thought some monitors simply don't have support for that
     
  6. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,313
    Likes Received:
    3,705
    GPU:
    GTX 1080ti
    Previously the Display scaling setting was exposed on screens whether they had hardware scaling or not, Windows 10 doesn't permit this any more.

    Gsync panels do not have a scaler.
     
  7. PeskyPotato

    PeskyPotato Member

    Messages:
    10
    Likes Received:
    1
    GPU:
    GTX 970 M
    I am not willing to test this, as I have no HDMI cable at the moment for one... and for two, the monitor can only run @ 60hz with HDMI cables. The display port (DP) cable allows you to use up to 240hz, which is a huge difference.

    I will say that using the "CRU utility" as directed in this post from another user, I was able to get the Nvidia Control Panel to allow me to select "Display Scaling" using the same monitor + DP cable on my new pc with Windows 10... however, for some reason I could only select 60hz for the refresh rate :(

    I tried to create a custom resolution of 240hz as he said in his post as well, but the screen just stays blank & does not allow that configuration to work, following the steps he had posted.

    So I ended up just resetting all of the settings to default in CRU, and am back to using 240hz with GPU Scaling sadly.


    Then how did the same monitor, using the same cable, on Windows 7 have Display Scaling?

    Even if as you say, the option would appear regardless of there BEING a scaler in the monitor... how would "Display Scaling" have worked on Windows 7 then? On Windows 7 with the same exact monitor + DP cable, the display scaling option had noticeably less input lag & made the graphics in-game look very different than how "GPU Scaling" appears.

    If what you said above in your post was the whole story and was accurate, then what would explain that?
     
  8. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,313
    Likes Received:
    3,705
    GPU:
    GTX 1080ti
    It didn't.

    The driver set GPU scaling regardless of your choice.

    Your feeling of lag is mind trickery.
     
  9. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,224
    Likes Received:
    180
    GPU:
    MSI RTX 2080
    In windows 7 at least. Display scaling does work last I checked. If you set display scaling and select a lower res, the display actually uses that resolution. Rather than still being fed a native res signal that is upscaled by the GPU.
    And rechecking this, it is still the case.

    Setting it to display will allow the display to handle the signal itself.

    Couldn't say about latency.
     
  10. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,313
    Likes Received:
    3,705
    GPU:
    GTX 1080ti
    That's not display scaling, that is the same as no scaling at all.

    Display and GPU scaling both imply the resolution will be scaled by either devices.
     

Share This Page