No Open GL for me Either

Discussion in 'Videocards - AMD Radeon Drivers Section' started by xteenagerebel, Dec 5, 2005.

  1. xteenagerebel

    xteenagerebel New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    AGP Radeon x850 Pro 256mb
    Just went from a NVidia 6600 to brand new x850 Pro and now I can't get Medal of Honor AA to play. I'm assuming from many of the other threads that this might have to do with Open GL? I'm gettting 5100 on my 3DMark and I'm playing BF2 on mostly high settings and it's absolutely wonderful. I was just hoping to leave MOHAA on my own terms, not because my awesome new card won't recognize it.

    I read all the other threads and have tried everything but reverting back to old drivers. I just don't think it's right that I get a new card and should have to install drivers from over a year ago to play an old game. I just wanted to weigh in and let ATI know that this is not an isolated issue for a few folks...seems like many are having the same issue with the 5.11. And the controversial 5.11b's didn't do a thing for me either. :frown:
     
  2. tweakboy

    tweakboy Banned

    Messages:
    798
    Likes Received:
    0
    GPU:
    ASUS AX800XTPE@550/1215Mhz
    I feel your pain brother teengerbel.

    ATI has been a joke in drivers always. My dads old ATI all in wonder 1st generation had huge driver issues, corrupt 2D screen; some drivers made it happen less, some it happened more. Then I had a old ATI TV card, and same ****. I couldn't even use their own program to view TV, I had to get Dscaler lol. From what I have seen soo far, ATI boards now adays are rock solid, it's just that their drivers are always suspect....
     
  3. Seketh

    Seketh Ancient Guru

    Messages:
    1,904
    Likes Received:
    6
    GPU:
    RX 580 8GB
    Try to use the new omegas. If it doesn't work, contact ATI support. They'll only fix it if there's enough complaints.
     
  4. xteenagerebel

    xteenagerebel New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    AGP Radeon x850 Pro 256mb
    Sorry - kind of new to this stuff. I've always been a plug n play guy and spent more time fiddling with software than hardware. But this world of tweaking and overclocking is starting to suck me in.

    I've seen those aftermarket drivers and was kind of wondering about them. Is Omega "the one" to use? Do most folks bypass the official ATI drivers?
     

  5. mildew

    mildew Member Guru

    Messages:
    127
    Likes Received:
    0
    GPU:
    Triplex 9800pro
    i dunno if this is relevant, but the default ati drivers built into xp work fine with d3d but do not support ogl.

    im running 5.11's and dont have any opengl games installed at the mo to test on, but anandtech has a 5.11 vs 5.12 comparision that includes quake4, so clearly ati have not dropped ogl support!

    m
     
    Last edited: Dec 6, 2005
  6. OldMX

    OldMX Member

    Messages:
    46
    Likes Received:
    3
    GPU:
    PNY GTX 1660
    Windows included driver for nvidia / ati has no opengl support end of story.

    CAtalyst 5.11 opengl works flawless, if you dont get proper support you messed something while on the installation, get driver cleaner to get rid of old .dlls and registry entries and reinstall a fresh copy of the drivers.

    oldmx
     
  7. tweakboy

    tweakboy Banned

    Messages:
    798
    Likes Received:
    0
    GPU:
    ASUS AX800XTPE@550/1215Mhz
    Hilarous my neighboor down the stree, is returning his Sapphire x850 XT. 520core 540memory. Cuz openGL runs like crapola for him, like Im talking Quake 4 and HL Source @ 105fps. Anyhow I helped him out a lot, and we tried safe mode and normal mode both; driver cleaner . cat uninstall utitily from ATI. To no avail of any version of OpenGL running good for him. Im talking his old 5600 is faster @ HL1 then this is. Anyhow hes gonna send it back to newegg in exhance for a nvidia 6800gt agp.

    How odd that two neighboors are having OpenGL problems, major ones @ that. Well I used to say, Dell Dell Go to Hell,,, Now I will say ATI ATI a dagger between the Eyes,,,,

    Brothers whoever reads this and is thinking about getting ATI, simply DONT! get nvidia.... and help yourself,,, Thank you
     
  8. xteenagerebel

    xteenagerebel New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    AGP Radeon x850 Pro 256mb
    What version drivers did you try Tweakboy? At least that can help me rule out what not to try. I've only tried the 5.11's so far...been having too much fun playing BF2 with all settings high to really miss my MOHAA game. But we've got some recruits in my clan that are going to have their tryouts soon and I'm going to need to be there...

    Wierd, I noticed you said your neighbor had an x850 XT also. So I wonder if it's the actual card or the drivers, because mine is an x850 Pro. My hunch is that it's definitely the drivers.
     
  9. tweakboy

    tweakboy Banned

    Messages:
    798
    Likes Received:
    0
    GPU:
    ASUS AX800XTPE@550/1215Mhz
    Everyone having OpenGL problems with 5.11, please download the 5.12 beta just posted here a day ago. Now I have openGL again, everything is running smooth too........ :)
     
  10. xteenagerebel

    xteenagerebel New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    AGP Radeon x850 Pro 256mb
    That's Gold Jerry, Gold!

    Thanks Tweakboy, if you didn't have so many posts, I probably wouldn't have tried it, but I gave it a shot and just got finished playing MOHAA and then went and played BF2 to make sure that worked also.

    One point I'd like to make though is that the new drivers come with Control Panel rather than Catalyst Control Center. So I'm really not sure if it's the new drivers or the fact that I ditched CCC. But regardless...I'm now a happy camper!

    Woohoo!
     

Share This Page