No Man's Sky (Procedural, open world space-sim)

Discussion in 'Games, Gaming & Game-demos' started by harkinsteven, Dec 9, 2013.

  1. Reddoguk

    Reddoguk Ancient Guru

    Messages:
    2,123
    Likes Received:
    265
    GPU:
    RTX3090 GB GamingOC
    For my system i expected more out of NMS Prisms. I have tried both Vulkan and DirectX and to be honest the game runs poorly. Only time i get good fps is when i go undergound. Even @ 1440p it can kick my systems arse and fps tanks sometimes down to below 60 fps and i haven't even got the game cranked up to max settings.
     
  2. Grimbarian

    Grimbarian Ancient Guru

    Messages:
    1,760
    Likes Received:
    366
    GPU:
    AMD RX5700 8gb
    How did you try it in Directx? I thought Vulkan was forced since they added it?
     
  3. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    9,162
    Likes Received:
    3,121
    GPU:
    ASUS RX 470 Strix
    I'm confused by that too, the game was built originally with OpenGL, Hello Games then updated it to run Vulkan to get better performance.
     
  4. Zenoth

    Zenoth Maha Guru

    Messages:
    1,220
    Likes Received:
    192
    GPU:
    MSI GTX 1080
    Something is not right. Are you using mods? Have you tried to uninstall / reinstall and tried a completely new game (away from a previous saved game from a previous version that would have been saved with mods in it)?

    I've tried this Prisms update last night, from scratch (new game, no mods) and I'm running the game at 1440p, Ultra settings just fine on my GTX 1080 (non-Ti). I get an average of about 50 fps, it rarely goes below 40 even in slow downs (and they're not frequent), and I get up to 60 fps in interiors (space stations, settlements, underground / caverns, etc). If your performance is tanking with the best video card currently available on this planet while running this game at 2K resolution... you should call Houston, because you have a problem.

    Do a clean reinstall, no mods. Then try in Normal mode, entirely new game, that would be your first step to see what's going on. Update your drivers (or reinstall them), etc.

    Now, side note about the Prisms update, it makes the game look considerably better in general; especially the volumetric light, that one helps a TON to improve the atmosphere when exploring on foot. There's some genuinely impressive scenery moments now, more than ever before.
     
    Skinner and Grimbarian like this.

  5. Repo Man

    Repo Man Ancient Guru

    Messages:
    2,573
    Likes Received:
    374
    GPU:
    RTX 2060
    I tried it briefly this morning and had similar results at 1080p with my 2060. Tried dropping some settings but didn't seem to make a lot of difference as fps stayed around 70-80 which is ok I suppose but DLSS didn't seem to bring much to the party except maybe better overall AA when set to quality. Also I really couldn't see all that much change in the graphics in this new update so perhaps I need to either start a new save or just reinstall the game and start a new save as suggested above.

    My main issue with the game continues to be the super narrow FOV ( even at max ) and things like camera shake that can't be turned off, both are things that really exacerbate my motion sickness. I know you can change the FOV to an even higher value from the config file but in 2021 this shouldn't be needed.
     
  6. Reddoguk

    Reddoguk Ancient Guru

    Messages:
    2,123
    Likes Received:
    265
    GPU:
    RTX3090 GB GamingOC
    No i haven't used a single mod ever. I only just installed the game on a new system. My save was stored through the cloud. Last night i tried to mess about with the settings and DirectX is available for me in the settings so i switched from Vulkan to it to see if the performance is any better. It was not better. Soon as i go underground i get 240 fps but on the surface my fps is anywhere between 120 and 40 fps. When it goes low fps it starts acting badly like i see gaps in the map terrain and i start getting slight freezes.

    Maybe the settings file was also saved with the cloud and last time i played the game was on a 980 maxwell card. Either way the game runs like dog crap for me atm.

    Something wrong with the game thats for sure. After messing with the settings last night i'm now getting huge plants in my buildings growing through the floors. When i go into the small bases with a landing pad on this planet then the plants are everywhere inside the building coming from underneath.

    My fov settings is 90 and 100 for my ships which is what i set last time i played on my old system. So the settings.ini has probably been saved from before and also uploaded from my cloud saves.

    Maybe i should somehow delete the settings file and get a new one if that's possible. I hate games which don't have an auto-detect system/gfx card recognition or some that do but do it poorly.
     
    Last edited: Jun 5, 2021
  7. Zenoth

    Zenoth Maha Guru

    Messages:
    1,220
    Likes Received:
    192
    GPU:
    MSI GTX 1080
    There's a mod that disables camera shake effects (and it's compatible with the Prisms update): https://www.nexusmods.com/nomanssky/mods/1967

    Remember to rename the " DISABLEMODS " .txt file located in GAMEDATA > PCBANKS folder, to " ENABLEMODS ", then save it (without the quotes).
     
    Repo Man likes this.
  8. Repo Man

    Repo Man Ancient Guru

    Messages:
    2,573
    Likes Received:
    374
    GPU:
    RTX 2060
    Thanks, I might give that a go. I increased the FOV to 135 last night and it made the game immediately 200% more tolerable!
     
  9. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    9,162
    Likes Received:
    3,121
    GPU:
    ASUS RX 470 Strix
    Last edited: Jun 10, 2021

Share This Page