No Direct x 11 Direct compute tesselation 9.12

Discussion in 'Videocards - AMD Radeon Drivers Section' started by olapaulakoski, Dec 21, 2009.

  1. Memorian

    Memorian Ancient Guru

    Messages:
    3,654
    Likes Received:
    587
    GPU:
    RTX 4090
    Tomorrow i'm getting my HD5870 hope everything will be fine with cat 9.12 :)
     
  2. lorikano

    lorikano Master Guru

    Messages:
    323
    Likes Received:
    0
    GPU:
    2x Sapphire 7950@1150
    BTW there's this tool from AMD called Ladybug that demonstrates Ati 5870 now the culprit if you ask me seems to be W7 coz if I try to install this tool it fails with message "Windows 7 is required for installation" .I am gonna have to say ati screwed big time with 9.12
     
  3. China Mark

    China Mark Member Guru

    Messages:
    101
    Likes Received:
    0
    GPU:
    XFX 5870 1GB (1040/1275)
    Are you running an RC version of Win 7 because that Ladybug demo and the other Mecha only work on the full retail versions? It's something to do with them being .msi files.
     
  4. Yadda

    Yadda Active Member

    Messages:
    64
    Likes Received:
    0
    GPU:
    GTX 780 @ 1200/6400
    Ladybug won't launch for me either, using the 7600 rtm build Windows 7 Home Premium, Asus 5770, cat 9.12 hotfix.

    So for me, no tessellation in Heaven using 9.11, 9.12 or 9.12 hotfix drivers (except for right after I installed the driver, tessellation worked until I rebooted), and no Ladybug demo (although I didn't test it with 9.11 & 9.12 I have no reason to think the result would be any different to the 9.12 hotfix).

    Here's what I get when I try to run the Ladybug demo...

    [​IMG]
     
    Last edited: Jan 5, 2010

  5. pjokerxp

    pjokerxp Banned

    Messages:
    652
    Likes Received:
    0
    GPU:
    Palit GeForce GTX 680 2GB
    AMD called Ladybug is working for me in Win Vista 64
    with 9.12 hotfix and stream...
     
  6. FastZ28

    FastZ28 Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    Tri-Fire (4870/4870/4850)
    Yeah, release notes (cat 9.12hot with stream sdk) say DX compute avail on 48xx, and on those, it does work fine.

    tbh, with 4670 (if not ddr2 gimped) best you can probably hope is video transcoding, as 4000 was hardware improved for this (but they've kinda been promising this for years so)

    You got more shaders/better gfx ram, but my htpc ddr2 4350 has OpenCL quite slower than most avg CPUs, not terribly useful currently. 96 Gflops, uh, looks good on the reviews/box tho...
     
  7. x2percentmilk

    x2percentmilk New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ASUS HD 5850 OCed
    having trouble

    i have the hotfix, legit copy of windows 7 64, and an asus radeon hd5850 with the latest ati drivers. the only way i get directx 11 to work is if i reinstall the ati drivers, then DONT restart. every time i power my computer on i need to do this.

    and, unlike microsoft says, its not just a reporting error. Heaven does not allow tesselation without this, and dirt2's directx 11 features do not work (however, after reinstallation of the drivers they both do)

    im assuming its them and not me...correct?
     
  8. Bullu$

    Bullu$ Master Guru

    Messages:
    410
    Likes Received:
    0
    GPU:
    R290X CFX@1050/1350
    Try to update your chipsetdrivers
     
  9. kyrill

    kyrill New Member

    Messages:
    4
    Likes Received:
    0
    i wish you were right..
    I have all the above problems with.. windows 7 ultimate 64 (build 7600) bought as a silver disc, a true retail version
     
    Last edited: Jan 8, 2010
  10. kyrill

    kyrill New Member

    Messages:
    4
    Likes Received:
    0
    ok i dont care how my dx 11 is reported in dxdiag.exe as long as dx11 wordk
    i have followed all uninstall advice to no avail incl driversweeper and regsweeper
    BUT :) finally heaven showed me after 1,1/2 day frustration the dx11 tesselations
    i did install windows 7 again clean install and the 9.12 hotfix even no SDK and it worked after rebooting
    now i wil install my regular prgs
    ======================================
    Ah well, i have what others have mentioned as well
    even when dx 11 works its is broken after the next restart of windows
    you can unistall heaven, and the display driver again, reboor, reinstall cata 12 hotfix, reboot, install heaven and voila dx11 is back as long as the computer does not restart.

    this must be the fault of the Ati driver as its also breaks the DX11 connection in Dirt 2 and the benchmark of the Stalker benchmark
     
    Last edited: Jan 9, 2010

  11. Yadda

    Yadda Active Member

    Messages:
    64
    Likes Received:
    0
    GPU:
    GTX 780 @ 1200/6400
    As Joebear55 has posted one cause and offered a solution on another thread, I thought I'd update this one with the info incase anyone missed his thread.

    Basically, he identified the cause of the problem to be the Asus Smartdoctor and/or Asus GamerOSD software, or more specifically, older versions of the software. I can also verify that since removing Smartdoctor and GamerOSD (I now solely use MSI's Afterburner software) and then removing and re-installing my Catalyst drivers (and also reinstalling Heaven), DX11 is now working as it should in the Heaven benchmark and in the Call of Pripyat benchmark the option now appears to select DX11. Also both Ladybug and Mecha DX11 demos run now whereas previously they wouldn't start. Also, now DX11 still works after a reboot whereas previously it would only work immediately after installing the graphics driver but would fail to work after rebooting.

    So, if anyone is having and Directcompute/DX11 problems and is also running Asus Smartdoctor and/or GamerOSD software, I recommend you try this approach first.
     
    Last edited: Jan 24, 2010

Share This Page