New Xonar DX drivers

Discussion in 'Soundcards, Speakers HiFI & File formats' started by spdracer, Jun 16, 2010.

  1. NiukNiuk

    NiukNiuk Ancient Guru

    Messages:
    2,057
    Likes Received:
    0
    GPU:
    MSI R6950 twin frozr II
    Well I've modded them for my card, D2, like the previous ones I posted.
    I may try to mod them for the D2x

    edit: for the d2x, try the modded ones posted by jonasbeckman
     
    Last edited: Jul 2, 2010
  2. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,562
    Likes Received:
    2,958
    GPU:
    MSI 6800 "Ref"
    That package just to explain further is all the INF files (And background logo during installation.) compared via Winmerge and then copy/pasted between D2X .77 and Xense .88 (Version number might be inaccurate.)

    This alters the name of the card, name shown when installed (Not the uninstall name in program view or control panel icon however.) and removes all unused devices (Both xense and d2x core INF are included but identical after comparison.)

    (Such as the front panel like stuff being gone from the D2X as it's unused or rather doesn't exist plus any typos of which there are a few like Converted are fixed and now say Converter as fixed in .80 and these .88 drivers plus other stuff.)

    (Easy to use Winmerge or similar to compare the files with the original unmodified ones beforehand, Vista and W7 allows copy of files without overwriting so (2).inf in name which helps with comparison before deciding to overwrite should you want to.)

    They work quite well and the above sound panel "flap" not correctly removing after startup is also fixed.
    (Aside from starting the control panel and then hiding it again leaving it in the tray menu and correctly hidden as needed via previous drivers or using other EXE file for it.)
     
  3. NiukNiuk

    NiukNiuk Ancient Guru

    Messages:
    2,057
    Likes Received:
    0
    GPU:
    MSI R6950 twin frozr II
    Last edited: Jul 3, 2010
  4. TziMmys

    TziMmys Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    nVidia /gtx260 / 896 MB
    I download the xense drivers and replaced the original files with the modded ones JonasBeckman gave. But yours NiukNiuk are a bit different. Yours have a folder "MCE". Witch ones should I use? Sorry if I get you tired.
     

  5. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,562
    Likes Received:
    2,958
    GPU:
    MSI 6800 "Ref"
    Ah right I forgot about that, MCE wasn't part of the Xense drivers but are part of the D2X ones, I think it's part of Media Center for Windows but I don't think it'll be installed even though the folder is present due to information differences in Setup.exe and the installer though I don't know what it's function is either.
    (My archive is only 170 or so KB and only includes the modified files, rest is provided from the Xense driver package itself, also while on it you can remove the OpenAL and Windows Update archives in the driver, I recommend the latest official OpenAL release from Creative instead which is a newer build and you probably already have that update installed.)
     
  6. NiukNiuk

    NiukNiuk Ancient Guru

    Messages:
    2,057
    Likes Received:
    0
    GPU:
    MSI R6950 twin frozr II
    TziMmys, I've also made a modded version of these Xense 1788 drivers for the D2X:
    http://www.multiupload.com/RGOYUZAWMO
    (I put the latest openal in the archive)
    So grab these ones or try the ones from JonasBeckman :)
     
  7. TziMmys

    TziMmys Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    nVidia /gtx260 / 896 MB
    Thanks man. I have already JonasBeckman, but I cant get 5.1 worked. Its probably because I had the prlude and there are left over drivers. Perhaps I should format my pc. :(
     
  8. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,562
    Likes Received:
    2,958
    GPU:
    MSI 6800 "Ref"
    The Xonar drivers usually works better if uninstalled first and then reinstalling the latest version, this might have improved over the initial couple of drivers however and maybe you've already installed them like that. :)
    (Uninstalling cleans out everything I think, drivers are rather lightweight though to begin with.)
     
  9. gold_heart007

    gold_heart007 Master Guru

    Messages:
    443
    Likes Received:
    0
    GPU:
    MSI GTX N560Ti TwinFrozr2
    Nice!
    Thanx for the drivers update. :)
     
  10. TziMmys

    TziMmys Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    nVidia /gtx260 / 896 MB
    NOTHING. I am going crazy. I have all day trying to make 5.1 works with no luck. I have tried ALL of your drivers, nothing. I have download from asus both new and olds, nothing. I have format my pc and cloned my fresh copy without drivers installed, so I can try a new driver and if not working return to fresh install and not simply unistall, NO GO!!! :bang:

    PLEASE, can anyone confirm that this card works on 5.1 mode on windows 7 64 bit? And if anyone has any suggestion, please give it.

    Thnak you a lot.
     

  11. Svein_Skogen

    Svein_Skogen Maha Guru

    Messages:
    1,230
    Likes Received:
    0
    GPU:
    2x GTX570, ASUS+eVGA
    5.1 output via the card's build in DAC, or via digital cable to receiver/amp?

    //Svein
     
  12. TziMmys

    TziMmys Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    nVidia /gtx260 / 896 MB
    I want to get 5.1 output via the card's build in DAC, but neither way works. To your answer, via the card's build in DAC.
     
  13. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,562
    Likes Received:
    2,958
    GPU:
    MSI 6800 "Ref"
    The "Audio Channels" bar in the Xonar control panel which goes between 2, 4, 6 and 8 affects speaker configuration, for example set it to 2 and then check the control panel and configure the speaker unit and it'll say stereo, set it to 4 and it'll say quad and 6 would be 5.1 with 8 being 7.1

    Sample rate seems best to set via the control panel as well and then adjusting it via the Xonar panel, the output should probably be 5.1 as well although seems to only be for analogue connections.

    GX mode shouldn't be needed for it to work either but might be worth trying depending on what you want to use 5.1 or similar with.

    Can't help with cable configuration and other problems that might cause this though it seems driver related, card is probably fully functional.
    (There might be some easier way to test this.)

    Also based on discussions on the Asus forums if your card is above the specs of what the Xense is capable of these 1788 drivers might not be optimal/ideal for some advanced features due to their configuration though this might be adjustable.
    (Somewhat difficult for me to explain this properly and I'm not very good on these sorts of things in general though I'm trying to improve and learn more.)
     
  14. TziMmys

    TziMmys Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    nVidia /gtx260 / 896 MB
    Nothing at all. Any ideas would be appreciated. I have also emailed asus, but I dont expect a lot.
     
  15. Svein_Skogen

    Svein_Skogen Maha Guru

    Messages:
    1,230
    Likes Received:
    0
    GPU:
    2x GTX570, ASUS+eVGA
    I'm running 5.1 output (via card's DACs) with these drivers on my D2/PM, without as much as a hiccup.

    //Svein
     

  16. TziMmys

    TziMmys Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    nVidia /gtx260 / 896 MB
    I dont know what to say... :(
     
  17. deepcover

    deepcover New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI 5870 1 gig
    Thank you for this. My D2X stopped being recognized on my new P6x58D-E. I really have no idea why. It had symptoms like a corrupt eeprom or registry. I was about to reformat until I came across this thread. After istalling your modified Xense drivers, everything works great that I can tell. Full 5.1 and it sounds awesome. Why can't Asus support the older cards?
     
  18. NiukNiuk

    NiukNiuk Ancient Guru

    Messages:
    2,057
    Likes Received:
    0
    GPU:
    MSI R6950 twin frozr II
    You're welcome :)
     
  19. Svein_Skogen

    Svein_Skogen Maha Guru

    Messages:
    1,230
    Likes Received:
    0
    GPU:
    2x GTX570, ASUS+eVGA
    I'm not sure, but I think the correct translation is:
    //Svein
     
  20. Markvm

    Markvm New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    XFX ATI Radeon HD4650 1GB
    Hi there,

    Are there also any modified drivers available for the Xonar D2 on WinXP (32 bit)? Because from what I read this topic is all about Windows 7.
     

Share This Page