New Vista Driver

Discussion in 'Videocards - AMD Radeon Drivers Section' started by clawhamer, Dec 16, 2006.

  1. clawhamer

    clawhamer Ancient Guru

    Messages:
    2,576
    Likes Received:
    0
    GPU:
    EVGA 780 Classified
  2. MaxBlade

    MaxBlade Master Guru

    Messages:
    895
    Likes Received:
    11
    GPU:
    980Ti/970/390/+ more
    Already been said. But thanks
     
  3. Daemon785

    Daemon785 Master Guru

    Messages:
    329
    Likes Received:
    0
    GPU:
    Diamond HD 5870
    after i removed teh warcat vista drivers and tried to put these on (thinking they may be a LITTLE more stable) i cant get the CCC to install. it says its already installed when i try to check it in the installer. also, it doenst seem to find the secondary video drvier for my second monitor. any thoughts as how to fix this?
     
  4. simnov

    simnov Member

    Messages:
    21
    Likes Received:
    0
    cool works perfect much better than xp no black screen
     

  5. clawhamer

    clawhamer Ancient Guru

    Messages:
    2,576
    Likes Received:
    0
    GPU:
    EVGA 780 Classified

    Try uninstalling all ATi related entries from within Add/Remove Programs. Unplug your internet connection, and restart the computer. Before you install the drivers, remove the ATI directory from C:\ and C:\Program Files\ATI (or any entry made by the warcat drivers).

    Just a side note, before I reinstall drivers; I run DriverCleaner in Safe Mode (this version is compatible with Vista http://www.drivercleaner.net/index.php). I also run CCleaner after DriverCleaner; then after every thing is cleaned out I boot back into normal mode and install the new driver. Maybe not necessary steps, but I never have a problem changing drivers.
     
  6. Daemon785

    Daemon785 Master Guru

    Messages:
    329
    Likes Received:
    0
    GPU:
    Diamond HD 5870
    i fixed it. i just used the ati install manager. it took care of it. tho add/remove still has the ccc listed, its off. but i found taht the ccc was actually causeing my system to lock up after awhile. so i just put on the drivers. now to wait for ati tray tools vista :D
     
  7. Intelman

    Intelman Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Saphire 4870 512MB
    How is the performance with these latest drivers. I seem to be able to play Rainbow 6 Vegas alright, even though the game isn't well optimized. How many frames am I loosing in Vista, if any :p
     
  8. Daemon785

    Daemon785 Master Guru

    Messages:
    329
    Likes Received:
    0
    GPU:
    Diamond HD 5870
    fantastic. at least for me. my games have never gone faster. granted, no opengl games yet till official vista drivers, but my other games blaze now. FEAR and Serious Sam 2 fly. tho for some reason C&C Generals is a bit slower. oblivion also suffers a lil and no aa+hdr yet but oh well. no going back to xp now :D
     
  9. Intelman

    Intelman Active Member

    Messages:
    53
    Likes Received:
    0
    GPU:
    Saphire 4870 512MB
    Yeah, it is very hard to go back to XP, when Vista offers so many new features and plus it looks much better. My only concern was game performance. I mainly play Battlefield 2 Rainbow 6 Lockdown and Vegas, and FEAR, which plays much better now with the new drivers. Saddly though, the sound in Lockdown is kinda screwy for me, anyone else have that issue?
     
  10. Hansho

    Hansho New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    ATI Radeon X1900XTX 512M
    Can't run quake4 or other OpenGl games.:mad4:
    Can't run Farcry1.4 with HDR.both +AA or no AA:mad4:
     

Share This Page