New vBIOS for Sapphire R9 290X Tri-X OC 4GB GDDR5 (Hynix) UEFI

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Jackalito, Jul 9, 2015.

  1. Jackalito

    Jackalito Master Guru

    Messages:
    575
    Likes Received:
    96
    GPU:
    Radeon RX 5700 XT
    Hi everyone,

    I hope it's not against the rules of the forums to share a new official vBIOS for my graphics card, the Sapphire R9 290X Tri-X OC 4GB GDDR5 (Hynix) UEFI. The new version is 015.046.000.000 and it's far newer than the one my card had from factory, which was 015.042.000.000.

    Here you'll find the UEFI and non-UEFI vBIOSes. Enjoy!

    https://mega.co.nz/#F!39EjhJKI!74YeO9Km2h_HF35zHvXZRg

    [​IMG]


    Cheers! :)
     
    Last edited: Jul 9, 2015
  2. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    Submit it to TechpowerUp, please.
     
  3. Jackalito

    Jackalito Master Guru

    Messages:
    575
    Likes Received:
    96
    GPU:
    Radeon RX 5700 XT
    That's what I'm trying to do. I've registered there. Could you please tell me how I must proceed in order to upload the vBIOS there?

    Thanks! :)

    EDIT: If it's through the GPU-Z tool, I've already submitted them. So now I guess I just have to wait for them to get approved ;)
     
    Last edited: Jul 9, 2015
  4. DDSZ

    DDSZ Member

    Messages:
    46
    Likes Received:
    0
    GPU:
    Gigabyte R9 290 unlocked
    Link is wrong
     

  5. MojoW

    MojoW Member Guru

    Messages:
    173
    Likes Received:
    0
    GPU:
    Gigabyte 1080 G1 Gaming
    This
     
  6. Jackalito

    Jackalito Master Guru

    Messages:
    575
    Likes Received:
    96
    GPU:
    Radeon RX 5700 XT
  7. MojoW

    MojoW Member Guru

    Messages:
    173
    Likes Received:
    0
    GPU:
    Gigabyte 1080 G1 Gaming
  8. Jackalito

    Jackalito Master Guru

    Messages:
    575
    Likes Received:
    96
    GPU:
    Radeon RX 5700 XT
    Those are the files Sapphire provided to me. I have successfully flashed both of them and they're working as expected. I'm only using the UEFI one, though.

    I'm no expert on the matter, so maybe someone else can shed light on the matter.

    Cheers!
     
  9. Mooby29

    Mooby29 Member Guru

    Messages:
    134
    Likes Received:
    0
    GPU:
    R9 290X@1150/1500mhz
    Can't load those files in HD7xxx Series UEFI Patch Tool BETA. It says "BIOS length doesn't match !"
     
  10. streakpt

    streakpt Master Guru

    Messages:
    277
    Likes Received:
    0
    GPU:
    Sapphire 290 Crossfire
    Does this work on the 290 model?
     

  11. Mooby29

    Mooby29 Member Guru

    Messages:
    134
    Likes Received:
    0
    GPU:
    R9 290X@1150/1500mhz
    Edited the UEFI one (1050/1350, 90% max temp, 65% max fan) and flashed it on my Sapphire R9 290X BF4 Edition (reference board). Works the way it should. Thanks for this bios !
    [​IMG]
     
    Last edited: Jul 9, 2015
  12. Tweaky81

    Tweaky81 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    XFX Fury TD
    Tri-x is based on the reference design so it should work on all reference boards.
     
  13. DDSZ

    DDSZ Member

    Messages:
    46
    Likes Received:
    0
    GPU:
    Gigabyte R9 290 unlocked
    Elpida is supported too. Theres also +25mV by default.
     
  14. Almi

    Almi New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    R9 290x Tri-X 8GB Oc
    It will be work with 8 Gb version ?
     
  15. Jackalito

    Jackalito Master Guru

    Messages:
    575
    Likes Received:
    96
    GPU:
    Radeon RX 5700 XT
    I honestly don't know. I guess your card also has 2 vBIOSes, so you can always check for yourself safely ;)
     

  16. b0uncyfr0

    b0uncyfr0 Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    Gaming XXX 1070
    Uhhh...I've got a vapor-x 8Gb with 015.048.000.016.00000 BIOS. Isn't that newer..?
     
  17. Jackalito

    Jackalito Master Guru

    Messages:
    575
    Likes Received:
    96
    GPU:
    Radeon RX 5700 XT
    I guess it is, but for example it may not work for my card. I tried in the past a newer vBIOS from a Vapor-X 4GB and only gave me a black screen.

    You could always share it in another thread if you feel like it ;)
     
  18. gupsterg

    gupsterg Member Guru

    Messages:
    177
    Likes Received:
    3
    GPU:
    RX VEGA 64
    Flashing a Vapor-X 290 bios to my Tri-X 290 would also result in black screen. I think it's due to Vapor-X is custom PCB.

    Thanks for share Jackalito , glad the ticket worked ;) .

    TechpowerUp database is great resource IIRC only W1zzard checks/approves and adds roms to database. Also at times you can find a UEFI rom and not the matching nonUEFI and vice versa. Even on TPU forum members share roms as it can be quicker method.

    For some reason the UEFI roms from Sapphire are all like this, I have noticed this on several roms I have of theirs. Once flashed and dumped they are 128kb, the padding/empty data area at the end of UEFI increases.

    Only curious, may I ask why your loading it in that program?
     
    Last edited: Jul 11, 2015
  19. Mooby29

    Mooby29 Member Guru

    Messages:
    134
    Likes Received:
    0
    GPU:
    R9 290X@1150/1500mhz
    To fix the checksum after I edited them, but I found a workaround so that's ok.
     
  20. WarDocsRevenge

    WarDocsRevenge Master Guru

    Messages:
    294
    Likes Received:
    0
    GPU:
    Fury-x Crossfire
    Good bios thanks glad it was in the driver section where i could see it
     

Share This Page